package ldm-server (not installed) failed to install/upgrade: trying to overwrite '/usr/sbin/ldminfod', which is also in package ltsp-server 0:5.0.40~bzr20080212-0ubuntu7

Bug #525619 reported by Mario Limonciello on 2010-02-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ldm (Ubuntu)
Medium
Stéphane Graber
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: ldm

during a hardy -> lucid upgrade

ProblemType: Package
Architecture: amd64
Date: Mon Feb 22 01:20:14 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: trying to overwrite '/usr/sbin/ldminfod', which is also in package ltsp-server 0:5.0.40~bzr20080212-0ubuntu7
Package: ldm-server (not installed)
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: ldm
Title: package ldm-server (not installed) failed to install/upgrade: trying to overwrite '/usr/sbin/ldminfod', which is also in package ltsp-server 0:5.0.40~bzr20080212-0ubuntu7
Uname: Linux 2.6.32-14-generic x86_64

Related branches

Mario Limonciello (superm1) wrote :
Stéphane Graber (stgraber) wrote :

Sorry for the delay, I only noticed this bug now.

I'll have a look soon and will probably upload an SRU to lucid fixing the hardy => lucid upgrade path.

Thanks

Changed in ldm (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
importance: Undecided → Medium
status: New → Triaged
Stéphane Graber (stgraber) wrote :

Fix uploaded to -proposed, should be ready for testing in a few days.

Changed in ldm (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Does that only affect upgrades to lucid? Or from lucid onwards as well? In the latter case, this needs to be fixed in oneiric as well.

Changed in ldm (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed

Hello Mario, or anyone else affected,

Accepted ldm into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Stéphane Graber (stgraber) wrote :

Only < jaunty upgrading to >= lucid. So based on what's currently supported, it's just a problem for people upgrading from hardy to lucid.

Stéphane Graber (stgraber) wrote :
Download full text (3.5 KiB)

Ok, just did a few tests with a clean hardy chroot.

Without lucid-proposed, asking apt to install ldm-server and upgrade ltsp-server:
root@vagonbrei:/# apt-get install ldm-server ltsp-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libedit2 openssh-client
Use 'apt-get autoremove' to remove them.
Suggested packages:
  dhcp3-server sdm audiooss nfs-kernel-server
Recommended packages:
  xterm openssh-server ssh ltspfs
The following NEW packages will be installed:
  ldm-server
The following packages will be upgraded:
  ltsp-server
1 upgraded, 1 newly installed, 0 to remove and 161 not upgraded.
Need to get 123kB of archives.
After this operation, 586kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com lucid/main ldm-server 2:2.1.1-0ubuntu2 [12.6kB]
Get:2 http://archive.ubuntu.com lucid/main ltsp-server 5.2.1-0ubuntu9 [110kB]
Fetched 123kB in 0s (271kB/s)
Preconfiguring packages ...
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package ldm-server.
(Reading database ... 9408 files and directories currently installed.)
Unpacking ldm-server (from .../ldm-server_2%3a2.1.1-0ubuntu2_all.deb) ...
dpkg: error processing /var/cache/apt/archives/ldm-server_2%3a2.1.1-0ubuntu2_all.deb (--unpack):
 trying to overwrite `/usr/sbin/ldminfod', which is also in package ltsp-server
Preparing to replace ltsp-server 5.0.40~bzr20080212-0ubuntu7 (using .../ltsp-server_5.2.1-0ubuntu9_all.deb) ...
Unpacking replacement ltsp-server ...
Errors were encountered while processing:
 /var/cache/apt/archives/ldm-server_2%3a2.1.1-0ubuntu2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

With lucid-proposed, asking apt to install ldm-server and upgrade ltsp-server:
root@vagonbrei:/# apt-get install ldm-server ltsp-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libedit2 openssh-client
Use 'apt-get autoremove' to remove them.
Suggested packages:
  dhcp3-server sdm audiooss nfs-kernel-server
Recommended packages:
  xterm openssh-server ssh ltspfs
The following NEW packages will be installed:
  ldm-server
The following packages will be upgraded:
  ltsp-server
1 upgraded, 1 newly installed, 0 to remove and 161 not upgraded.
Need to get 123kB of archives.
After this operation, 586kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com lucid/main ltsp-server 5.2.1-0ubuntu9 [110kB]
Get:2 http://archive.ubuntu.com lucid-proposed/main ldm-server 2:2.1.1-0ubuntu2.1 [12.7kB]
Fetched 123kB in 0s (335kB/s)
Preconfiguring packages ...
Can not write log, openpty() failed (/dev/pts not mounted?)
(Reading database ... 9408 files and directories currently installed.)
Preparing to replace ltsp-server 5.0.40~bzr20080212-0ubuntu7 (using .../ltsp-server_5.2.1-0ubuntu9_all.deb) ...
Unpacking replacement ltsp-server ...
Selecting previously deselected package ldm-server.
Unpacking ldm-server (from .../ldm-server_2%3a2.1.1-0ubun...

Read more...

Martin Pitt (pitti) on 2011-07-11
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ldm - 2:2.1.1-0ubuntu2.1

---------------
ldm (2:2.1.1-0ubuntu2.1) lucid-proposed; urgency=low

  * Properly transition from ltsp-server to ldm-server
    for ldminfod (LP: #525619)
 -- Stephane Graber <email address hidden> Thu, 07 Jul 2011 16:32:10 +0200

Changed in ldm (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in ldm (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers