Ubuntu

ldc is not installable due to unmet dependencies (libllvm2.7)

Reported by Leo Iannacone on 2012-02-26
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ldc (Ubuntu)
Undecided
Unassigned

Bug Description

On precise:

# apt-get install ldc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ldc : Depends: libllvm2.7 but it is not installable
E: Unable to correct problems, you have held broken packages.

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue.

I get a similar error message when attempting to install ldc in Ubuntu Precise.
The following packages have unmet dependencies:
 ldc : Depends: libllvm2.7 but it is not installable
       Recommends: libtango-ldc-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

summary: - ldc : Depends: libllvm2.7 but it is not installable
+ ldc : Depends: libllvm2.7 but it is not installable due to unmet
+ dependencies (libllvm2.7)
Changed in ldc (Ubuntu):
status: New → Confirmed
tags: added: precise unmetdeps

Actually, it looks like libllvm2.7 is missing in Precise (http://packages.ubuntu.com/precise/ldc).

summary: - ldc : Depends: libllvm2.7 but it is not installable due to unmet
- dependencies (libllvm2.7)
+ ldc is not installable due to unmet dependencies (libllvm2.7)

The problems seems to be that Ubuntu is shipping a fairly old version of LDC – which is unfortunately not very surprising, because there hasn't been an official release for quite some time now. This is being worked on, but in the meantime, the best solution might be packaging Git master, like other distributions do (which depends on LLVM 3.0 right now).

If there is anything else we as upstream devs can do in this regard, please don't hesitate to let me know.

Matthias Klose (doko) wrote :

nobody is working on this, removing the package for quantal.

please feel free to update the packaging and bring the new version into Ubuntu

Matthias Klose (doko) wrote :

removing and blacklisting the package. Arthur is MIA in Debian, so don't expect an update from there.

Removing packages:
 ldc 0.9.2+hg1655-0ubuntu5 in quantal
Comment: lp #941549, remove ldc, and blacklist
1 package successfully removed.

Changed in ldc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers