package lcdproc 0.5.5-2 failed to install/upgrade: ErrorMessage: EOF on stdin at conffile prompt

Bug #1052629 reported by jdonmoyer
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lcdproc (Ubuntu)
Undecided
Unassigned

Bug Description

occurred while upgrading from mythbuntu 11.10 to 12.04

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: lcdproc 0.5.5-2
ProcVersionSignature: Ubuntu 3.0.0-26.42-generic 3.0.42
Uname: Linux 3.0.0-26-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
Date: Tue Sep 18 15:05:59 2012
ErrorMessage: ErrorMessage: EOF on stdin at conffile prompt
SourcePackage: lcdproc
Title: package lcdproc 0.5.5-2 failed to install/upgrade: ErrorMessage: EOF on stdin at conffile prompt
UpgradeStatus: Upgraded to precise on 2012-09-18 (0 days ago)

Revision history for this message
jdonmoyer (jason-threddies) wrote :
Revision history for this message
Dominique Dumont (domi-dumont) wrote :

Here's an extract from VarLogDistupgradeApttermlog.gz :

+++
Setting up lcdproc (0.5.5-2) ...

Configuration file `/etc/LCDd.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
 The default action is to keep your current version.
*** LCDd.conf (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing lcdproc (--configure):
 EOF on stdin at conffile prompt
dpkg: dependency problems prevent configuration of lcdproc-extra-drivers:
 lcdproc-extra-drivers depends on lcdproc (= 0.5.5-2); however:
  Package lcdproc is not configured yet.
dpkg: error processing lcdproc-extra-drivers (--configure):
 dependency problems - leaving unconfigured
+++

Looks like the question asked by debconf was not answered. This version of lcdproc cannot be upgraded wihtout answering this question.

Starting from lcdproc 0.5.6, unattended upgrade are working, thanks to the automatic configuration upgrade performed by Config::Model

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers