Please backport important performance fixes from maverick to lucid

Bug #607947 reported by Brian Murray on 2010-07-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lazr.restfulclient (Ubuntu)
Undecided
Unassigned
Lucid
High
Brian Murray

Bug Description

The version of python-lazr.restfulclient in Maverick has multiple performance related changes that should be included in Lucid.

[Impact]
launchpadlib clients run at reduced performance on lucid compared with maverick.

[Development]
The fixes already uploaded to maverick include the following:

revno: 92
committer: Leonard Richardson
message:
  [r=abentley] Send a real value for the User-Agent header.

revno: 94
committer: Leonard Richardson
message:
  [r=abentley] Send a real User-Agent string and work around a bug in httplib2.

revno: 99
committer: Leonard Richardson
message:
  [r=intellectronica] Request compressed representation with Content-Encoding instead of TE.

[Release Patch]
A backport of the aforementioned patches is at
http://launchpadlibrarian.net/52230548/lazr.restfulclient_0.9.11-1ubuntu2.debdiff

[Test Case]
Run a launchpadlib application (such as apport or arsenal), and time how long it takes to perform.
Now upgrade to the new version and re-time it.
The time should be less.

[Regression Potential]
Low. The patch extends the test suite to cover the changes, and has been thoroughly reviewed and tested by other Launchpad engineers.

The most important client is apport, so positive verification can be achieved by running ubuntu-bug with this patch present.

Changed in lazr.restfulclient (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
importance: Medium → Undecided
Changed in lazr.restfulclient (Ubuntu Lucid):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → High
milestone: none → lucid-updates
Brian Murray (brian-murray) wrote :

debdiff that includes the changes that need including in Lucid

Bryce Harrington (bryce) on 2010-07-20
summary: - maverick release has multiple fixes lucid needs
+ Please backport important performance fixes from maverick to lucid
Bryce Harrington (bryce) on 2010-07-20
description: updated
description: updated
Bryce Harrington (bryce) on 2010-07-20
description: updated
Bryce Harrington (bryce) wrote :

Upload sponsored to lucid-proposed

Changed in lazr.restfulclient (Ubuntu Lucid):
status: In Progress → Fix Committed
Leonard Richardson (leonardr) wrote :

When you test, make sure you clear out your launchpadlib cache between the first run and the second.

Changed in lazr.restfulclient (Ubuntu Lucid):
milestone: lucid-updates → ubuntu-10.04.1
Martin Pitt (pitti) wrote :

This is not a regression and not critical for boot/install, so I move this to 10.04.2.

Changed in lazr.restfulclient (Ubuntu Lucid):
milestone: ubuntu-10.04.1 → ubuntu-10.04.2
John Dong (jdong) wrote :

Ok, given that there's a regression testing suite and has wide-scale benefits for our users (e.g. apport), I think this is a suitable SRU.

Martin Pitt (pitti) wrote :

The uploaded package adds three patches, but the source was misbuilt: It adds a debian/patches/debian-changes-0.9.11-1ubuntu1.1 which reverts the three patches. Please reupload.

Brian Murray (brian-murray) wrote :

Properly versioned debdiff.

Brian Murray (brian-murray) wrote :

This has been reuploaded now.

John Dong (jdong) wrote :

This patch looks better to me.

Accepted lazr.restfulclient into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

I've been using my PPA version of the same package since July 21st without any issue so I'd consider the verification done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lazr.restfulclient - 0.9.11-1ubuntu1.1

---------------
lazr.restfulclient (0.9.11-1ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/user-agent.patch: from upstream bzr revno 92 - send a real
    value for the user-agent header (LP: #607947)
  * debian/patches/httplib2-workaround.patch: from upstream bzr revno 94 -
    workaround a bug in httplib2 (LP: #607947)
  * debian/patches/user-agent.patch: from upstream bzr revno 99 - request
    compressed representation with Content-Encoding instead of TE
    (LP: #607947)
 -- Brian Murray <email address hidden> Tue, 20 Jul 2010 13:16:02 -0700

Changed in lazr.restfulclient (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers