Sync lazarus 0.9.28.2-10 (universe) from Debian unstable (main)

Bug #580099 reported by Artur Rona on 2010-05-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lazarus (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync lazarus 0.9.28.2-10 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
All changes have been incorporated in the Debian package.

Changelog entries since current maverick version 0.9.28.2-8ubuntu1:

lazarus (0.9.28.2-10) unstable; urgency=low

  * Fixed memory leak in GTK based lazarus IDE binary (Closes:Bug#571997)
  * Fixed crach by avoiding trapping some FPU exceptions which occurs in linked
    C code. (Closes:Bug#571998)

 -- Abou Al Montacir <email address hidden> Mon, 09 Apr 2010 00:23:00 +0100

lazarus (0.9.28.2-9) unstable; urgency=low

  * Bumped standard version.
  * Split lazarus-ide package into the following packages in order to reduce
    its size and afford more widgetsets support. (Closes:Bug#553519)
      + lazarus-ide-gtk2 : contains IDE linked to GTK+2 backend
      + lazarus-ide-qt4 : contains IDE linked to Qt4 backend
      + lazarus-ide : contains lazarus launcher and depending on either above
        packges
      + lcl-utils: contains command line tools (lazbuild, ...)
      + lcl-units : contains widgetset independent binary units depending on
        either follwing packages
      + lcl-nogui : contains NOGUI backend based LCL interface units
      + lcl-gtk2 : contains GTK+2 backend based LCL interface untis
      + lcl-qt4 : contains Qt4 backend based LCL interface units
      + lcl : metapackage depending on lcl-units and lcl-utils.
  * Fixed help for FPC identifiers applying a ptch from upstream and filled
    correct FPC source directory. (Closes:Bug#507523)

 -- Abou Al Montacir <email address hidden> Mon, 15 Mar 2010 20:02:00 +0100

Benjamin Drung (bdrung) on 2010-05-15
Changed in lazarus (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lazarus - 0.9.28.2-10

---------------
lazarus (0.9.28.2-10) unstable; urgency=low

  * Fixed memory leak in GTK based lazarus IDE binary (Closes:Bug#571997)
  * Fixed crach by avoiding trapping some FPU exceptions which occurs in linked
    C code. (Closes:Bug#571998)

lazarus (0.9.28.2-9) unstable; urgency=low

  * Bumped standard version.
  * Split lazarus-ide package into the following packages in order to reduce
    its size and afford more widgetsets support. (Closes:Bug#553519)
      + lazarus-ide-gtk2 : contains IDE linked to GTK+2 backend
      + lazarus-ide-qt4 : contains IDE linked to Qt4 backend
      + lazarus-ide : contains lazarus launcher and depending on either above
        packges
      + lcl-utils: contains command line tools (lazbuild, ...)
      + lcl-units : contains widgetset independent binary units depending on
        either follwing packages
      + lcl-nogui : contains NOGUI backend based LCL interface units
      + lcl-gtk2 : contains GTK+2 backend based LCL interface untis
      + lcl-qt4 : contains Qt4 backend based LCL interface units
      + lcl : metapackage depending on lcl-units and lcl-utils.
  * Fixed help for FPC identifiers applying a ptch from upstream and filled
    correct FPC source directory. (Closes:Bug#507523)
 -- Artur Rona <email address hidden> Mon, 09 Apr 2010 00:23:00 +0100

Changed in lazarus (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers