Can't find the lazarus executable /usr/lib/lazarus/2.0.6/lazarus

Bug #1859316 reported by corrado venturini
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lazarus (Ubuntu)
Undecided
Unassigned

Bug Description

On Ubuntu 20.04 lazarus installed from Ubuntu Software does not start with a message:
Can't find the lazarus executable /usr/lib/lazarus/2.0.6/lazarus

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: lazarus-ide-2.0 2.0.6+dfsg-3
ProcVersionSignature: Ubuntu 5.4.0-9.12-generic 5.4.3
Uname: Linux 5.4.0-9-generic x86_64
ApportVersion: 2.20.11-0ubuntu15
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Jan 12 09:37:08 2020
ExecutablePath: /usr/lib/lazarus/2.0.6/startlazarus
InstallationDate: Installed on 2020-01-04 (7 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200104)
SourcePackage: lazarus
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
corrado venturini (corradoventu) wrote :
summary: - Lazarus 2.0.6 error on start
+ Can't find the lazarus executable /usr/lib/lazarus/2.0.6/lazarus
Revision history for this message
corrado venturini (corradoventu) wrote :

The content of /usr/lib/lazarus/2.0.6/ created by Ubuntu repository is similar to /usr/share/lazarus/2.0.6/ created when installing from https://www.lazarus-ide.org/ but some files are missing in Ubuntu repository
see https://bugs.freepascal.org/view.php?id=36572

Revision history for this message
Paul Gevers (paul-climbing) wrote :

/usr/lib/lazarus/2.0.6/lazarus is a symlink that is created by installing lazarus-ide-2.0.6. The same package that carries the /usr/lib/lazarus/2.0.6/startlazarus script. Did you have any error when that package ran its postinst script (the script that runs during install)?

Revision history for this message
corrado venturini (corradoventu) wrote :

I don't see errors during install in /var/log/apt/history.log or /var/log/apt/term.log
should I look elsewhere?

This is the list of my /usr/lib/lazarus/2.0.6
corrado@corrado-p3-ff-0217:~$ ls /usr/lib/lazarus/2.0.6 -R
/usr/lib/lazarus/2.0.6:
components docs examples languages startlazarus

/usr/lib/lazarus/2.0.6/components:
chmhelp

/usr/lib/lazarus/2.0.6/components/chmhelp:
lhelp

/usr/lib/lazarus/2.0.6/components/chmhelp/lhelp:
lhelp

/usr/lib/lazarus/2.0.6/examples:
codepageconverter designerbaseclass dockmanager idehelp pascalstream
codetools designnonlcl exploremenu idequickfix xmlresource

/usr/lib/lazarus/2.0.6/examples/codepageconverter:
filefind

/usr/lib/lazarus/2.0.6/examples/codepageconverter/filefind:
filefindlaz.lpk

/usr/lib/lazarus/2.0.6/examples/codetools:
jumptoimplementation

/usr/lib/lazarus/2.0.6/examples/codetools/jumptoimplementation:
jumptoimplementation.lpk

/usr/lib/lazarus/2.0.6/examples/designerbaseclass:
designbaseclassdemopkg.lpk

/usr/lib/lazarus/2.0.6/examples/designnonlcl:
notlcldesigner.lpk

/usr/lib/lazarus/2.0.6/examples/dockmanager:
package

/usr/lib/lazarus/2.0.6/examples/dockmanager/package:
easydockmgr.lpk

/usr/lib/lazarus/2.0.6/examples/exploremenu:
exploreidemenu.lpk

/usr/lib/lazarus/2.0.6/examples/idehelp:
demoidehelp.lpk

/usr/lib/lazarus/2.0.6/examples/idequickfix:
quickfixexample.lpk

/usr/lib/lazarus/2.0.6/examples/pascalstream:
CopyAsPasPkg

/usr/lib/lazarus/2.0.6/examples/pascalstream/CopyAsPasPkg:
copyformaspascaldemopkg.lpk

/usr/lib/lazarus/2.0.6/examples/xmlresource:
xmlresource.lpk

/usr/lib/lazarus/2.0.6/languages:
debuggerstrconst.es.po lazaruside.af_ZA.po lazaruside.ja.po
debuggerstrconst.fr.po lazaruside.ar.po lazaruside.lt.po
debuggerstrconst.hu.po lazaruside.ca.po lazaruside.nl.po
debuggerstrconst.it.po lazaruside.cs.po lazaruside.pl.po
debuggerstrconst.ja.po lazaruside.de.po lazaruside.po
debuggerstrconst.lt.po lazaruside.es.po lazaruside.pt_BR.po
debuggerstrconst.po lazaruside.fi.po lazaruside.ru.po
debuggerstrconst.pt_BR.po lazaruside.fr.po lazaruside.sk.po
debuggerstrconst.ru.po lazaruside.he.po lazaruside.tr.po
debuggerstrconst.tr.po lazaruside.hu.po lazaruside.uk.po
debuggerstrconst.uk.po lazaruside.id.po lazaruside.zh_CN.po
debuggerstrconst.zh_CN.po lazaruside.it.po README.txt
corrado@corrado-p3-ff-0217:~$

Revision history for this message
Jens (jens-bormueller) wrote :

I get the same error when installing the Lazarus-IDE with ubuntu software.

No errors after running

$ sudo apt install lazarus lazarus-ide

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.