Remove launchpad-integration from the archive

Bug #999413 reported by Robert Ancell
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
launchpad-integration (Ubuntu)
Fix Released
Medium
Unassigned
Raring
Fix Released
Undecided
Unassigned
pasaffe (Ubuntu)
Fix Released
Undecided
Marc Deslauriers
quickly (Ubuntu)
Fix Released
Undecided
Unassigned
software-center (Ubuntu)
Fix Released
Medium
Robert Ancell
testdrive (Ubuntu)
Fix Released
Undecided
Andres Rodriguez
ubuntu-sugar-remix-meta (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

For Quantal we decided to drop support for Launchpad integration:
https://blueprints.launchpad.net/ubuntu/+spec/desktop-q-gnome-plans-review

Please remove the source package from the archive.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

There are two remaining packages that need updating:
- Testdrive (needs new release as lp:~robert-ancell/testdrive/drop-lp-integration has been merged)
- Quickly (lp:~robert-ancell/quickly/drop-lpi proposed, but probably needs some work and a release to be made)

Once these are complete I'll subscribe ubuntu-archive and this is good to go.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Dependencies found with:
apt-cache rdepends launchpad-integration liblaunchpad-integration1 python-launchpad-integration liblaunchpad-integration1.0-cil liblaunchpad-integration-3.0-1 gir1.2-launchpad-integration-3.0

Revision history for this message
Robert Ancell (robert-ancell) wrote :
Changed in launchpad-integration (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Robert Ancell (robert-ancell) wrote :

The Sugar remix also needs to update their seed to remove the dependency

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Flasher command that just lists the packages to be updated:
apt-cache rdepends launchpad-integration liblaunchpad-integration1 python-launchpad-integration liblaunchpad-integration1.0-cil liblaunchpad-integration-3.0-1 gir1.2-launchpad-integration-3.0|grep -v launchpad-int | grep -v '^Rever' | sort | uniq

Currently shows:
  pasaffe
  quickly-ubuntu-template
  software-center
  testdrive-gtk
  ubuntustudio-desktop
  ubuntu-sugar-remix

(all linked to this bug report)

Changed in pasaffe (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in testdrive (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
Changed in software-center (Ubuntu):
status: New → Fix Committed
Changed in pasaffe (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package testdrive - 3.16-0ubuntu1

---------------
testdrive (3.16-0ubuntu1) quantal; urgency=low

  [ Philip Muškovac ]
  * Correctly display versions for both -cli and -gtk

  [ Andres Rodriguez ]
  * testdrive/virt/kvm.py: Generate UUID. (LP: #959308)
  * correctly save arch's in preferences (LP: #873235)
  * Change tabs to spaces.
  * debian/source/format: Added.
  * fully migrate to dh_python2

  [ Robert Ancell ]
  * debian/control:
    - Drop dependency on python-launchpad-integration
  * bin/testdrive-gtk:
    - We no longer do Launchpad integration (LP: #999413)
 -- Andres Rodriguez <email address hidden> Tue, 15 May 2012 16:58:37 -0400

Changed in testdrive (Ubuntu):
status: New → Fix Released
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Down to four packages:
  pasaffe
  quickly-ubuntu-template
  software-center
  ubuntu-sugar-remix

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pasaffe - 0.19-0ubuntu1

---------------
pasaffe (0.19-0ubuntu1) quantal; urgency=low

  * New upstream release
   - Can now import KeePass2 XML files
     (Thanks to Mathieu Trudel-Lapierre!)
   - Disable Launchpad integration (LP: #999413)
  * debian/control: remove gir1.2-launchpad-integration-3.0 depends.
 -- Marc Deslauriers <email address hidden> Thu, 17 May 2012 20:49:19 -0400

Changed in pasaffe (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in quickly (Ubuntu):
status: New → Confirmed
Changed in ubuntu-sugar-remix-meta (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Robert Ancell (robert-ancell)
Jeremy Bicha (jbicha)
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-sugar-remix-meta (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Stéphane Graber (stgraber) wrote :

As discussed on IRC, nothing depends on launchpad-integration anymore, however, we think that quite a few packages outside of the archive, like those in extras may still be depending on it as it was the default in the quickly template.

The source and all binaries are now in universe and will stay there for Ubuntu 12.10 with the actual package removal happening in 13.04.

Changed in quickly (Ubuntu):
status: Confirmed → Fix Released
no longer affects: pasaffe (Ubuntu R-series)
no longer affects: quickly (Ubuntu R-series)
no longer affects: software-center (Ubuntu R-series)
no longer affects: testdrive (Ubuntu R-series)
no longer affects: ubuntu-sugar-remix-meta (Ubuntu R-series)
Changed in launchpad-integration (Ubuntu):
status: Triaged → Won't Fix
information type: Public → Public Security
information type: Public Security → Public
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Well, it's 13.04 now. Please remove launchpad-integration from the archive. No reverse dependencies found.

Revision history for this message
Colin Watson (cjwatson) wrote :

Removing packages from raring:
        launchpad-integration 0.1.56.2 in raring
                gir1.2-launchpad-integration-3.0 0.1.56.2 in raring amd64
                gir1.2-launchpad-integration-3.0 0.1.56.2 in raring armhf
                gir1.2-launchpad-integration-3.0 0.1.56.2 in raring i386
                gir1.2-launchpad-integration-3.0 0.1.56.2 in raring powerpc
                launchpad-integration 0.1.56.2 in raring amd64
                launchpad-integration 0.1.56.2 in raring armhf
                launchpad-integration 0.1.56.2 in raring i386
                launchpad-integration 0.1.56.2 in raring powerpc
                liblaunchpad-integration-3.0-1 0.1.56.2 in raring amd64
                liblaunchpad-integration-3.0-1 0.1.56.2 in raring armhf
                liblaunchpad-integration-3.0-1 0.1.56.2 in raring i386
                liblaunchpad-integration-3.0-1 0.1.56.2 in raring powerpc
                liblaunchpad-integration-3.0-dev 0.1.56.2 in raring amd64
                liblaunchpad-integration-3.0-dev 0.1.56.2 in raring armhf
                liblaunchpad-integration-3.0-dev 0.1.56.2 in raring i386
                liblaunchpad-integration-3.0-dev 0.1.56.2 in raring powerpc
                liblaunchpad-integration-cil-dev 0.1.56.2 in raring amd64
                liblaunchpad-integration-cil-dev 0.1.56.2 in raring armhf
                liblaunchpad-integration-cil-dev 0.1.56.2 in raring i386
                liblaunchpad-integration-cil-dev 0.1.56.2 in raring powerpc
                liblaunchpad-integration-common 0.1.56.2 in raring amd64
                liblaunchpad-integration-common 0.1.56.2 in raring armhf
                liblaunchpad-integration-common 0.1.56.2 in raring i386
                liblaunchpad-integration-common 0.1.56.2 in raring powerpc
                liblaunchpad-integration-dev 0.1.56.2 in raring amd64
                liblaunchpad-integration-dev 0.1.56.2 in raring armhf
                liblaunchpad-integration-dev 0.1.56.2 in raring i386
                liblaunchpad-integration-dev 0.1.56.2 in raring powerpc
                liblaunchpad-integration1 0.1.56.2 in raring amd64
                liblaunchpad-integration1 0.1.56.2 in raring armhf
                liblaunchpad-integration1 0.1.56.2 in raring i386
                liblaunchpad-integration1 0.1.56.2 in raring powerpc
                liblaunchpad-integration1.0-cil 0.1.56.2 in raring amd64
                liblaunchpad-integration1.0-cil 0.1.56.2 in raring armhf
                liblaunchpad-integration1.0-cil 0.1.56.2 in raring i386
                liblaunchpad-integration1.0-cil 0.1.56.2 in raring powerpc
                python-launchpad-integration 0.1.56.2 in raring amd64
                python-launchpad-integration 0.1.56.2 in raring armhf
                python-launchpad-integration 0.1.56.2 in raring i386
                python-launchpad-integration 0.1.56.2 in raring powerpc
Comment: requested by ~robert-ancell; not very useful for normal users, high maintenance cost, should be superseded by https://wiki.ubuntu.com/ContributorConsole; LP: #999413
Remove [y|N]? y
1 package successfully removed.

Changed in launchpad-integration (Ubuntu Raring):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers