Context menu has option "Report a Bug"

Bug #93350 reported by Mario Vukelic on 2007-03-18
6
Affects Status Importance Assigned to Milestone
launchpad-integration (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: gnome-panel

The term "bug" is a technical term in computing and is not universally known. There is no tooltip to explain it either. The term is also inconsistent with the System menu on the gnome panel. The option in this menu is called "Report a Problem", which seems more universally comprehensible (and it has a tooltip).

The respective options also don't use the same icon: the panel context menu has an orange triangle with an exclamation mark, the System menu has an orange star.

Mario Vukelic (mario-vukelic) wrote :

The workspace-switcher also uses "Report a Bug". I did not find a binary for workspace-switcher and support files are in gnome-panel-data, so I figure it is built into gnome-panel and it is likely that other applets share the same inconsistency.

Confirmed. This should be consistent.

Changed in gnome-panel:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

The menu item is the same for all the desktop applications

Changed in gnome-panel:
importance: Medium → Wishlist
Matthew Paul Thomas (mpt) wrote :

I sincerely hope this menu item is intended just for development versions, not for any release version (Ubuntu already gets more bug reports than the bugsquad can handle, so inviting more is counterproductive). And those people who run development versions should be quite familiar with what a "bug" is.

Martin Pitt (pitti) wrote :

Thanks for the bug. I'll make the icons consistent and change 'bug' to 'problem'.

Matthew, it is not currently planned to remove the menu entry from lp-i before the release. It has been part of https://wiki.ubuntu.com/BugReportingTool. Please bring this up on ubuntu-devel@ if we should better remove it again. Thank you!

Changed in launchpad-integration:
assignee: nobody → pitti
importance: Wishlist → Low
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Fixed in bzr head. Seb is currently working on head, too, so I cannot upload this yet.

Changed in launchpad-integration:
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

This upload fixes the bug:

 launchpad-integration (0.1.11) feisty; urgency=low
 .
   [ Sebastien Bacher ]
   * debian/liblaunchpad-integration0.install,
     lib/launchpad-integration.c, lib/lpint-bonobo.c, pixmaps/Makefile.am:
     - use themeable icon (Ubuntu: #51901, #40312)
   * lib/launchpad-integration.c, lib/lpint-bonobo.c:
     - list "Get Help Online" again, launchpad has been updated
       (Ubuntu: #103024)
   * launchpadintegration/urls.py:
     - special case firefox to open a new window (Ubuntu: #94166)
 .
   [ Martin Pitt ]
   * 'Report a Bug' -> 'Report a Problem' for consistency and avoiding the
     technical slang 'Bug'. Update the existing .po files. (LP: #93350)

Changed in launchpad-integration:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers