LOCALEDIR wrong due to local m4 files

Bug #85654 reported by Kees Cook on 2007-02-16
2
Affects Status Importance Assigned to Milestone
launchpad-integration (Ubuntu)
Medium
Kees Cook

Bug Description

Binary package hint: launchpad-integration

The LOCALEDIR is being defined wrong, leading to liternal '${prefix}' in the library:

 $ strings /usr/lib/liblaunchpad-integration.so | grep prefix
 ${prefix}/share/locale

This is due to m4/define-localedir.m4 overriding the fixed glib automake macro. Though, in fixing this, I'd recommend using the Makefile.am -D approach, as that is more future-friendly. Patch attached...

Kees Cook (kees) wrote :

You can see the discussion of this here:

 http://bugzilla.gnome.org/show_bug.cgi?id=343825

Attached is a tested patch to clean this up; I didn't want to commit directly to the bzr trunk since I hadn't looked at this code before. If someone says "okay", I'll do it and upload a new package, though. :)

Changed in launchpad-integration:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Looks fine, please commit and upload ;)

Kees Cook (kees) wrote :

0.1.6 was uploaded without the bzr branch getting updated...

Changed in launchpad-integration:
assignee: nobody → keescook
importance: Undecided → Medium
Kees Cook (kees) wrote :

I've published 0.1.8, but 0.1.6 and 0.1.7 aren't in bzr. I emailed doko and asked if he could sync it up.

Changed in launchpad-integration:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers