help -> report a problem doesn't work on Maverick

Bug #589656 reported by Pedro Villavicencio on 2010-06-04
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
launchpad-integration (Ubuntu)
Medium
Canonical Desktop Team
linux (Ubuntu)
High
Kees Cook

Bug Description

Binary package hint: launchpad-integration

The menu on Maverick is not working, tried gcalctool to report a problem and I've got:

2010-06-04 08:25:35,081 ERROR Could not find executable for process 1267
Traceback (most recent call last):
  File "/usr/share/launchpad-integration/launchpadintegration/packageinfo.py", line 138, in fromProcessID
    filename = os.readlink('/proc/%d/exe' % pid)
OSError: [Errno 13] Permission denied: '/proc/1267/exe'
Traceback (most recent call last):
  File "<string>", line 5, in <module>
  File "/usr/share/launchpad-integration/launchpadintegration/main.py", line 44, in main
    pkginfo = PackageInfo.fromProcessID(options.pid, logger)
  File "/usr/share/launchpad-integration/launchpadintegration/packageinfo.py", line 144, in fromProcessID
    'process %d' % pid)
launchpadintegration.packageinfo.PackageNotFoundError: Could not find executable for process 1267

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: launchpad-integration 0.1.36
ProcVersionSignature: Ubuntu 2.6.34-5.13-generic 2.6.34
Uname: Linux 2.6.34-5-generic i686
Architecture: i386
Date: Fri Jun 4 08:26:05 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100602.2)
PackageArchitecture: all
ProcEnviron:
 LANG=es_CL.utf8
 SHELL=/bin/bash
SourcePackage: launchpad-integration

Pedro Villavicencio (pedro) wrote :
Changed in launchpad-integration (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Pedro Villavicencio (pedro) wrote :

Noticed that /proc/pid/exe , /proc/pid/cwd and /proc/pid/root are not longer accessible for the user they can only be seeing by root. Linux issue perhaps?

Kees Cook (kees) wrote :

This is due to over-zealous PTRACE restrictions that went into the most recent kernel package. I will dial this back a bit.

Changed in launchpad-integration (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu):
importance: Undecided → High
assignee: nobody → Kees Cook (kees)
status: New → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Kees Cook (kees) wrote :
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.35-2.2

---------------
linux (2.6.35-2.2) maverick; urgency=low

  [ Andy Whitcroft ]

  * [Config] d-i: make armel configuration versatile flavour specific
    - LP: #588805
  * [Config] d-i: enable .udebs for omap flavour
    - LP: #588805

  [ Kees Cook ]

  * ptrace: limit scope to attach only (allow read)
    - LP: #589656

  [ Leann Ogasawara ]

  * rebase to v2.6.35-rc2
  * [Config] update configs following rebase to v2.6.35-rc2
  * [Config] update port configs following rebase to v2.6.35-rc2

  [ Lee Jones ]

  * Enable perf to be more helpful when perf_<version> does not exist.
    - LP: #570500
  * 'fdr editconfig' modification. Easily skip over unwanted menuconfigs.

  [ Tim Gardner ]

  * [Config] Update bnx2 udeb firmware files
    - LP: #589304

  [ Upstream changes ]

  * rebased to v2.6.35-rc2
 -- Leann Ogasawara <email address hidden> Mon, 07 Jun 2010 09:45:04 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers