Launchpad opens duplicate pixbufs

Bug #51901 reported by Ben Maurer on 2006-07-04
6
Affects Status Importance Assigned to Milestone
launchpad-integration (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

If one runs valgrind with --show-reachable, the following backtrace can be seen:

==16971== 79,872 bytes in 78 blocks are still reachable in loss record 12,191 of 12,200
==16971== at 0x401C422: malloc (vg_replace_malloc.c:149)
==16971== by 0x4A49E6D: g_try_malloc (in /usr/lib/libglib-2.0.so.0.1000.3)
==16971== by 0x46F6E1B: gdk_pixbuf_new (gdk-pixbuf.c:293)
==16971== by 0x53D9A94: ??? (io-png.c:294)
==16971== by 0x46F9A2E: _gdk_pixbuf_generic_image_load (gdk-pixbuf-io.c:792)
==16971== by 0x46F9CBD: gdk_pixbuf_new_from_file (gdk-pixbuf-io.c:904)
==16971== by 0x402FA68: launchpad_integration_add_item_factory (in /usr/lib/liblaunchpad-integration.so.0.0.0)
==16971== by 0x402FADE: (within /usr/lib/liblaunchpad-integration.so.0.0.0)
==16971== by 0x402FB7E: launchpad_integration_add_ui (in /usr/lib/liblaunchpad-integration.so.0.0.0)
==16971== by 0x809B9BA: (within /usr/bin/gedit)
==16971== by 0x809F059: (within /usr/bin/gedit)
==16971== by 0x4A0F381: g_type_create_instance (in /usr/lib/libgobject-2.0.so.0.1000.3)

Looking at strace -eopen gedit, there is the sequence:
open("/usr/share/pixmaps/lpi-help.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-translate.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-help.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-translate.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-help.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-translate.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-help.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-translate.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-help.png", O_RDONLY|O_LARGEFILE) = 17
open("/usr/share/pixmaps/lpi-translate.png", O_RDONLY|O_LARGEFILE) = 17

It looks like duplicates of the images are being created. The icons should really be in /usr/share/icons so that the mmap'd cache can be used. This would also make the icons themeable.

Daniel Holbach (dholbach) wrote :

Michael, you think we can fix this as part of IconthemeEverywhere?

Changed in launchpad-integration:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

This upload fixes the bug:

 launchpad-integration (0.1.11) feisty; urgency=low
 .
   [ Sebastien Bacher ]
   * debian/liblaunchpad-integration0.install,
     lib/launchpad-integration.c, lib/lpint-bonobo.c, pixmaps/Makefile.am:
     - use themeable icon (Ubuntu: #51901, #40312)
   * lib/launchpad-integration.c, lib/lpint-bonobo.c:
     - list "Get Help Online" again, launchpad has been updated
       (Ubuntu: #103024)
   * launchpadintegration/urls.py:
     - special case firefox to open a new window (Ubuntu: #94166)
 .
   [ Martin Pitt ]
   * 'Report a Bug' -> 'Report a Problem' for consistency and avoiding the
     technical slang 'Bug'. Update the existing .po files. (LP: #93350)

Changed in launchpad-integration:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers