trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png', which is also in package liblaunchpad-integration0

Bug #213863 reported by Fred on 2008-04-08
406
This bug affects 1 person
Affects Status Importance Assigned to Milestone
launchpad-integration (Ubuntu)
High
Unassigned

Bug Description

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  liblpint-bonobo0: Depends: liblaunchpad-integration1 (>= 0.1.17) but it is not installed
  python-launchpad-integration: Depends: liblaunchpad-integration1 (>= 0.1.17) but it is not installed
E: Unmet dependencies. Try using -f.

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  liblaunchpad-integration1
The following NEW packages will be installed:
  liblaunchpad-integration1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0B/17.7kB of archives.
After this operation, 172kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 225612 files and directories currently installed.)
Unpacking liblaunchpad-integration1 (from .../liblaunchpad-integration1_0.1.18_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb (--unpack):
 trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png', which is also in package liblaunchpad-integration0
Errors were encountered while processing:
 /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The same trouble while trying to update.

Matthias Metzger (macellarius) wrote :

Confirmed. A possible workaround should be the following:
1. Download http://archive.ubuntu.com/ubuntu/pool/main/l/launchpad-integration/liblaunchpad-integration1_0.1.18_i386.deb
2. Install this package manually with the following commands: sudo dpkg --force-overwrite -i liblaunchpad-integration1_0.1.18_i386.deb
3. sudo apt-get -f install or sudo apt-get upgrade

Regards
Matthias

bthiphagne (thiphagne-benoit) wrote :

Thanks for this tip, tested on my computer, worked fine

Lorenco Trichardt (trichalo) wrote :

Same here....

Fred (eldmannen+launchpad) wrote :

Matthias Metzger,
Workaround does not work (for me).

$ sudo dpkg --force-overwrite -i liblaunchpad-integration1_0.1.18_i386.deb
dpkg: error processing liblaunchpad-integration1_0.1.18_i386.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 liblaunchpad-integration1_0.1.18_i386.deb

Fred (eldmannen+launchpad) wrote :

Matthias Metzger,
Nevermind the previous reply.
The workaround *does* work for me. :)

Pete (plwilkins) wrote :

This workaround worked for me too - although I used the amd64.deb for my setup

Changed in launchpad-integration:
importance: Undecided → High
status: New → Confirmed
Matthias Metzger (macellarius) wrote :

Yes, of course, you have to download the proper package for your system.
Browse this directory (http://archive.ubuntu.com/ubuntu/pool/main/l/launchpad-integration/) for the correct version: liblaunchpad-integration1_0.1.18_???.deb

sebs (sebs) wrote :

Confirmed. Bug and Workaround.

Dale (quail-linux) wrote :

confirmed bug, and confirmed work around works too

BKontek (birger-kontek) wrote :

The solution works for me too, but I used the amd64-package. Everything fine now. :-)

Sebastien Bacher (seb128) wrote :

the bug has been fixed in hardy now

Changed in launchpad-integration:
status: Confirmed → Fix Released
Kerry Hatcher (kerry.hatcher) wrote :

Worked for me! Thanks!
Dell E520
AMD64

Perpetual (landonab) wrote :

Thanks for the fix.

Manuel Herrera (blackout2day) wrote :

Thanks for the fix. Very fast

fix worked for me too, thanks!

dhopki (dhopki) wrote :

Worked for me as well. Thanks!

Sukarn Singh Maini (sukarn) wrote :

Still getting this conflict on amd64 (updated package list from the main archive server - archive.ubuntu.com)

Anything I might be doing wrong?

kulight (kulight) wrote :

workaround worked for me too
thank you

wingnux (wingnux) wrote :

The fix didn't work for me:

wingnux@wingnux:~/Downloads$ sudo dpkg --force-overwrite -i liblaunchpad-integration-dev_0.1.18_amd64.deb
(Reading database ... 151321 files and directories currently installed.)
Preparing to replace liblaunchpad-integration-dev 0.1.18 (using liblaunchpad-integration-dev_0.1.18_amd64.deb) ...
Unpacking replacement liblaunchpad-integration-dev ...
dpkg: dependency problems prevent configuration of liblaunchpad-integration-dev:
 liblaunchpad-integration-dev depends on liblaunchpad-integration1 (= 0.1.18); however:
  Package liblaunchpad-integration1 is not installed.
dpkg: error processing liblaunchpad-integration-dev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 liblaunchpad-integration-dev

wingnux@wingnux:~/Downloads$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  nspluginwrapper libotr2
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  liblaunchpad-integration1
The following NEW packages will be installed:
  liblaunchpad-integration1
0 upgraded, 1 newly installed, 0 to remove and 16 not upgraded.
6 not fully installed or removed.
Need to get 0B/18.3kB of archives.
After this operation, 176kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 151321 files and directories currently installed.)
Unpacking liblaunchpad-integration1 (from .../liblaunchpad-integration1_0.1.18_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_amd64.deb (--unpack):
 trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png', which is also in package liblaunchpad-integration0
Errors were encountered while processing:
 /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Colin Watson (cjwatson) wrote :

The fix is in 0.1.19, not 0.1.18. It should be available shortly. Don't use --force-overwrite with it; there's no need.

(Sebastien, could you please include version numbers when you say that a bug is fixed, to prevent this kind of confusion?)

Colin Watson (cjwatson) wrote :

wingnux: The workaround said to use --force-overwrite with liblaunchpad-integration1, not liblaunchpad-integration-dev.

Sukarn Singh Maini (sukarn) wrote :

0.1.19 installing fine - amd64

wingnux (wingnux) wrote :

OMG! Wrong package! I feel like an idiot! LOL!

Thanks for pointing out, Colin! =)

SouthStarr (jtheimperfect) wrote :

southstarr@southstarr-laptop:~$ sudo dpkg --force-overwrite -i liblaunch-intergration1_0.1.18_i386.deb
dpkg: error processing liblaunch-intergration1_0.1.18_i386.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 liblaunch-intergration1_0.1.18_i386.deb

Did i do something wrong? the liblaunch file is on my desktop by the way... should it be someplace else?

Sukarn Singh Maini (sukarn) wrote :

SouthStarr:

Just try updating from synaptic to version 0.1.19

Matthias Metzger (macellarius) wrote :

@SouthStarr
For the workaround you have to change to the directory where the .deb file is located.
If it is on your desktop, first type: cd Desktop
or try: sudo dpkg --force-overwrite -i Desktop/liblaunch-intergration1_0.1.18_i386.deb

But now, I suggest you to wait for the fixed package in synaptic.

  • unnamed Edit (3.0 KiB, text/html; charset=ISO-8859-1)

cd to dir Desktop in the terminal first. Then apply the update/restore.
I made the same mistake at first.

On Tue, Apr 8, 2008 at 3:42 PM, SouthStarr <email address hidden> wrote:

> southstarr@southstarr-laptop:~$ sudo dpkg --force-overwrite -i
> liblaunch-intergration1_0.1.18_i386.deb
> dpkg: error processing liblaunch-intergration1_0.1.18_i386.deb
> (--install):
> cannot access archive: No such file or directory
> Errors were encountered while processing:
> liblaunch-intergration1_0.1.18_i386.deb
>
>
> Did i do something wrong? the liblaunch file is on my desktop by the
> way... should it be someplace else?
>
> --
> trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png',
> which is also in package liblaunchpad-integration0
> https://bugs.launchpad.net/bugs/213863
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Source Package "launchpad-integration" in Ubuntu: Fix Released
>
> Bug description:
> $ sudo apt-get upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> You might want to run `apt-get -f install' to correct these.
> The following packages have unmet dependencies:
> liblpint-bonobo0: Depends: liblaunchpad-integration1 (>= 0.1.17) but it
> is not installed
> python-launchpad-integration: Depends: liblaunchpad-integration1 (>=
> 0.1.17) but it is not installed
> E: Unmet dependencies. Try using -f.
>
> $ sudo apt-get -f install
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Correcting dependencies... Done
> The following extra packages will be installed:
> liblaunchpad-integration1
> The following NEW packages will be installed:
> liblaunchpad-integration1
> 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
> 2 not fully installed or removed.
> Need to get 0B/17.7kB of archives.
> After this operation, 172kB of additional disk space will be used.
> Do you want to continue [Y/n]? y
> (Reading database ... 225612 files and directories currently installed.)
> Unpacking liblaunchpad-integration1 (from
> .../liblaunchpad-integration1_0.1.18_i386.deb) ...
> dpkg: error processing
> /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb
> (--unpack):
> trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png',
> which is also in package liblaunchpad-integration0
> Errors were encountered while processing:
> /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>

SouthStarr (jtheimperfect) wrote :

I see.... well since there is going to be fixed package soon and im on my way out to begin with i guess i'll check for it later if not i will just switch the directories and fix it manually..

 Thanks Matthias and Alainn

Just curious... where should files like these be placed in to get the terminal commands to work corectly? so i don't have this same problem in the future...

Thanks again...

@ SouthStarr
Home directory

Matthias Metzger (macellarius) wrote :

Well, it doesn't matter where the file is placed, but you have to care that you *first* change to the directory where the file is located.
By default the terminal opens in /home/username/ (for you probably /home/southstarr/). So you can place the file to this directory and then the command (sudo dpkg --force-overwrite -i liblaunch-intergration1_0.1.18_i386.deb) works perfect.

Germán Poo-Caamaño (gpoo) wrote :

Interesting.

While I'm waiting for i386 package (probably it's being built), I realized evolution doesn't run without liblaunchpad-integration.so.1.

evolution: error while loading shared libraries: liblaunchpad-integration.so.1: cannot open shared object file: No such file or directory

If this can help :

E: /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb: intentando sobreescribir `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png', que está también en el paquete liblaunchpad-integration0

-----

(Leyendo la base de datos ...
189223 ficheros y directorios instalados actualmente.)
Desempaquetando liblaunchpad-integration1 (de .../liblaunchpad-integration1_0.1.18_i386.deb) ...
dpkg: error al procesar /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb (--unpack):
 intentando sobreescribir `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png', que está también en el paquete liblaunchpad-integration0
Se encontraron errores al procesar:
 /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
No se ha podido instalar un paquete. Intentando recuperarse:
dpkg: problemas de dependencias impiden la configuración de python-launchpad-integration:
 python-launchpad-integration depende de liblaunchpad-integration1 (>= 0.1.17); sin embargo:
  El paquete `liblaunchpad-integration1' no está instalado.
dpkg: error al procesar python-launchpad-integration (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de liblpint-bonobo0:
 liblpint-bonobo0 depende de liblaunchpad-integration1 (>= 0.1.17); sin embargo:
  El paquete `liblaunchpad-integration1' no está instalado.
dpkg: error al procesar liblpint-bonobo0 (--configure):
 problemas de dependencias - se deja sin configurar

comhack (sec-securitybreach) wrote :

Thanks for the fix.

philsom (phil-somerville) wrote :

All worked, thanks

SFN (sfnative33) wrote :

How would one go about upgrading to 0.1.19 when it doesn't show available either via Synaptic or when doing an apt-get upgrade?

SFN (sfnative33) wrote :

I should add, "and there's no download link listed".

Ivan Janjić (milandd) wrote :

Works fine. Thanks!

Sukarn Singh Maini (sukarn) wrote :

SFN:
click refresh in synaptic, or type "sudo apt-get update" in terminal

if version 0.1.19 does not show up then wait for a while before trying again.

Everyone, this bug is fixed. Update Synaptic and install 0.1.19. (If it's not available yet, please wait a few hours for it.) Comments about workarounds are not necessary anymore, unless you're having a different problem (in which case you should file a new bug report). And there's no need to confirm that the fix worked; it's a fix, that's how this works.

SFN (sfnative33) wrote :

"SFN:
click refresh in synaptic, or type "sudo apt-get update" in terminal

if version 0.1.19 does not show up then wait for a while before trying again."

OK. I've been doing that. I'll just wait.

Thanks.

  • unnamed Edit (2.9 KiB, text/html; charset=ISO-8859-1)

Hey,
thank you but I don't understand very much about these things (My problems
are not located in language). I supposed this problem to be mine, but now
every try update or even re-install these package ends with the error:
defect dependencies.
Bye :)

2008/4/8, Sukarn Maini <email address hidden>:
>
> SFN:
> click refresh in synaptic, or type "sudo apt-get update" in terminal
>
> if version 0.1.19 does not show up then wait for a while before trying
> again.
>
>
> --
> trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png',
> which is also in package liblaunchpad-integration0
> https://bugs.launchpad.net/bugs/213863
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "launchpad-integration" in Ubuntu: Fix Released
>
> Bug description:
> $ sudo apt-get upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> You might want to run `apt-get -f install' to correct these.
> The following packages have unmet dependencies:
> liblpint-bonobo0: Depends: liblaunchpad-integration1 (>= 0.1.17) but it
> is not installed
> python-launchpad-integration: Depends: liblaunchpad-integration1 (>=
> 0.1.17) but it is not installed
> E: Unmet dependencies. Try using -f.
>
> $ sudo apt-get -f install
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Correcting dependencies... Done
> The following extra packages will be installed:
> liblaunchpad-integration1
> The following NEW packages will be installed:
> liblaunchpad-integration1
> 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
> 2 not fully installed or removed.
> Need to get 0B/17.7kB of archives.
> After this operation, 172kB of additional disk space will be used.
> Do you want to continue [Y/n]? y
> (Reading database ... 225612 files and directories currently installed.)
> Unpacking liblaunchpad-integration1 (from
> .../liblaunchpad-integration1_0.1.18_i386.deb) ...
> dpkg: error processing
> /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb
> (--unpack):
> trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png',
> which is also in package liblaunchpad-integration0
> Errors were encountered while processing:
> /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>

This happened to me just after the last update (April 8 11AM Eastern Time)

Cheers

Mariano

Miguel Ruiz (mruiz) wrote :

I got the same error. The last version (0.1.19) fixes the problem.

I installed manually the needed files ( http://launchpadlibrarian.net/13223274/liblaunchpad-integration1_0.1.19_i386.deb and
 http://launchpadlibrarian.net/13223274/liblaunchpad-integration1_0.1.19_i386.deb).

Cheers!

ernsti (ubuntu-user-gmx-at) wrote :

Works fine. Thanks!

ernsti

SFN (sfnative33) wrote :

0.1.19 became available. Upgraded. Works fine.

Also, after fixing that, 29 more packages became available for upgrade and 2 more from dist-upgrade. Upgraded those without issue.

BrunoGomes (bgomes-s1solucoes) wrote :

I use hardy with this problem

Distributor ID: Ubuntu
Description: Ubuntu hardy (development branch)
Release: 8.04
Codename: hardy

E: /var/cache/apt/archives/liblaunchpad-integration1_0.1.18_i386.deb: trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png', which is also in package liblaunchpad-integration0

LiraNuna (liranuna) wrote :

I had the problem too, above .deb packages fixes it. Had to install using command line (dpkg -i .deb), GDbei reported errors.

dapiz987 (dapiz987) wrote :

Thanks much, workaround worked perfectly

kena (kennethnyman2) wrote :

Thanks a lot. Worked fine. :)

adel (netdur-gmail) wrote :

doesn't work for me because ubuntu boot into read only file system

Andrew Conkling (andrewski) wrote :

On Tue, Apr 8, 2008 at 6:31 PM, adel <email address hidden> wrote:

> doesn't work for me because ubuntu boot into read only file system

Sounds like you got yourself into a jam. Did you happen to try one of the
(unsanctioned) workarounds?

Regardless, your best bet is to seek help via the various channels:
https://help.ubuntu.com/community/HowToGetHelp.

Confirmed. A possible workaround should be the following:
1. Download http://archive.ubuntu.com/ubuntu/pool/main/l/launchpad-integration/
2. Install this package manually with the following commands: sudo dpkg --force-overwrite -i
3. sudo apt-get -f install or sudo apt-get upgrade

Thanks!!!! Worked fine. :)

Andrew Conkling (andrewski) wrote :

On Tue, Apr 8, 2008 at 10:28 PM, vitali <email address hidden> wrote:

> Confirmed. A possible workaround should be the following:
> 1. Download
> 2. Install this package manually
> 3. sudo apt-get -f install or sudo apt-get upgrade
>

No need for these types of workarounds, this is fixed, please don't keep
suggesting them; other people may think they're necessary. At this point,
the new version should be in the archives and a standard system update
should resolve the problem.

A.C. (aarcooper) wrote :
  • unnamed Edit (1.2 KiB, text/html; charset=ISO-8859-1)

Thanks!! That worked for me as well

On Tue, Apr 8, 2008 at 8:28 PM, vitali <email address hidden> wrote:

>
> Confirmed. A possible workaround should be the following:
> 1. Download
> http://archive.ubuntu.com/ubuntu/pool/main/l/launchpad-integration/
> 2. Install this package manually with the following commands: sudo dpkg
> --force-overwrite -i
> 3. sudo apt-get -f install or sudo apt-get upgrade
>
>
> Thanks!!!! Worked fine. :)
>
> --
> trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png',
> which is also in package liblaunchpad-integration0
> https://bugs.launchpad.net/bugs/213863
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

BatsShadow (batsshadow) wrote :

> No need for these types of workarounds, this is fixed, please don't keep
> suggesting them; other people may think they're necessary. At this point,
> the new version should be in the archives and a standard system update
> should resolve the problem.

This does not seem to be true. My system did not detect any other updates and failed to upgrade while in this state. Performing the manual override as explained in the post above yours seemed to fix the problem.

gaurdro (gaurdro) wrote :
  • unnamed Edit (1.6 KiB, text/html; charset=ISO-8859-1)

Yes it is. have you tried updating the cache ie: "sudo apt-get update"
otherwise simply uninstall the package (i think it's something like
_____-integration0) and your system will do the update as normal. neither
are unsanctioned workarounds but will fix your system.

-Ross Smith

On Tue, Apr 15, 2008 at 7:00 AM, BatsShadow <email address hidden> wrote:

> > No need for these types of workarounds, this is fixed, please don't keep
> > suggesting them; other people may think they're necessary. At this
> point,
> > the new version should be in the archives and a standard system update
> > should resolve the problem.
>
> This does not seem to be true. My system did not detect any other
> updates and failed to upgrade while in this state. Performing the
> manual override as explained in the post above yours seemed to fix the
> problem.
>
> --
> trying to overwrite `/usr/share/icons/hicolor/16x16/apps/lpi-bug.png',
> which is also in package liblaunchpad-integration0
> https://bugs.launchpad.net/bugs/213863
> You received this bug notification because you are a direct subscriber
> of the bug.
>

download and install
http://launchpadlibrarian.net/13223274/liblaunchpad-integration1_0.1.19_i386.deb
It works and it fixes the problem

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Aaron Cooper

Aaron Cooper
Network Engineer & Trainer at AT&T and Avaya
Greater Denver Area

Confirm that you know Aaron Cooper
https://www.linkedin.com/e/epgnen-gmhaesur-1z/isd/2693637522/RnoBcwvN/

--
(c) 2011, LinkedIn Corporation

To post a comment you must log in.