Activity log for bug #730633

Date Who What changed Old value New value Message
2011-03-07 14:00:29 Dan Muresan bug added bug
2011-03-07 14:00:29 Dan Muresan attachment added Patch to replace DT_* with stat / S_IS* in lashd https://bugs.launchpad.net/bugs/730633/+attachment/1891583/+files/05_stat.patch
2011-03-07 17:38:13 Brian Murray bug added subscriber Ubuntu Review Team
2011-03-08 00:27:12 Alessio Treglia lash (Ubuntu): importance Undecided Medium
2011-03-14 12:10:52 Alessio Treglia bug task added lash (Debian)
2011-03-14 12:11:07 Alessio Treglia lash (Debian): status New Fix Released
2011-03-14 12:11:55 Alessio Treglia lash (Ubuntu): status New Triaged
2011-05-09 00:06:15 Alessio Treglia lash (Ubuntu): status Triaged Fix Released
2011-05-09 00:06:29 Alessio Treglia nominated for series Ubuntu Natty
2011-05-09 00:06:29 Alessio Treglia bug task added lash (Ubuntu Natty)
2011-07-20 18:19:30 Daniel T Chen description Binary package hint: lashd lashd-0.6.0~rc2-1ubuntu2 (Maverick and Natty) doesn't restore projects from JFS filesystems upon startup. This is because the code uses an unreliable, non-portable check for dirent.d_type == DT_DIR, which fails on many filesystems, causing lashd to think that the project directories are not, in fact, directories. The attached 05_stat.patch uses stat / S_ISDIR to properly check dentries (and fixes a similar problem with the lashd "appdb"). It has been tested in my PPA. Binary package hint: lashd SRU Impact statement: lashd-0.6.0~rc2-1ubuntu2 (Maverick and Natty) doesn't restore projects from JFS filesystems upon startup. This is because the code uses an unreliable, non-portable check for dirent.d_type == DT_DIR, which fails on many filesystems, causing lashd to think that the project directories are not, in fact, directories. Patch / resolution: The attached 05_stat.patch uses stat / S_ISDIR to properly check dentries (and fixes a similar problem with the lashd "appdb"). It has been tested in my PPA. TEST CASE: Install lashd on 11.04 and attempt to load a project hosted on JFS. It will fail. Regression risk: Slim to none.
2011-07-20 18:19:38 Daniel T Chen removed subscriber Ubuntu Review Team
2011-07-20 18:20:33 Daniel T Chen attachment added Patch for natty-proposed https://bugs.launchpad.net/ubuntu/natty/+source/lash/+bug/730633/+attachment/2221562/+files/lash_0.6.0%7Erc2-5ubuntu0.1.debdiff
2011-07-20 18:21:13 Daniel T Chen description Binary package hint: lashd SRU Impact statement: lashd-0.6.0~rc2-1ubuntu2 (Maverick and Natty) doesn't restore projects from JFS filesystems upon startup. This is because the code uses an unreliable, non-portable check for dirent.d_type == DT_DIR, which fails on many filesystems, causing lashd to think that the project directories are not, in fact, directories. Patch / resolution: The attached 05_stat.patch uses stat / S_ISDIR to properly check dentries (and fixes a similar problem with the lashd "appdb"). It has been tested in my PPA. TEST CASE: Install lashd on 11.04 and attempt to load a project hosted on JFS. It will fail. Regression risk: Slim to none. Binary package hint: lashd SRU Impact statement: lashd-0.6.0~rc2-1ubuntu2 (Maverick and Natty) doesn't restore projects from JFS filesystems upon startup. This is because the code uses an unreliable, non-portable check for dirent.d_type == DT_DIR, which fails on many filesystems, causing lashd to think that the project directories are not, in fact, directories. Patch / resolution: The attached 05_stat.patch uses stat / S_ISDIR to properly check dentries (and fixes a similar problem with the lashd "appdb"). It has been tested in my PPA. Oneiric is not affected, as the lash source package is not available. Patch for natty-proposed: https://bugs.launchpad.net/ubuntu/natty/+source/lash/+bug/730633/+attachment/2221562/+files/lash_0.6.0~rc2-5ubuntu0.1.debdiff TEST CASE: Install lashd on 11.04 and attempt to load a project hosted on JFS. It will fail. Regression risk: Slim to none.
2011-07-20 18:22:02 Daniel T Chen lash (Ubuntu Natty): assignee Daniel T Chen (crimsun)
2011-07-20 18:22:28 Daniel T Chen tags patch patch-accepted-debian
2011-07-20 18:23:16 Daniel T Chen bug added subscriber Ubuntu Stable Release Updates Team
2011-09-19 21:47:55 Ubuntu Foundations Team Bug Bot tags patch-accepted-debian patch-accepted-debian testcase
2014-12-03 08:58:31 Rolf Leggewie lash (Ubuntu Natty): status New Won't Fix