Add main-accepted Voikko packages to a seed, language-support-fi should depend on Voikko spellchecking libraries in 7.04

Bug #82143 reported by Timo Jyrinki on 2007-01-29
2
Affects Status Importance Assigned to Milestone
language-support-fi (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: language-support-fi

Source packages malaga, suomi-malaga, libvoikko, tmispell-voikko and openoffice.org-voikko have been in UbuntuMainInclusionQueue as accepted since early December, so they should be going in main. According to https://wiki.ubuntu.com/MainInclusionProcess , they should be added to a seed, but maybe also just including them as a dependency of language-support-fi is enough like hinted on the same page?

The dependencies of language-support-fi should be changed so that the following binary packages are installed automatically as part of Finnish language support:

tmispell-voikko, libenchant-voikko, openoffice.org-voikko

Those depend further on libmalaga7, voikko-fi (from suomi-malaga source package) and libvoikko1.

Martin Pitt (pitti) on 2007-01-29
Changed in language-support-fi:
assignee: nobody → pitti
status: Unconfirmed → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

Remember also that openoffice.org-voikko needs at least one rebuild commenced to update dependencies, see bug 82121. It might be relevant to change the generate_dependencies.sh in openoffice.org-voikko to allow more changes in the OOo version number without conflicting - but upgrading OpenOffice.org to a new major version without reinstalling extensions in it can lead to total breakage of OOo, that's why the conflict is there, ie. to force not to upgrade OOo or also reinstall OOo-voikko. Currently no other solution has been done either in Debian. It's solvable either in dpkg (somehow require OOo rebuilds/newversions to always rebuild OOo-voikko too to force reinstall) or upstream OOo so that OOo doesn't break when updating it.

Timo Jyrinki (timo-jyrinki) wrote :

The current conflict generation seems quite okay for Ubuntu (it is more problematic with ".dfsg" string in the version number). If a rebuild is done, the field will be openoffice.org-core (>= 2.1.1), which should be a proper conflict for Feisty, ie. if anyone is trying to update OOo later on to 2.2 in Feisty (which is of course a bit unlikely), it will be noticed that a new OOo-voikko has to be built at the same time.

I think it should be fine for now, unless a failproof method to unregister/register every OOo extension when updating OOo is written, in which case a rebuild/reinstallation is not needed and the whole Conflicts-generation can be removed.

Timo Jyrinki (timo-jyrinki) wrote :

OOo-voikko rebuild is now in "Fix committed" state in the bug 82121, so it's starting to be fixed.

Timo Jyrinki (timo-jyrinki) wrote :

Meanwhile... we've discussed on the Voikko mailing list (http://hunspell-fi.org/mailman/listinfo/devel_hunspell-fi.org) about the other language-support-fi dependencies as well.

wfinnish, aspell-fi and myspell-fi should be removed from the dependencies.

tmispell-voikko replaces wfinnish completely. aspell-fi has no direct replacement, though some programs are starting to support and prefer libenchant and its Voikko plugin (like Abiword) instead. aspell-fi is however currently responsible of underlining every other word in Gaim, because of the poor quality of spell-checking. myspell-fi interferes with openoffice.org-voikko, requiring often manual settings in OOo to use the better quality spell-checking. Then again it removes spell-checking from Thunderbird, but again the quality of myspell-fi spellchecking is so low that people should probably seek to install it themselves if they really know that they want it. Otherwise it is probably more of a disturbance.

Martin Pitt (pitti) wrote :

language-support-fi (1:7.04+20070206) feisty; urgency=low

  * Automatic update to latest translation data.
  * Added: openoffice.org-voikko, tmispell-voikko, libenchant-voikko
  * Removed: aspell-fi, myspell-fi, wfinnish

 -- Ubuntu automatic language-pack builder <email address hidden> Tue, 6 Feb 2007 08:31:23 +0000

I also promoted the five affected packages to main.

Changed in language-support-fi:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers