Ubuntu

en install ends up with en_US packages being installed

Reported by Jg-jguk on 2006-01-08
138
This bug affects 28 people
Affects Status Importance Assigned to Milestone
language-support-en (Ubuntu)
Wishlist
Unassigned
language-support-writing-en (Ubuntu)
Wishlist
Unassigned

Bug Description

Hello,
I installed Kubuntu 5.10. I completed the install and selected en_GB, with en_GB
locale and keyboard config.

When I started the system I found KDE is in locale "C" US English, and
myspell-en-us was installed, I can't remove it because there are deps:
language-support-en mozilla-firefox-locale-en-gb

Seems a little odd for en_US setup when I did not choose that, and for en_US
packages to be required for a functioning system.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The fact that you get both GB and US dictoniaries is intentional. If you disagree feel free to reopen this bugreport and assign it to language-support-en and ask for a split.

The fact that you got a en_US (or "C") desktop is puzzling but I'm sure that this does not happen anymore with dapper/edgy. I will close the bug now, please reopen if that is still the case or you disagree.

Jg-jguk (jg-jguk) wrote :

Hi Michael,

Thanks for your follow-up message.

Re: GB and US dictionaries I think both shouldn't be required, I'll do as you suggest and assign it to language-support-en and ask for US to be separated out.

Re:KDE defaulting to "C" locale, this it's because KDE_LANG is not being set, not sure why they don't use the other locale environment variables.
http://bugs.kde.org/show_bug.cgi?id=134993

Is KDE_LANG being set correctly in dapper/edgy?

Cheers
Jon

Jg-jguk (jg-jguk) wrote :

Hi,
I can't spot the way to assign the bug to language-support-en, do I have the privileges?
Jon

Jg-jguk (jg-jguk) wrote :

Michael Vogt highlighted language-support-en was the right package to assign this to, as en_US packages are tied in when we would like an English locale at present.
Jon

Hew McLachlan (hew) wrote :

I can confirm this issue. As noted in the duplicate, the dependencies should require just one dictionary to be installed, which should be the one matching the user's locale. Note also that myspell-en-au is currently left out for some reason, so all four en-* dictionaries should be made options. Fixing this issue would also reduce the complexity of bug 157921.

Changed in language-support-en:
status: New → Confirmed
Arne Goetje (arnegoetje) wrote :

I'm afraid with the current structure in our language support (by Language, not by variation) we don't have any other choice. I have some ideas already on how to change the structure of how languages are managed, but this will need to be fleshed out in a blueprint.

Changed in language-support-en (Ubuntu):
importance: Medium → Wishlist
Changed in language-support-writing-en (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Emi Bcn (emi) wrote :

Look at /usr/share/hunspell/ and delete all files you don't need/want. It's all!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers