Use the modern English name Bangla instead of Bengali for the language code bn

Bug #991002 reported by shafin on 2012-04-29
118
This bug affects 28 people
Affects Status Importance Assigned to Milestone
CLDR
Fix Released
Unknown
GLibC
Fix Released
Medium
gnome-control-center
Expired
Medium
xkeyboard-config
Fix Released
Medium
gnome-control-center (Ubuntu)
Medium
Gunnar Hjalmarsson
iso-codes (Debian)
Fix Released
Unknown
iso-codes (Ubuntu)
Undecided
Gunnar Hjalmarsson
langpack-locales (Ubuntu)
Medium
Gunnar Hjalmarsson
language-selector (Ubuntu)
Undecided
Gunnar Hjalmarsson
localechooser (Ubuntu)
Medium
Gunnar Hjalmarsson
xkeyboard-config (Debian)
Fix Released
Unknown
xkeyboard-config (Ubuntu)
Medium
Gunnar Hjalmarsson

Bug Description

The official name for the state language for Bangladesh is Bangla, as detailed on section 3, part 1 of the Bangladesh constitution (http://www1.umn.edu/humanrts/research/bangladesh-constitution.pdf). However, language selector continues to refer to this language as Bengali (Bangladeh). While Bengali has been historically used as the english name for the language during colonial periods, the name 'Bangla' is more widely used nowadays. It is also the name with which native speakers identify the language.

This package uses Bengali(Bangladesh) as the identifier for language code bn-BD. Please change the name to Bangla(Bangladesh).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: language-selector-gnome 0.79
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Sun Apr 29 16:14:25 2012
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=bn_BD:bn:en_IN:en_GB:en
 PATH=(custom, no user)
 LANG=bn_BD.UTF-8
 SHELL=/bin/bash
SourcePackage: language-selector
UpgradeStatus: Upgraded to precise on 2012-03-19 (41 days ago)

Related branches

shafin (mahdee-jameel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Changed in language-selector (Ubuntu):
assignee: nobody → Junayeed Ahnaf Nirjhor (zombiegenerator)
assignee: Junayeed Ahnaf Nirjhor (zombiegenerator) → nobody
Tanvir Ahmed (tanvir-sb) wrote :

Yes, It should be changed... This bug effects me.

Saifullah Shaquille (shaquille) wrote :

This bug effects me..... it should be changed.

Yes, It should be changed... This bug effects me.

It should be changed as soon as possible. Cause the translation Bangla(Bangladesh) have been used in our Constitute instead of Bengali(Bangladesh)

Knocking the attention!!!

Changed in language-selector (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Colin Watson (cjwatson) on 2012-10-16
affects: ubiquity → localechooser (Ubuntu)
Changed in localechooser (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

language-selector displaying Bengali is actually a bug in the iso-codes package. I have forwarded the bug to upstream (Debian), and will submit a merge proposal when we know the name of the R cycle.

Changed in iso-codes (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Changed in language-selector (Ubuntu):
status: Confirmed → Invalid
Christian Perrier (bubulle) wrote :

Comments in this bug report are very badly informed.

The iso-codes package purpose is not to provide language names in the said language (or in whatever transcription of it). The purpose of the package is to provide the list of languages codes and language names IN ENGLISH, exactly as they are in the ISO 639 standard.

The standard says "Bengali", so "Bengali" will remain in the package.

Please notice that iso-codes provides translations of its strings. For instance, for iso_639, we have a bn_IN.po file where thetranslation of "Bengali" is:

msgstr "বাংলা"

No idea whether that says "Bangla" or anything else. I suspect it's likely to be it.

The problem might come because the translation is named bn_IN.po and not bn.po. This is a very common misconception of translators that they should have different translations for different locales. Unfortunately, the consequence of this is that Bangladesh users will NOT get this translation. I suspect this might be the origin of the problem.

To make it short:
- in a list of language names in English, the language name will always be "Bengali"....at least until the ISO 639 standard is changed (good luck...)
- in a list of language names in Bengali/Bangla, it should certainly be "Bangla" (written in Bengali script of course)
- in a mixed list, like we have in Debian Installer (the original one, the one that seems too complicated to offer as a default for Ubuntu users), it should be "বাংলা - Bengali" (guess what? This is what we have in Debian Installer)

This bug should be WONTFIX and will be marked as such in Debian

tags 690739 wontfix
thanks

Quoting Gunnar Hjalmarsson (<email address hidden>):
> This bug is a forward upstream of the Ubuntu bug
> https://bugs.launchpad.net/bugs/991002

> Description: Change Bengali to the official name Bangla

Sorry, but no:

http://www.loc.gov/standards/iso639-2/php/code_list.php

The name of the language in the standard is "Bengali", so it will
remain as "Bengali" in the package.

If you want this to be changed, please get the standard changed.

Changed in iso-codes (Debian):
status: Unknown → Won't Fix

Christian,

Maybe it's true that we are very badly informed; thanks for enlightening us.

I do admit that keeping the iso-codes package in sync with applicable standards sounds reasonable, at least from a formal POV. OTOH, making exceptions, when details in the standards are apparently outdated, would also make sense IMO.

As regards translations, maybe it would be a good idea if the translation teams in Bangladesh and India cooperated on bn.po translations, and that bn_IN.po was dropped. (There is no bn_IN language pack in Ubuntu.) But even if that happened, and applied to the issue of this bug report, what you suggest would require translations of Bengali into (the local equivalent of) Bangla. Assuming that both Bangla and Bengali are existing words in Bangla (and many other languages), doing so would not be correct from a translation POV, I suppose.

I checked out whether nl_langinfo() may be of some help:

   $ cat test.c
   #include <stdio.h>
   #include <locale.h>
   #include <langinfo.h>

   main () {
      setlocale (LC_IDENTIFICATION, "bn_BD.UTF-8");
      char *lang_name = nl_langinfo (_NL_IDENTIFICATION_LANGUAGE);
      printf ("%s\n", lang_name);
   }

   $ ./test
   BengaliBangla
   $

Hmm.. Probably not.

IMO, at first hand this is about Ubuntu showing awareness of the fact that the name of the language has been changed. Giving the opposite impression is a bad idea. Making current and potential Ubuntu users, who speak Bangla, happy is better. Bangla is one of the biggest languages in the world (http://en.wikipedia.org/wiki/List_of_languages_by_number_of_native_speakers).

I tend to think that we should acknowledge that things change, and that approving the proposed merge proposal, at least in Ubuntu, is the better option. While sending a note "upstream", i.e. to ISO, of course. ;-)

"The state language of the Republic is Bangla."

After all, that sentence in the constitution of Bangladesh, is a strong argument.

Christian Perrier (bubulle) wrote :

Constitution française, article II "De la souveraineté" :

"La langue de la République est le français. "

Should we then change the name of "FR" in iso-codes to "Français"? I guess you'll say "no" and you'll be right.

The standard is a standard for names of languages *in the English language*.

And, indeed, when I read the text of the Bangladesh constituion in English (http://en.wikipedia.org/wiki/Constitution_of_Bangladesh), it reads "The state language is Bengali".

I guess that the original text is in Bengali and probably says "The state language is Bangla". This is perfectly fine, of course.

We can also find many governmental resources in Bangladesh that use "Bengali" in their *English* pages. For instance: http://www.bangladesh.gov.bd/index.php?option=com_content&task=view&id=116&Itemid=190

What's confusing here is that most Indic languages are also used in a transcripted manner, so people reading a list of languages think they should read the transcription of the language name....while they're reading the name of the language in English.

I don't want to hurt my friends in Bangladesh, but, really, the original statement in this bug report is incorrect. And I would be very very very deeply sorry if Ubuntu patches iso-codes this way. Also, please think that doing so you're opening a big giant can of worms. You'll very quickly end up in political fights, either with language names or (more likely) with country names.

I am maintaining iso-codes for 8 years now....and the only solution I found to avoid this is to stick to the standard. Strictly.

If people want things to be changed, then they have to make the standard changed.

Another reference : http://www.ethnologue.com/show_language.asp?code=ben. Ethnologue is a highly recognized resource when it comes at languages (indeed, SIL International, who maintains the site, is also the maintainer of the ISO 639-3 standard). Here, again, we have "Bengali" (Bangla appears in alternate names, admitedly, but we really can't add alternate names in lists.....and, anyway, they are not maintained in the standard).

So, really really, don't patch iso-codes in Ubuntu.

By the way, I renamed bn_IN.po to bn.po. This should be effective in the next release of iso-codes, due out November 1st (assuming Tobias Quatamer uses his usual schedule)

shafin (mahdee-jameel) wrote :

Hi bubulle,
Thanks for your well researched opinion. As the original reporter of this bug, I just want to offer some small observations on your post.

Firstly, "La langue de la République est le français. " is from the french version of the constitution. We do not necessarily requested use of the name "বাংলা" in native language. We just want the English name that is used by the republic.

Secondly, the wikipedia reference you mentioned is wrong. That is not your fault, but if you look at the original text of the constitution which is referred at the end of the wikipedia page at http://www.parliament.gov.bd/Constitution_English/index.htm , you'll see that the text contains "Bangla", not "Bengali". And this is from the official English translation of the constitution, not the Bangla version.

Just for a little more reference, there is an effort to use Bangla as one of the official languages of the United Nations, you can see at the news reports that English language newspapers refer to the language as Bangla: http://articles.timesofindia.indiatimes.com/2012-02-19/south-asia/31076849_1_sheikh-hasina-bangladesh-parliament-official-languages . From the English speech of the prime minister hosted at UN site, you can see that there is no mention of Bengali, but Bangla is used instead: http://www.un.org/en/ga/64/generaldebate/pdf/BD_en.pdf

Even BBC calls its Bangla language service "BBC Bangla"- http://en.wikipedia.org/wiki/BBC_Bangla ,and there are also a lot of examples where native speakers of English are starting to use "Bangla" instead of "Bengali".

Windows 8 also uses the name "Bangla", not "Bengali". Please see this screenshot:
https://dl.dropbox.com/u/100483406/Bangla_Win_8.JPG

All these supports my original statement that the official name of the language in English remains Bangla. This also goes on to show that a lot of high profile organizations are starting to adopt the official name instead of the colonial one.

About Ethnolouge, the problem is that they are using the old name, and that probably contributed to that name being used in ISO standards, of which they are the maintainer. Actually even in ethnologue if you dig a little deeper and see the pages for some of the languages closely related with Bangla, you'll see mentions of language names like Sylhetti Bangla : http://www.ethnologue.com/show_language.asp?code=syl or Bahe Bangla, Anchalit Bangla: http://www.ethnologue.com/show_language.asp?code=rkt but no mention of Bahe Bengali etc. So the derivative languages are already using Bangla, not Bengali.

Again my sincere thanks to you and also to gunnarhj for taking a look at this bug report. I really hope you'll start using "Bangla" in ubuntu instead of "Bengali"

shafin (mahdee-jameel) wrote :

United nations has a international mother language day, a day to celebrate the diversity of languages. You can see its page here:
http://www.un.org/en/events/motherlanguageday/

If you kindly look at the third paragraph, you can see that "International Mother Language Day has been observed every year since February 2000 to promote linguistic and cultural diversity and multilingualism. The date represents the day in 1952 when students demonstrating for recognition of their language, Bangla, as one of the two national languages of the then Pakistan, were shot and killed by police in Dhaka, the capital of what is now Bangladesh."

You can see here that the name of the language used by UN is "Bangla". And the international mother language day is celebrated on the date when some of its speakers gave up their lives to bring to others the right to speak in their mother tongue.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Christian
I won't repeat any clarifications with respect to your latest comment (#12) that shafin already made.

After having read both your and shafin's comments carefully, I still think that the arguments for making the proposed change are more convincing than the arguments against. The constitution of Bangladesh, UN ... and also the most commonly used OS. It's highly likely that sooner or later Bengali will be exchanged for Bangla in the ISO standards, so this is more like making a change some time before "upstream" (ISO) does - it's not a matter of introducing a permanent difference.

I understand that you are worried about possible consequenses of patching a language name - the "giant can of worms", as you put it. Please note that I don't advocate differences to the standard which are not very well founded; to me the Bangla/Bengali case seems to be an exceptional case. If we keep the bar high for even discussing exceptions, I'm quite sure that approving this proposal won't cause a flood of similar requests.

Nevertheless, unlike me you have a long experience of the iso-codes package, and I fear that you may think I'm naive. I have asked David Planella, Ubuntu's translations coordinator, to review the merge proposal including the comments in this bug report. I would suggest that we await his input before discussing this topic further.

On 2012-10-21 18:56, Christian Perrier wrote:
> By the way, I renamed bn_IN.po to bn.po.

Thanks! That's clearly a step in the right direction.

@shafin
Are you possibly aware of any attempts to call ISO's attention to the issue and make them change the name in the standard?

Christian Perrier (bubulle) wrote :

Whatever comments above, my stance is still the same. Iso-codes references the standard, whatever the standard is : "good" or "wrong". We even list "Taiwan, province of China" as name for Taiwan and, believe me, this is way much more controversial than Bengali/Bangla.

In short, if you want us to use Bangla in iso-codes as the English name for "bn", then get the standard changed.

As I explained already, Ubuntu maintainers are free to patch the package to use whatever name they think is appropriate. I have no way to prevent them from doing so, except 8 years experience telling me this is opening a can of worms.

But, *I* will not patch iso-codes upstream. Neither in the released tarball, nor in the Debian package. Debian will be right, whatever "right" is. Ubuntu will be wrong, whatever "wrong" it is. That won't be the first time that clumsy, short-term solutions are adopted in Ubuntu, this seems to be the way development works there, sometimes. I really don't care.

As a kind of compromise, I'll think about the possibility to add a specific field we could name "common_name" in the ISO-639 XML file. This is the trick we used for the "Taiwan" issue or the "Macedonia" issue in ISO-3166. Maybe that could work as people wanting to use iso-codes and play with alternatives (at the expense of other people not agreeing with the use of alternatives to complain), to have the possibility of doing it.

Gunnar Hjalmarsson (gunnarhj) wrote :

Christian,

First I thought that what you said about Taiwan was a joke, but I just saw it in the files... That's controversial indeed! The Bengali/Bangla issue isn't controversial at all in a similar sense, if I understand it correctly.

The possible compromise you mention would be a really good solution to this issue. Those who object (if any) may just ignore the common_name field, right? I'd really appreciate if you could make that change upstream.

Thanks, Christian, for a very constructive idea!

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Invalid → In Progress
Changed in lightdm (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Changed in iso-codes (Debian):
status: Won't Fix → New
Changed in iso-codes (Debian):
status: New → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

The iso-codes (Ubuntu) task fixed through an import from upstream (Debian).

Changed in iso-codes (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

(unsubscribing sponsors since the merge request is already in the sponsoring queue, no need to have a duplicate entry)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.93

---------------
language-selector (0.93) raring; urgency=low

  * LanguageSelector/LocaleInfo.py:
    Look first for a common_name field when grabbing a language name
    (LP: #991002).
 -- Gunnar Hjalmarsson <email address hidden> Fri, 16 Nov 2012 16:55:39 +0000

Changed in language-selector (Ubuntu):
status: In Progress → Fix Released

The current language key for bn_BD is "Bengali/Bangla" and for bn_ID it's "Bengali". Apparently, Bengali is an older colonial word. Whereas Bangla is the more modern and official version. It's widely used in the English-speaking world too (UN, BBC, Windows 8).

I'm passing this along from an Ubuntu report. I myself am not well versed in the naming issue. See https://launchpad.net/bugs/991002 and https://launchpad.net/bugs/1070581

(At the least, the slash in "Bengali/Bangla" needs to be escaped, but changing the name to not need a slash is preferrable.)

Patch coming.

Created attachment 6774
Proposed patch

Patch by Gunnar Hjalmarsson.

Changed in glibc:
importance: Unknown → Medium
status: Unknown → Confirmed
affects: lightdm (Ubuntu) → langpack-locales (Ubuntu)
Changed in langpack-locales (Ubuntu):
importance: Undecided → Medium
Changed in localechooser (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → In Progress

This bug was fixed in the package langpack-locales - 2.13+git20120306-5

---------------
langpack-locales (2.13+git20120306-5) raring; urgency=low

  * debian/patches/ubuntu-bn-language.patch: Use the official name Bangla
    for the language spoken in Bangladesh (LP: #991002, LP: #1070581).
 -- Gunnar Hjalmarsson <email address hidden> Mon, 04 Feb 2013 17:32:38 +0100

Changed in langpack-locales (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package localechooser - 2.49ubuntu2

---------------
localechooser (2.49ubuntu2) raring; urgency=low

  * languagelist: Use the official name Bangla for the language spoken
    in Bangladesh (LP: #991002).
 -- Gunnar Hjalmarsson <email address hidden> Sun, 03 Feb 2013 04:51:00 +0100

Changed in localechooser (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu15

---------------
gnome-control-center (1:3.6.3-0ubuntu15) raring; urgency=low

  * debian/control.in:
    - Build-Depends on libwebkitgtk-3.0-dev
  * debian/patches/unity_notice_info.patch:
    - display "Legal Notice" in the infos dialog (lp: #1130158)
  * debian/searchingthedashlegalnotice.html,
    debian/gnome-control-center-data.install:
    - copy notice text from unity, will be updated later
 -- Sebastien Bacher <email address hidden> Fri, 15 Mar 2013 18:40:53 +0100

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → In Progress
Changed in xkeyboard-config (Debian):
status: Unknown → Confirmed

Created attachment 90202
Replace "Bengali" with "Bangla"

This is a forward of the Ubuntu bug https://launchpad.net/bugs/991002

We try to consistently use the name Bangla all over Ubuntu for the
language spoken in Bangladesh and in some Indian regions. This requires
changes to xkeyboard-config, where language names are hard coded.

We believe it would be a good idea to make this change upstream as well.

Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Confirmed
summary: - Change name for bn-BD from 'Bengali(Bangladesh)' to
- 'Bangla(Bangladesh)')
+ Use the modern English name Bangla instead of Bengali for the language
+ code bn

fine, thank you!

Changed in xkeyboard-config:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.10.1-1ubuntu1

---------------
xkeyboard-config (2.10.1-1ubuntu1) trusty; urgency=low

  [ Dmitry Shachnev ]
  * Merge with Debian unstable, remaining changes:
    - control, rules, xkb-data-i18n.install, xkb-data.install: Split out
      xkb-data-i18n to be used by console-setup.
    - xkb-data.postinst.in: Remove the xkb cache to make sure it gets
      regenerated.
    - 105_intelligent_keyboard.patch: Add support for the Intelligent
      Keyboard K04.
    - 108_fix_intltool_make_check.diff: Fix make check in the presence
      of the quilt patch system.
    - Add multi-arch support.
  * Dropped change (Ubuntu 12.04 LTS has a version newer than 1.9):
    - Migrate settings from dvorak-intl to dvorak-alt-intl to match rename
      in xkeyboard-config 1.9.

  [ Gunnar Hjalmarsson ]
  * debian/patches/bengali_to_bangla.patch:
    Use the modern language name Bangla instead of Bengali (LP: #991002).

xkeyboard-config (2.10.1-1) unstable; urgency=low

  [ Dmitry Shachnev ]
  * New upstream release (closes: #718730).
  * Refresh revert-goodmap-badmap-for-apple.diff.
  * Drop preserve-shift.diff, applied upstream.
  * Update debian/watch for new tarballs location (closes: #727812).
  * Disable autopoint, it causes build failure and we use intltoolize
    instead.
  * Bump Standards-Version to 3.9.5, no changes needed.
 -- Dmitry Shachnev <email address hidden> Sun, 29 Dec 2013 11:43:52 +0400

Changed in xkeyboard-config (Ubuntu):
status: In Progress → Fix Released
Changed in xkeyboard-config (Debian):
status: Confirmed → Fix Released
Changed in cldr:
status: Unknown → New
Changed in cldr:
status: New → Confirmed
Changed in cldr:
status: Confirmed → Fix Released
Changed in gnome-control-center:
status: New → Confirmed
Changed in glibc:
status: Confirmed → Incomplete
Changed in glibc:
status: Incomplete → Fix Released
Changed in gnome-control-center:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.