fontconfig-voodoo crashed with CalledProcessError in check_output(): Command '['/usr/share/language-tools/language2locale', '']' returned non-zero exit status 1

Bug #926049 reported by Gary Poster on 2012-02-03
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Unassigned

Bug Description

Upgraded Precise as of less than 15 minutes ago. I was not doing anything in particular when it crashed--Thunderbird, XChat, Chromium, Terminal & Emacs were running.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: language-selector-common 0.64
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Fri Feb 3 08:24:42 2012
ExecutablePath: /usr/bin/fontconfig-voodoo
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/fontconfig-voodoo --auto --quiet
ProcEnviron:
 PATH=(custom, no user)
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/fontconfig-voodoo', '--auto', '--quiet']
SourcePackage: language-selector
Title: fontconfig-voodoo crashed with CalledProcessError in check_output(): Command '['/usr/share/language-tools/language2locale', '']' returned non-zero exit status 1
UpgradeStatus: Upgraded to precise on 2012-01-23 (10 days ago)
UserGroups:

Gary Poster (gary) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2012-02-06
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.65

---------------
language-selector (0.65) precise; urgency=low

  [ Colin Watson ]
  * check-language-support: Ignore errors from locale.setlocale. We might
    well be running from the installer before locales have been properly
    configured (LP: #925330).
  * Clean up lots of pyflakes warnings.
  * LanguageSelector/FontConfig.py, LanguageSelector/LocaleInfo.py,
    LanguageSelector/utils.py: Use string methods rather than deprecated
    string functions.

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/LocaleInfo.py: Prevent makeEnvString() from
    processing the empty string (LP: #926049).
  * fontconfig/30-cjk-aliases.conf: Changes due to Korean migration to
    fonts-nanum (LP: #792471).
  * debian/control: pyqt4-dev-tools added to build-depends (the pyuic4
    program is called from LanguageSelector/qt/Makefile).

  [ Martin Pitt ]
  * debian/control: Use standard X-Python-Version field.
  * debian/control: Bump Standards-Version to 3.9.2.
  * debian/control: Move transitional packages to Priority: Extra to quiesce
    lintian.
  * debian/control: Drop Vcs-Bzr. We move to the standard
    lp:ubuntu/language-selector branch now.
 -- Martin Pitt <email address hidden> Mon, 06 Feb 2012 07:23:43 +0100

Changed in language-selector (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers