After regional formats are set to Dutch on an English system, Software Center asks permission using a mixture of Dutch and English

Bug #877610 reported by Gerhard Burger on 2011-10-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
accountsservice (Ubuntu)
Undecided
Gunnar Hjalmarsson
language-selector (Ubuntu)
Undecided
Gunnar Hjalmarsson

Bug Description

After setting Regional Formats to Dutch (leaving the menus and interface language in English), logging out and in, the permission to install a program with the Software Center is asked in a mixture of Dutch and English. See screenshot. The expected behavior is that only date, time and currency formats are affected. Happened on a clean 11.10 64 bit install.

Gerhard Burger (burger.ga) wrote :
description: updated
summary: - After regional formats are set to Dutch on an English system,
- permissions are asked using a mixture of Dutch and English
+ After regional formats are set to Dutch on an English system, Software
+ Center asks permission using a mixture of Dutch and English
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your effort to improve Ubuntu by reporting this issue. I too encounter similar mixed language messages occationally.

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
Phil. V (philip.v) wrote :

Please include the version of Ubuntu that you are running in your report. Under 11.10 64 bit I was unable to reproduce your exact problem; the prompt requesting elevated privileges from the software center was fully translated. A prompt requesting elevated privileges for changing proxy settings was not fully translated, however, as the title was in English "System policy prevents setting proxy settings". It's possible other prompts aren't fully translated as well, so this should certainly be looked into. Did you ensure that you set not only regional formats to dutch but also the system language to dutch? From your report that is unclear.

Gerhard Burger (burger.ga) wrote :

sorry for the confusion I was indeed not very specific in my problem report, I am running 11.10 64bit. However, I only changed the Regional Formats to Dutch since I like to keep my menus and interface in English. I will fix it in the description as well.

description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

Gerhard Burger wrote:
> I only changed the Regional Formats to Dutch since I like to keep my
> menus and interface in English.

And that combination should indeed work. Any occurrence of a message translated into Dutch is buggy behavior in your case.

Changed in language-selector (Ubuntu):
status: Confirmed → In Progress
Martin Pitt (pitti) on 2012-02-02
Changed in accountsservice (Ubuntu):
status: New → In Progress
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
Martin Pitt (pitti) on 2012-02-02
Changed in accountsservice (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.15-2ubuntu3

---------------
accountsservice (0.6.15-2ubuntu3) precise; urgency=low

  [ Gunnar Hjalmarsson ]
  * debian/patches/0001-formats-locale-property.patch and
    debian/libaccountsservice0.symbols:
    - Addition of FormatsLocale property and SetFormatsLocale method.
  * debian/patches/0009-language-tools.patch:
    - Make SetLanguage() and SetFormatsLocale() write to
      ~/.pam_environment instead of ~/.profile (LP: #866062).
    - Make the LANG variable, which up to now has represented regional
      formats, denote the display language instead (LP: #877610).
  * debian/patches/0010-set-language.patch:
    - If the Language or FormatsLocale property is not yet set when
      queried, respond with a sensible, dynamically generated fallback
      value.
    - Code added for migrating ~/.profile environment settings to
      ~/.pam_environment.
    - Don't alter any settings if SetLanguage is called from a language
      chooser on the greeter and /home is encrypted or not yet mounted.
    - Misc. code refactoring.
  * debian/accountsservice.postinst:
    - Modify /etc/default/locale and /etc/environment due to a changed
      meaning of the LANG environment variable.

  [ Martin Pitt ]
  * debian/accountsservice.postinst: Only run the LANG migration when
    upgrading to this version. Also, slightly improve the call to grep.
  * debian/libaccountsservice0.symbols: Fix versions of symbols from
    0001-formats-locale-property.patch.
  * debian/libaccountsservice0.symbols: Add new symbols from 0.6.15-2ubuntu1.
  * debian/accountsservice.postinst: In the LANG migration, do not add all the
    variables to a file which doesn't define LANG, so that we don't repeat
    them in /etc/environment when they are already in /etc/default/locale.
 -- Martin Pitt <email address hidden> Fri, 03 Feb 2012 06:42:19 +0100

Changed in accountsservice (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.63

---------------
language-selector (0.63) precise; urgency=low

  [ Martin Pitt ]
  * LanguageSelector/LanguageSelector.py: Fix KeyError crash on a nonexisting
    package. (LP: #843430)
  * language_support_pkgs.py: Add PackageKit WhatProvides() plugin for
    "locale()" search. Register it in setup.py.
  * LanguageSelector/LangCache.py, data/blacklist, setup.py: Drop support for
    data/blacklist, we haven't needed it for a long time, and don't intend to
    bring back this hack.
  * dbus_backend/ls-dbus-backend: Drop GetMissingPackages{,Async} methods. The
    current code isn't using them, and there is no need to have this in a
    D-BUS service. language_support_pkgs works fine as user in frontends.
  * Drop tests/test_dbus_backend.py. It only exercised above method, not the
    "set system-wide locale" bits.
  * Drop LanguageSelector/CheckLanguageSupport.py,
    dbus_backend/ls-dbus-backend: Not used by anything any more, obsoleted by
    language_support_pkgs.py.
  * LanguageSelector/LanguageSelector.py: Reimplement getMissingLangPacks()
    using language_support_pkgs.py. This gets rid of a lot of redundant and
    bad code.
  * Change code to use the LanguageSelector.LangCache namespace more
    explicitly, to make it easier to get rid of LangCache.
  * LanguageSelector/LangCache.py: Remove yet another copy of the pkg_depends
    evaluation logic, and some more dead code, rewrite using
    language_support_pkgs.
  * Drop tests.moved/. Unused, no automatic tests, not very useful.
  * LanguageSelector/LangCache.py, LanguageSelector/qt/QtLanguageSelector.py:
    Drop last remainders of the languageSupport* info, language-support-* were
    dropped several cycles ago.

  [ Gunnar Hjalmarsson ]
  * Make the LANG variable, which up to now has represented regional
    formats, denote the display language instead (LP: #877610).
  * Make use of accountsservice's FormatsLocale property and
    SetFormatsLocale method when selecting a user's regional formats.
    (LP: #866062)
  * When setting the system-wide language, ensure that the system
    regional formats locale is set in order to prevent surprise
    changes of the formats.
  * data/LanguageSelector.ui: Text about rebooting no longer
    applicable, so removed.
  * LanguageSelector/LocaleInfo.py: Encode @variant string in the
    translate() function as UTF-8 to avoid a UnicodeDecodeError if a
    locale with @variant is selected for regional formats.
  * debian/control: Bump accountsservice dependency to >= 0.6.15-2ubuntu3,
    to ensure that we have the new SetFormatsLocale method.
  * debian/control: Make im-switch a dependency of language-selector-gnome,
    since it's no longer a dependency of ibus (LP: #908762).
 -- Martin Pitt <email address hidden> Fri, 03 Feb 2012 07:01:24 +0100

Changed in language-selector (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers