gnome-language-selector crashed with AttributeError in _full_callback(): Handler on_treeview_languages_cursor_changed not found

Bug #859961 reported by Nicolas DERIVE on 2011-09-26
334
This bug affects 67 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Gunnar Hjalmarsson

Bug Description

Applying regional formats to the wide system, I got this crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: language-selector-gnome 0.53
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
CheckboxSubmission: 52c8d1e1dc4f870adb17edbee465da09
CheckboxSystem: 0886efe3e95f2342b20ae33cd4eb5c2a
Date: Mon Sep 26 21:52:14 2011
ExecutablePath: /usr/bin/gnome-language-selector
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gnome-language-selector
PythonArgs: ['/usr/bin/gnome-language-selector']
SourcePackage: language-selector
Title: gnome-language-selector crashed with AttributeError in _full_callback(): Handler on_treeview_languages_cursor_changed not found
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 348, in _full_callback
     raise AttributeError('Handler %s not found' % handler_name)
 AttributeError: Handler on_treeview_languages_cursor_changed not found
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Nicolas DERIVE (kalon33) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your help to improve Ubuntu by reporting this issue. The linked branch includes a proposal that should fix this bug.

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → In Progress
Bernard Decock (decockbernard) wrote :

The language selected is grayed out after updating the latest packages. Clicking on the language wanted generates this bug.

Gunnar Hjalmarsson (gunnarhj) wrote :

I would think that this bug happens once you start Language Support, but that the dialog that tells you about it appears only a few seconds later. If you start gnome-language-selector from a terminal window, you'll probably come to the same conclusion.

Arik Kfir (arikkfir) wrote :

For me it happened after I opened the Language Support dialog from the system settings window.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Arik
Yes, you don't need to do anything else. That's what I meant too.

Anyway, this bug will go away with the next language-selector version.

Thank you (I don't know that anyone will write to me). After computer
restart My language was installed, so this bug probably is not so serious.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.54

---------------
language-selector (0.54) oneiric; urgency=low

  * data/LanguageSelector.ui:
    - Reference to the handler "on_treeview_languages_cursor_changed",
      which was removed in v. 0.53, dropped (LP: #859961).
    - Property "relief" for help button reinserted.
  * LanguageSelector/LangCache.py [change not affecting KDE]:
    - Don't confuse the UI by testing whether dropped metapackages
      are installed. Makes a difference on upgraded systems where
      (traces of) such packages are left on disk from previous
      language installations (should affect LP: #841712).
 -- Gunnar Hjalmarsson <email address hidden> Wed, 28 Sep 2011 17:21:13 +0200

Changed in language-selector (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers