fontconfig-voodoo crashed with DBusException in __new__(): org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

Bug #856975 reported by Mike Durham on 2011-09-23
146
This bug affects 17 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Martin Pitt

Bug Description

Just booted and ran firefox, then this happened.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: language-selector-common 0.52
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Fri Sep 23 11:11:23 2011
ExecutablePath: /usr/bin/fontconfig-voodoo
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110531.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/fontconfig-voodoo --auto --quiet
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/fontconfig-voodoo', '--auto', '--quiet']
SourcePackage: language-selector
Title: fontconfig-voodoo crashed with DBusException in __new__(): org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Mike Durham (mdurhamesq) wrote :

This crash has the same stack trace characteristics as bug #830938. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-09-26
Changed in language-selector (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

This is a bit inexplicable, as the system d-bus should be running pretty much at all times. I see that language-selector does not explicitly depend on dbus, thus it is not guaranteed that dbus is configured when the postinst runs. I fixed that in bzr, but it's unlikely to have any practical effect.

If you get this crash report right after login, it's very likely that it happend during the previous session, or for another user, and session start just shows all the crashes which were not presented yet.

This seems to be a corner case, lowering priority.

Changed in language-selector (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
importance: High → Low
status: In Progress → Confirmed
tags: added: bugpattern-needed
Eduardo Riesco (eduardo.riesco) wrote :

Ok Martin, I found the problem. I installed the system but I used an old /home partition. This gave me some problems like this.
Finally I reinstalled again and everything works.
You can close this bug.
Sorry for make you loose your time.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Eduardo
Great that it works for you, but there is likely more into it. There are a bunch of fresh duplicates of this bug, so it should be kept open.

tags: removed: bugpattern-needed
tags: added: bugpattern-written
Xavier Bassery (xaba) wrote :

I had this bug after having upgraded precise from a "recovery mode" boot (from grub).
I guess that this is such a case where dbus is not running.
In my case, this confirms Martin's opinion on the cause of this bug.

I see this every time I boot the Xubuntu Oneiric install CD (without "quiet splash" in boot options).

Begin: Enabling detection of crashes... ... done.
Begin: Disabling unnecessary KDE services... ... done.
Begin: Fixing language selector... ... Traceback (most recent call last):
/usr/bin/fontconfig-voodoo

File "/usr/lib/python2.7/dist-packages/dbus/dbus.py", line 125, in __new__
  bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
DBusException: org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket
 /var/run/dbus/system_bus_socket: No such file or directory

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/856975

tags: added: iso-testing
Martin Pitt (pitti) wrote :

Ah, I bet I know what happens: There is a casper script ./scripts/casper-bottom/35fix_language_selector which calls

  chroot /root fontconfig-voodoo --auto --quiet

This happens at a time when there is no D-BUS running. I'll see to making this work without D-BUS.

Changed in language-selector (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Low → Medium
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Fixed in bzr.

Changed in language-selector (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.69

---------------
language-selector (0.69) precise; urgency=low

  * LanguageSelector/LocaleInfo.py, getUserDefaultLanguage(): Fix crash if
    system D-BUS is not running, which happens when running fontconfig-voodoo
    from casper. (LP: #856975)
  * debian/control: "Ubuntu Linux" → "Ubuntu". (LP: #919972)
  * data/pkg_depends: Move mozvoikko to xul-ext-mozvoikko.
  * data/pkg_depends: gedit and sylpheed use libenchant now, move these from
    aspell to hunspell dictionaries.
  * Close window on "Esc". (LP: #614933)
  * LanguageSelector/gtk/GtkLanguageSelector.py: Intercept errors from
    aptdaemon transactions and stop waiting for the transaction to finish on
    an error. (LP: #863875)
 -- Martin Pitt <email address hidden> Thu, 09 Feb 2012 14:41:43 +0100

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Tyler Gates (tgates81) wrote :

Martin,
   I am using Oneiric with languages-selector 0.56.1 which does not have this fix nor the ability to upgrade to it. Would you please provide a patch? I diffed the latest (0.75) but there appears to be many unrelated differences.

Tyler Gates (tgates81) wrote :

Nevermind, I was finally able to dig up version 0.69 and patch manually.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers