Let you install only the translations (not the input methods, dictionnaries, etc)

Bug #856217 reported by Sebastien Bacher on 2011-09-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
High
Martin Pitt
Oneiric
High
Martin Pitt

Bug Description

The Oneiric beta2 version seems to only let you install langpacks but not the dictionnaries, input methods, etc

* open language-selector
* click on add,remove
* select a language and look the boxes at the bottom, only the translation one can be ticked

Changed in language-selector (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

@Sebastien,
As you may remember, we talked about this a few weeks ago, and agreed it was an issue then. However, for me it seems to have been fixed somehow, i.e. if I select a language for which more than translations are available, the applicable check boxes can be ticked.

For instance, if I select Italian, the "Spell checking and writing aids" box can be ticked, and if I select Japanese, both the "Input methods" and "Extra fonts" boxes can be ticked.

Sebastien Bacher (seb128) wrote :

Hi Gunnar, thanks for commenting, I tested again on my laptop which has the recent 0.52 update and it still doesn't work for me, I've also tested on a french beta2 install yesterday without success. I've tried to select english, italian, german, only the translations can be ticked, for french I've the dictionnaries box checked (since I've those installed) and I can uncheck it but I can't do it for "new" languages ... do you know where is the code which checks if dictionnaries, etc are available for the locale?

Gunnar Hjalmarsson (gunnarhj) wrote :

Unfortunately, when testing on a fresh b2, I got the same result as you. Previously I tested on my main partition, and the fact that I can check quite a few boxes there is probably because I have had quite a few languages installed there for testing purposes. Besides, input methods etc. are not installed even when checked. (When starting l-s next time, other boxes than the translation box are unchecked again.)

This is a rather serious issue, right?

Gunnar Hjalmarsson (gunnarhj) wrote :

As regards the code, I think that LanguageSelector/LangCache.py is one important file.

Martin Pitt (pitti) on 2011-09-26
Changed in language-selector (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

At least for me enabling a language that way actually does install all the extra fonts etc., it just seems to be a problem of the checkboxes in the GUI.

Changed in language-selector (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
tags: added: regression-release
Martin Pitt (pitti) wrote :

Ah, these check boxes only controlled whether or not to install e. g. language-support-fonts-XX and the like. These language-support-* packages are gone from Ubuntu, so I think we just ought to disable these check boxes entirely.

Martin Pitt (pitti) on 2011-09-26
Changed in language-selector (Ubuntu Oneiric):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.53

---------------
language-selector (0.53) oneiric; urgency=low

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/LocaleInfo.py:
    - Change of makeEnvString() in v. 0.52 reversed. Didn't work
      as expected; old simpler code sufficient for now
      (fixes LP: #858184).
    - New function for testing whether the user language is set
      completely.
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - When setting the own regional formats, ensure that the user
      language is set completely in order to prevent a surprise change
      of the display language.

  [ Martin Pitt ]
  * debian/control: Explicitly depend on "dbus", to ensure that it is
    configured at the time the postinst runs. Might help for bugs like
    LP #856975.
  * LanguageSelector/LangCache.py: Add a __str__() method to
    LanguagePackageStatus class, to ease debugging.
  * debian/control: Add missing python-kde4 dependency to l-s-kde.
  * Drop the details expander from the GTK UI for the "fonts/writing
    aids/etc." checkboxes. These were used to install language-support-*-XX
    metapackages which got dropped. (LP: #856217)
  * tests/test_check_language_support.py: Fix test case for current number of
    language support packages: -ar installs exactly 5, so reduce the "> 5"
    check to "> 3".
 -- Martin Pitt <email address hidden> Mon, 26 Sep 2011 15:29:50 +0200

Changed in language-selector (Ubuntu Oneiric):
status: Fix Committed → Fix Released

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 09/26/2011 06:57 PM, Martin Pitt wrote:
> Ah, these check boxes only controlled whether or not to install e. g.
> language-support-fonts-XX and the like. These language-support-*
> packages are gone from Ubuntu, so I think we just ought to disable these
> check boxes entirely.
>
Hmm... and how are the users now going to install an input method module
for, let's say Japanese, without installing all the translations?
I.e. I just want to be able to type Japanese, but I don't care about the
localized GUI, since it's not my native language, or I just prefer the
English GUI.
The checkboxes were there for exactly this reason. Being able to just
display (fonts), or type (input methods) a language without having to
install the translations.

If you want the users to do this in software center, you need to add a
simple interface for them to choose what they want:
* Fonts -> Language -> Install
* Input Method -> Language -> Install

Until then, please don't remove this functionality.
If you decide to put all the dependency handling into the application,
fine. But then please fix the checkboxes, so that they use the same
mechanism.

Just my two NT$.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBCAAGBQJOgUVhAAoJENiwmJtstTzsprcQAL07oVgmIEZmGlPyIH+1rfrC
zxIMb5FXo+C54gV3uzye594LalFP7JTp9nyIhluWEBLn7BmsnPuilm9Lpte6svVj
fCiUDrGFKiBPA2TIA88Ce4M7CwMKZ1tLhHx+ruKqYRatlZrZyv0VewDTqcavUrbL
xFRoaOQMzzLyUWyB1AWkG6QRxkPo8yUtH8VC4WXXF2Ld/xFLakv8oikGbhCTIQLj
87ef+PdK+MvGpInImiYVj/zmshG6nq/dphvm1ApF5IoX7ULCZwHxWuYbGoYgC4KE
Q6wPrHfq2dgtDJgSGBLoHt6mXwg1LkRTt0F0LFKd4W6ggS/jydreeZDI5rD+8Y37
hx83S+5/uQ0KJVmnkPDB2z2GEkGMSE2ETfF1HYvX3BqmiG0mxY2WQw9mgO2bRNlP
I+An5RbVY08o5+RgVUVuycuHGol4VYuQdwm2yCOXO7JrT/+CGuWbAWf8XhIoVl8I
mnCXmPOY/fl+IQMjHp8Tx4jgU78FSolAdUvTmuzk1Fh7rcZQRcdXBqNAUazVVP4u
G9rVUQZ9AP7NP0sm/P1Ruxb4emTqzR5Jnxhorrfsy38IWwkBYiEzzFNiffhuW00u
nThvFsy9moscPDoCFcQAxPb5gnHW9sSt0oAxk6T5kZPLANEkzRjSXYKTjpj4+hX6
HRTgBXDrkfY89abLe+a3
=xzmb
-----END PGP SIGNATURE-----

Martin Pitt (pitti) wrote :

Arne Goetje [2011-09-27 3:39 -0000]:
> Hmm... and how are the users now going to install an input method module
> for, let's say Japanese, without installing all the translations?
> I.e. I just want to be able to type Japanese, but I don't care about the
> localized GUI, since it's not my native language, or I just prefer the
> English GUI.
> The checkboxes were there for exactly this reason. Being able to just
> display (fonts), or type (input methods) a language without having to
> install the translations.

Yes, I'm aware of that. But at this time of the freeze actually
re-implementing this feature would be too intrusive and take too much
time, I'm afraid.

Arne Goetje (arnegoetje) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 09/27/2011 12:13 PM, Martin Pitt wrote:
> Arne Goetje [2011-09-27 3:39 -0000]:
>> Hmm... and how are the users now going to install an input method module
>> for, let's say Japanese, without installing all the translations?
>> I.e. I just want to be able to type Japanese, but I don't care about the
>> localized GUI, since it's not my native language, or I just prefer the
>> English GUI.
>> The checkboxes were there for exactly this reason. Being able to just
>> display (fonts), or type (input methods) a language without having to
>> install the translations.
>
> Yes, I'm aware of that. But at this time of the freeze actually
> re-implementing this feature would be too intrusive and take too much
> time, I'm afraid.
>
Then please document this change and give the users a Howto to get the
same result. And please put this in a prominent place! I predict that
many users will be confused and will rant about this change...

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBCAAGBQJOgW40AAoJENiwmJtstTzsyyEP/23j55OjlUq0CYenvITW1Gw1
z0x1MM8rKiVBQVruRB9SZFajExPzbgWEzT4l97491xNStsltAV11Hv6fUSQTFby1
JU1075nAacG12uz3j3rfHP7yj8EKmbwXVw2dIKAfodnfkPXBSfvItnU/tsnk2+1n
u3hZPMBgP3fSGhtAviDBBaHVH4q8X1zZbOYNxXxuMlHDpOE9XAaxe76YG4MxOs7u
5EzZJ/9QLj4Yq6S6/MbXE5q5IaRRDURFGgVzjhsueq4JvWCxAAfm1s8EiEHEFggo
T7ZCURWiIJ6FLFMHw7/pjucT4DRxe5/NMoY8aRfXEgTjZmzIampy1P+T6nVAsDUZ
Pqg+WtDQaBgSIDpmc2ltzJK/amOTdeLOViTcN9YcOym1m22myGfleMZHz7kQRR5C
pu/qzs428+IQIPcX1Q31RLzTgTZaC+Gr4EylcVR6I6PW2bX4l9NfJ5cr0X1PGw/f
OriMtW+MjusiIjxm1hxCXbo5ijBZUt81ySLlNWQU7KO0dzdwYhuPFpM7yJaJtm9L
787969XhwIZvxxlVMy9Zk9Yy3GqX/uAwIGRHLylBgDTo7H5boKITgENF2+HG8dFL
E+X/1rFbdKVmoKXSQE4/TClEDl65GEB64y0CQgPR62x+MVTQ9gLPwEUZp53kiCig
IxvvDpErfvqTSKKZXQxu
=e0S4
-----END PGP SIGNATURE-----

Gunnar Hjalmarsson (gunnarhj) wrote :

I have no own firm opinion on this design change, but a couple of hours ago I saw this comment on the topic:
https://bugs.launchpad.net/ubuntu/+source/language-selector/+bug/841712/comments/3

Franko Burolo (fburolo) wrote :

Yep, I am ranting, too. It's a regression, not a benefit. As a slavistics and italianistics student, I need italian, slovenian and serbian cyrillic writing support (+ english is sometimes useful, too), because I read and write in all those languages for study and work, while my native (and default GUI) language is croatian. Am I supposed to have 4 (or even 5) different complete language packs installed on my system now? It would be crazy, I don't need all that. I want my GUI to be in croatian, while being able to use all the benefits of writing in other languages, without the need of installing all those translations.
I want those checkboxes back. At least, make an "Advanced" button or something that would let us choose more in detail what language packages we exactly need, in case we don't need them all... The actual design is very bad for people working with various languages. The way it was before was just great. I was always promoting Ubuntu among my co-students for this feature, not anymore... :-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers