[natty] fontconfig-voodoo -a does not work in Japanese locales

Bug #778869 reported by Fumihito YOSHIDA on 2011-05-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Unassigned
maverick-backports
Fix Released
Undecided
Unassigned
language-selector (Ubuntu)
Undecided
Gunnar Hjalmarsson
Natty
Undecided
Unassigned

Bug Description

Binary package hint: language-selector

This report is proxy-ed from https://forums.ubuntulinux.jp/viewtopic.php?id=11207 , thank you for original reporters.

In Natty with Japanese locales, fontconfig-voodoo -a does not create
69-language-selector-ja-jp.conf in some situation. That works in maverick.

Notes: This bug seems reproducical in ko_KR. But zh_CN/zh_TW/zh_HK seems fine.

-------------------------------------------------------------------------
How to reproduce:
1) Install natty with Japanese language.
2) Open language-selector
  (e.g.: Type Alt+F2 and "gnome-language-selector")
3) exec:
 sudo rm /etc/fonts/conf.d/69-language-selector-ja-jp.conf
4) exec:
 sudo fontconfig-voodoo -a

Actual result:
 /etc/fonts/conf.d/69-language-selector-ja-jp.conf is not created.

Expected/mavericks result:
 /etc/fonts/conf.d/69-language-selector-ja-jp.conf is created.

Workaround:
 exec:
$ sudo fontconfig-voodoo -s ja_JP
-------------------------------------------------------------------------
Second face of this bug:
This behavior cause some side effects (probably critical for
non-geeky users).

1) Install natty with Japanese language.
2) Open language-selector
  (e.g.: Type Alt+F2 and "gnome-language-selector")
5) in "Language for menus and windows:" list,
   set Japanese(日本語) as your non-primary(such as 2nd of list).
6) Push [Apply System-Wide] button, and close language-selector
7) check /etc/fonts/conf.d/69-language-selector-ja-jp.conf ,
   /etc/fonts/conf.d/69-language-selector-ja-jp.conf is erased.
   This is expected behavior, but...
8) re-open language-selector
9) in "Language for menus and windows:" list,
   set Japanese(日本語) as your primary(top of list).
10) Push [Apply System-Wide] button, and close language-selector
11) check /etc/fonts/conf.d/69-language-selector-ja-jp.conf ,
    /etc/fonts/conf.d/69-language-selector-ja-jp.conf is not created....

So, that erase 69-language-selector-ja-jp.conf , and could not recoverable
with language-selector.
---------------------------------------------------------------------------
Im my grasp, look at affection through the lens of /etc/fonts/conf.d/,
"fontconfig-voodoo -a" same as "fontconfig-voodoo -s ja_JP".
But "fontconfig-voodoo -s ja_JP" works fine, may be something went
wrong in fontconfig-voodoo -a codes.

related configs are:

$ grep 'ja:' /usr/share/language-selector/data/langcode2locale
ja:ja_JP

$ cat /var/lib/locales/supported.d/ja
ja_JP.UTF-8 UTF-8

$ cat /var/lib/locales/supported.d/local
ja_JP.UTF-8 UTF-8
en_US.UTF-8 UTF-8

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: language-selector (not installed)
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sat May 7 13:28:07 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
ProcEnviron:
 LANGUAGE=ja:en
 LANG=ja_JP.UTF-8
 SHELL=/bin/bash
SourcePackage: language-selector
UpgradeStatus: No upgrade log present (probably fresh install)

Fumihito YOSHIDA (hito) on 2011-05-07
description: updated
tags: removed: unity-2d
Gunnar Hjalmarsson (gunnarhj) wrote :

This is a regression bug due to the language-selector solution of bug #693337. A fix is proposed to be uploaded to Oneiric (branch linked), and an updated build is available in my PPA (https://launchpad.net/~gunnarhj/+archive/misc).

Since the fontconfig-voodoo feature is of high importance to CJK users, while it's partly broken for Japanese and Korean users, I would suggest that the fix is uploaded as a Natty SRU as well.

Thanks for reporting this bug, and sorry for the inconvenience.

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Fumihito YOSHIDA (hito) wrote :

> A fix is proposed to be uploaded to Oneiric (branch linked), and an updated build is available in my PPA (https://launchpad.net/~gunnarhj/+archive/misc).

ppa packages work fine for my natty environments, thank you for quick fixing.

@Gunnar ,
In the fix of bug #693337, that provides {lucid,maverick}-backports, are they affect too?
If yes (or probably/maybe yes), I(we?) will test with these backports.

Gunnar Hjalmarsson (gunnarhj) wrote :

I didn't think of the backports, but now when you ask, so yes, they probably have the same bug.

I'd appreciate if you could test them. If you confirm that they too suffer from the bug, I'll propose tomorrow that similar fixes be added to the backports.

Thanks!

Fumihito YOSHIDA (hito) wrote :

@Gunnar,

I check with {lucid, maverick} with backports(0.5.8+langfixes~lucid1 , 0.6.8+langfixes~maverick1), I can reproduce the bug.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for confirming that, Fumihito.

I propose that equivalent changes are merged into the Lucid and Maverick backports. Branches with the changes (links above) were uploaded to my PPA (https://launchpad.net/~gunnarhj/+archive/lang-backports), and the resulting builds have been installed and run successfully.

When working with the backports, I realized that the changes in the branch intended for Oneiric and Natty were not sufficient; while they addressed the command "fontconfig voodoo -a", the failure to set the configuration by clicking the "Apply System-Wide" button in Language Support hadn't been dealt with. I updated the branch accordingly, so now the merge proposal for Oneiric should be ok. An updated build is available at https://launchpad.net/~gunnarhj/+archive/misc .

@Fumihito
Since the changes will go to lucid-backports, maverick-backports, and - hopefully - natty-proposed, your assistance with testing these new branches would be valuable.

Changed in lucid-backports:
status: New → Confirmed
Changed in maverick-backports:
status: New → Confirmed
Martin Pitt (pitti) on 2011-05-18
Changed in language-selector (Ubuntu):
status: In Progress → Fix Committed
Changed in language-selector (Ubuntu Natty):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.35

---------------
language-selector (0.35) oneiric; urgency=low

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/FontConfig.py:
    - Make the fontconfig-voodoo --auto option work also when the first
      LANGUAGE item is just 'ja' or 'ko', i.e. without country code
      (LP: #778869).
  * dbus_backend/ls-dbus-backend:
    - When applying the language settings system-wide, set the fonts
      configuration also when the first LANGUAGE item is just 'ja' or
      'ko' (LP: #778869).
  * fontconfig-voodoo:
    - Do not require --force when removing the current config using the
      fontconfig-voodoo -r option.
    - Print an exception message if the --auto option fails to find a
      suitable configuration.

  [ Martin Pitt ]
  * tests/test_check_language_support.py: Fix test case for removed
    gnome-user-guide-XX packages.
  * LanguageSelector/gtk/GtkLanguageSelector.py: Stop forcing GTK2, moving to
    GTK 3 now. Update GIR dependencies to the GTK 3 versions.
 -- Martin Pitt <email address hidden> Wed, 18 May 2011 09:35:29 +0200

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

It's not clear to me that this has been tested in a lucid/maverick environment and it should be before upload to backports, but I'm generally in favor of this.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks, Scott. As regards testing, please see comment #5. The installations and tests I mentioned were in Lucid respective Maverick.

Accepted language-selector into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in language-selector (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

Successfully installed and run language-selector 0.34.2. In particular:

* When making Japanese the system language, a link to the Japanese
  fontconfig file is added to /etc/fonts/conf.d as expected, even if
  the first item in LANGUAGE is just 'ja', i.e. without country code
  (since there are no country specific Japanese translations on my box).

* Running the command "sudo fontconfig-voodoo -a", when the list in the
  LANGUAGE environment variable begins with 'ja', adds a similar link
  as expected if it wasn't there before.

tags: added: verification-done
removed: verification-needed
Changed in lucid-backports:
status: Confirmed → In Progress
Changed in maverick-backports:
status: Confirmed → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Realize that I wasn't supposed to set the "verification-done" tag, so changing back to "verification-needed".

tags: added: verification-needed
removed: verification-done
Martin Pitt (pitti) wrote :

Sponsored and accepted into l/m-backports, thanks Gunnar!

Changed in lucid-backports:
status: In Progress → Fix Released
Changed in maverick-backports:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.34.2

---------------
language-selector (0.34.2) natty-proposed; urgency=low

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/FontConfig.py:
    - Make the fontconfig-voodoo --auto option work also when the first
      LANGUAGE item is just 'ja' or 'ko', i.e. without country code
      (LP: #778869).
  * dbus_backend/ls-dbus-backend:
    - When applying the language settings system-wide, set the fonts
      configuration also when the first LANGUAGE item is just 'ja' or
      'ko' (LP: #778869).
  * fontconfig-voodoo:
    - Do not require --force when removing the current config using the
      fontconfig-voodoo -r option.
    - Print an exception message if the --auto option fails to find a
      suitable configuration.

  [ Martin Pitt ]
  * debian/control: Switch Vcs-Bzr: to natty branch.
 -- Gunnar Hjalmarsson <email address hidden> Wed, 18 May 2011 09:42:00 +0200

Changed in language-selector (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers