package language-selector-common 0.6.8 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 2

Bug #766672 reported by PresuntoRJ on 2011-04-19
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: language-selector

Just upgraded from the 0.6.7 with a similar problem just fixed

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: language-selector-common 0.6.8
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic-pae 2.6.35.11
Uname: Linux 2.6.35-28-generic-pae i686
NonfreeKernelModules: nvidia
AptOrdering:
 language-selector-common: Configure
 language-selector: Configure
Architecture: i386
Date: Tue Apr 19 19:59:43 2011
ErrorMessage: sub-processo script post-installation instalado retornou estado de saída de erro 2
PackageArchitecture: all
SourcePackage: language-selector
Title: package language-selector-common 0.6.8 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 2

PresuntoRJ (fabio-tleitao) wrote :
Gunnar Hjalmarsson (gunnarhj) wrote :

Have you tried to first downgrade to 0.6.6 and then upgrade to 0.6.8?

Changed in language-selector (Ubuntu):
status: New → Incomplete

no, I have not... but since you have indicated, I have tried to apt-get
autoremove --purge it and install again... then the 0.6.8 got installed ok.

how do I downgrade it to 0.6.6 to test it ?

2011/4/19 Gunnar Hjalmarsson <email address hidden>

> ** Changed in: language-selector (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/766672
>
> Title:
> package language-selector-common 0.6.8 failed to install/upgrade: sub-
> processo script post-installation instalado retornou estado de saída
> de erro 2
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/language-selector/+bug/766672/+subscribe
>

--
Fábio Leitão
..-. .- -... .. --- .-.. . .. - .- --- ...-.-

Gunnar Hjalmarsson (gunnarhj) wrote :

Actually I realize now that I should have suggested you to remove or purge, i.e. what you did. ;-) Please disregard the downgrade thought.

Glad the problem got resolved for you.

Changed in language-selector (Ubuntu):
status: Incomplete → Confirmed
Kees Cook (kees) wrote :

The dpkg log attached to the report shows the failure with 0.6.7. Are you seeing failures with 0.6.8? The following should work:

sudo apt-get update
sudo apt-get dist-upgrade

Changed in language-selector (Ubuntu):
status: Confirmed → Incomplete
PresuntoRJ (fabio-tleitao) wrote :

well, first I was on 0.6.6 ...

I always do apt-get update && apt-get upgrade && apt-get dist-upgrade to keep the system up-to-date, specially while testing

So, when it came, I have tried the upgrade to 0.6.7 (which was the only available) but that has failed... with ubuntu-bug I have filed the bug (and got redirected the original duplicate)... then when the fix was released, upgraded to 0.6.8, and got the apport asking to file the bug (again?) which I did... and here we are... not sure if it was supposed to be filed, or if it was caused by 0.6.7 or 0.6.8, but apport got the exception. Could this be an apport bug?

Gunnar Hjalmarsson (gunnarhj) wrote :

Setting status "Confirmed", considering the duplicates.

Changed in language-selector (Ubuntu):
status: Incomplete → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Second thought... While the issue may be confirmed, it's not yet clear which package is causing it.

Changed in language-selector (Ubuntu):
status: Confirmed → New
Martin Pitt (pitti) wrote :

Presumably this happens if D-BUS is not currently running. That's certainly an odd situation, but we should get along with it.

Changed in language-selector (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.72

---------------
language-selector (0.72) precise; urgency=low

  [ Sebastien Bacher ]
  * data/language-selector.desktop.in:
    - use official "Keywords" rather than "X-GNOME-Keywords" (LP: #949849)

  [ Martin Pitt ]
  * LanguageSelector/qt/QtLanguageSelector.py: Kubuntu's package manager is
    "Muon", not "Adept". Also update all messages in po/*.po to avoid breaking
    existing translations. (LP: #628653)
  * LanguageSelector/gtk/GtkLanguageSelector.py: Fix crash in
    updateLocaleChooserCombo() if tree model is not yet set. (LP: #945494)
  * debian/language-selector-common.postinst: Do not fail configuring if D-BUS
    does not give us the PID of a running ls-dbus-backend. (LP: #766672)
 -- Martin Pitt <email address hidden> Fri, 09 Mar 2012 16:34:49 +0100

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers