package language-selector-common 0.6.7 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Bug #766412 reported by Ben H on 2011-04-19
260
This bug affects 54 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: language-selector

root@yoni:/home/yoni# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up language-selector-common (0.6.7) ...
dpkg: error processing language-selector-common (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of language-selector:
 language-selector depends on language-selector-common (= 0.6.7); however:
  Package language-selector-common is not configured yet.
dpkg: error processing language-selector (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Processing triggers for python-central ...
Errors were encountered while processing:
 language-selector-common
 language-selector
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@yoni:/home/yoni# lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10
root@yoni:/home/yoni# apt-cache policy pkgname
N: לא מצליח לאתר את החבילה pkgname
root@yoni:/home/yoni# apt-cache policy language-selector-common
language-selector-common:
  Installed: 0.6.7
  Candidate: 0.6.7
  Version table:
 *** 0.6.7 0
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386 Packages
        100 /var/lib/dpkg/status
     0.6.6 0
        500 http://il.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: language-selector-common 0.6.7
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
Date: Tue Apr 19 21:57:04 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
PackageArchitecture: all
SourcePackage: language-selector
Title: package language-selector-common 0.6.7 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Ben H (4ouradmins) wrote :
Zak Stone (zstone) wrote :

I just encountered the same error:

"Setting up language-selector-common (0.6.7) ...
dpkg: error processing language-selector-common (--configure):
 subprocess installed post-installation script returned error exit status 2 . . . "

Michael Warren (mike-ef) wrote :

I am encountering the same error as above. This was working about an hour ago. Seems like a new version of the language-selector-common package may have been pushed with a bug?

GabbaGandalf (d1no) wrote :

I have got the same error message auf dist-upgrade:

"...
Richte language-selector-common ein (0.6.7) ...
dpkg: Fehler beim Bearbeiten von language-selector-common (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von language-selector:
 language-selector hängt ab von language-selector-common (= 0.6.7); aber:
  Paket language-selector-common ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von language-selector (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Es wurde kein Apport-Bericht verfasst, da die Fehlermeldung darauf hindeutet, dass dies lediglich ein Folgefehler eines vorherigen Problems ist.
                                                                Verarbeite Trigger für python-central ...
Fehler traten auf beim Bearbeiten von:
 language-selector-common
 language-selector
E: Sub-process /usr/bin/dpkg returned an error code (1)"

Same here with dist-upgrade:

Configurando language-selector-common (0.6.7) ...
dpkg: error al procesar language-selector-common (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 2
dpkg: problemas de dependencias impiden la configuración de language-selector:
 language-selector depende de language-selector-common (= 0.6.7); sin embargo:
 El paquete `language-selector-common' no está configurado todavía.
dpkg: error al procesar language-selector (--configure):
 problemas de dependencias - se deja sin configurar
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
                                                                                                                           Procesando disparadores para python-central ...
Se encontraron errores al procesar:
 language-selector-common
 language-selector
E: Sub-process /usr/bin/dpkg returned an error code (1)

katian (katiancat) wrote :

me too :

xx@xx-desktop:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 0o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Paramétrage de language-selector-common (0.6.7) ...
dpkg : erreur de traitement de language-selector-common (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 2
dpkg : des problèmes de dépendances empêchent la configuration de language-selector :
 language-selector dépend de language-selector-common (= 0.6.7) ; cependant :
 Le paquet language-selector-common n'est pas encore configuré.
dpkg : erreur de traitement de language-selector (--configure) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour « python-central »...
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Des erreurs ont été rencontrées pendant l'exécution :
 language-selector-common
 language-selector
E: Sub-process /usr/bin/dpkg returned an error code (1)

I confirm that bug on my system also.
The same logs as Katian and others.

Is there any way to recover "by hand" ?

robertahilljr (robertahilljr) wrote :

Also got the same problem on my server after running updates, not quite sure what to do about it, tryed "sudo apt-get -f install" and "sudo dpkg --configure --pending" with no luck!

trunet (wsartori) wrote :

Attached:

# dpkg --debug=77777 --configure -a > dpkg_debug.out 2>&1

Andras Borek (mail-borek) wrote :

Bug confirmed here as well:

# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up language-selector-common (0.6.7) ...
dpkg: error processing language-selector-common (--configure):
 subprocess installed post-installation script returned error exit status 2
Processing triggers for python-central ...
Errors were encountered while processing:
 language-selector-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

# lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

# apt-cache policy language-selector-common
language-selector-common:
  Installed: 0.6.7
  Candidate: 0.6.7
  Version table:
 *** 0.6.7 0
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386 Packages
        100 /var/lib/dpkg/status
     0.6.6 0
        500 http://hu.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

trunet (wsartori) wrote :

Patch attached. I don't know how to branch and ask for a merge.

Apparently there's a problem on postinst script trying to kill a process that does not exists on all ubuntu.

Yep, I have just commented out that line and it fixes the problem here too.

trunet (wsartori) on 2011-04-19
Changed in language-selector (Ubuntu):
status: New → Confirmed
Andrew DeLisa (ayan4m1) wrote :

I can also confirm this bug on Ubuntu 10.10 x64, and that the patch proposed in #11 resolved the issue for me.

Mark Simpson (sparkynine) wrote :

A quick 'fix' is to create a script called

ls-dbus-backend

with the following contents:

#!/bin/bash
sleep 900
exit 0

then run as root in one shell:

sudo ./ls-dbus-backend

and run in another shell:

sudo apt-get -f install

aljazek (aljazek) wrote :

How can I use or apply this patch?

Andrea Grandi (andreagrandi) wrote :

I confirm this bug too (Ubuntu 10.10 - 32bit on Asus EeePC 1005PE)

Robert Dyer (psybers) wrote :

I can confirm the patch in #11 works for me as well.

Gaston (gastonsa) wrote :

I can also confirm this bug on Ubuntu 10.10 x64, and that the patch proposed in #11 resolved the issue for me.

Blaise Alleyne (balleyne) wrote :

I can confirm this bug on Ubuntu 10.10, and also that the quick fix suggestion in comment #14 worked for me.

Gaston (gastonsa) wrote :

you can edit the file /var/lib/dpkg/info/language-selector-common.postinst go to the line with this content :
kill $(pgrep -U root '^ls-dbus-backend$') 2>/dev/null
at the end add || true to get this line
kill $(pgrep -U root '^ls-dbus-backend$') 2>/dev/null || true

run apt-get upgrade again

This fix the problem for me

Gunnar Hjalmarsson (gunnarhj) wrote :

This bug is about to be fixed via bug 766534.

aljazek (aljazek) wrote :

Thank you!

Tek Ang (tekang) wrote :

#14 worked for me

Gus (gus-lgze) wrote :

It looks like the fix is in the repository now. Apt get update and apt get upgrade. I suspect this can be closed now.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Gus
This bug report is in effect closed already, since it's marked as a duplicate of the closed bug 766534. ;-)

roachmmflhyr (roachmmflhyr) wrote :

apt-get update && apt-get updgrade will still fail as of today. It will not let you properly install language-selector-common. I have confirmed that you need to edit a file for post installation:

sudo vi /var/lib/dpkg/info/language-selector-common.postinst

Look for this line:

kill $(pgrep -U root '^ls-dbus-backend$') 2>/dev/null

append || true so that its look like:

kill $(pgrep -U root '^ls-dbus-backend$') 2>/dev/null || true

then run:

 sudo apt-get update && sudo apt-get upgrade

This method will fix the issue, a simple apt-get upgrade will not fix the problems as of yet.

Gunnar Hjalmarsson (gunnarhj) wrote :

@roachmmflhyr
It seems to me that your comment would fit better on bug 766672, which is still open. Please review that bug report including the comments, and possibly repost your comment there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers