provide a message when you changed language

Bug #612991 reported by Victor Vargas on 2010-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Wishlist
Gunnar Hjalmarsson

Bug Description

Binary package hint: gnome-control-center

This issue is a wishlist one and I think it's easy to fix.

Steps to reproduce this problem

1) Open gnome-language-selector
2) change your current language to another one (for example from Spanish to English), this time I will forget the fact that you should move your selection to the top of this menu that and maybe is already reported for improve this.
3) Then click on "Apply on system wide..."

When you finished the last step you never receive a message for this change, so you don't know if is already done or something goes wrong. I expect when you finished to apply this change, a message should be displayed saying something like "Operation is finished, please restart your system to complete this proccess" (because you should restart your actual session to refresh and see this change).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-control-center 1:2.30.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Tue Aug 3 09:33:47 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100630.2)
ProcEnviron:
 LANGUAGE=es_CL:en
 LANG=es_CL.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center

Victor Vargas (kamus) wrote :
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
Victor Vargas (kamus) on 2010-08-03
affects: gnome-control-center (Ubuntu) → language-selector (Ubuntu)
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for helping improve Ubuntu by reporting this issue. I will propose that the text right below the "Apply System-Wide" button is extended to include the info you would like to see. Hope that's good enough, at least for now. ;-)
https://code.launchpad.net/~gunnarhj/language-selector/language-menu

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Victor Vargas (kamus) wrote :

Gunnar, I recently tried to run your branch but I got a TraceBack:

Traceback (most recent call last):
  File "./gnome-language-selector", line 8, in <module>
    from LanguageSelector.gtk.GtkLanguageSelector import GtkLanguageSelector
  File "/home/vvargas/testing/language-menu/LanguageSelector/gtk/GtkLanguageSelector.py", line 24, in <module>
    Gtk.require_version('2.0')
  File "/usr/lib/pymodules/python2.6/gtk-2.0/gi/module.py", line 212, in __getattr__
    attribute = getattr(self._dynamic_module, name)
  File "/usr/lib/pymodules/python2.6/gtk-2.0/gi/module.py", line 88, in __getattr__
    self.__class__.__name__, name))
AttributeError: 'DynamicModule' object has no attribute 'require_version'

I am running Ubuntu Maverick fully up to date, do I need something else to run it?

Thanks for your efforts!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.12

---------------
language-selector (0.12) natty; urgency=low

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - Show only options corresponding to available translations in the
      combo box on language-selector's "Language" tab (LP: #693337).
  * LanguageSelector/LanguageSelector.py:
    - Skip the encoding part in the dmrc "Language" value. It's not
      a locale name, so let's not give the impression it is.
  * data/LanguageSelector.ui:
    - Clearer labels to describe the second ("Text") tab.
    - Icon added to taskbar. Thanks to Pavol Klačanský (LP: #648109).
    - Texts that inform the user about the need to restart for changes
      to system settings to take effect (LP: #127356, #612991).
    - Ellipses removed from the labels on the "Apply System-Wide"
      buttons (LP: #531799).
    - Layout tweaking of the "Format" (previously "Text") tab
      (LP: #697606).
  * data/main-countries:
    - Provide main or origin country for languages with multiple country
      codes present among the languages' available locales.
  * LanguageSelector/utils.py:
    - Take main country code into account when language2locale()
      generates a locale name for LC_MESSAGES.
    - language2locale() rewritten to make use of other language-selector
      functions.

  [ Martin Pitt ]
  * LanguageSelector/gtk/GtkLanguageSelector.py: Update ListStore construction
    to also work with the next pygobject release.
 -- Gunnar Hjalmarsson <email address hidden> Fri, 28 Jan 2011 15:50:50 +0100

Changed in language-selector (Ubuntu):
status: In Progress → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

@Kamus
Since you are using Maverick, you need to install the Maverick branch, not the Natty branch. ;-) (The proposal has now been released in Natty, so I just deleted the language-selector package for Natty from my PPA.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers