language-selector installs missing packages without opt-out possibility.

Bug #584438 reported by Nancy Pelosi on 2010-05-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: firefox

Going to System, Administration, Language support and checking the input methods option (press Install/Remove languages to access menu) for at least east asian languages will force annoying and irrelevant packages to be installed in Lucid (10.04).

It suddenly wants to install:
gimp-help-common
gimp-help-en
gnome-user-guide-en

I already had gimp installed and it was happy the way it was without this crap.

I don't have room for these useless packages and I really don't have bandwidth to be downloading them on my dialup-like Clearwire connection. This is not an isolated problem. There are a lot of nonsensical dependencies for packages in ubuntu, but this one is pretty outstanding as language input has nothing to do with the above files.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.3+nobinonly-0ubuntu4
Uname: Linux 2.6.34-020634rc6-generic x86_64
Architecture: amd64
Date: Sat May 22 22:05:46 2010
FirefoxPackages:
 firefox 3.6.3+nobinonly-0ubuntu4
 firefox-gnome-support 3.6.3+nobinonly-0ubuntu4
 firefox-branding 3.6.3+nobinonly-0ubuntu4
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox

Nancy Pelosi (linuxandsuspend) wrote :
Micah Gersten (micahg) wrote :

Moving to language-selector as Firefox doesn't control this.

affects: firefox (Ubuntu) → language-selector (Ubuntu)
Arne Goetje (arnegoetje) wrote :

This has nothing to do with input related packages. The problem is, that your language installation was not complete for the English language and therefor language-selector installs the missing packages at the next opportunity, which is the next time you install anything else with language-selector.
The real bug is that it doesn't let the user opt out. This may get fixed during maverick cycle.

summary: - (Scim) Input support requires irrelevant packages
+ language-selector installs missing packages without opt-out possibility.
Changed in language-selector (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Arne Goetje (arnegoetje) on 2010-05-27
Changed in language-selector (Ubuntu):
milestone: none → maverick-alpha-2
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.6.0

---------------
language-selector (0.6.0) maverick; urgency=low

  [ Michael Vogt ]
  * add dbus backend, no need for gksu anymore (LP: #290570)
  * use aptdaemon in the gtk frontend
  * run tests at build time
  * fix "installs missing packages without opt-out" (LP: #584438)
  * code cleanup

  [Arne Goetje]
  * raise exception and display error when package cache is broken (LP: #331380)
 -- Michael Vogt <email address hidden> Fri, 28 May 2010 22:13:17 +0200

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers