Notification of missing language support not shown after installation

Bug #527623 reported by David Planella on 2010-02-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
language-selector (Ubuntu)
High
Arne Goetje
Lucid
High
Arne Goetje
pkgsel (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson
ubiquity (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson

Bug Description

Binary package hint: language-selector

During testing of the pre-Alpha3 ISOs, I run the test case with no network installation for a language not included in the ISO's language packs (ca).

After installation I was expecting a notification telling me that translations for my language were not installed and that I should connect to the Internet to download the language pack.

In Lucid the notification does no longer appear.

ProblemType: Bug
Architecture: i386
Date: Thu Feb 25 09:39:46 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: language-selector 0.4.18
PackageArchitecture: all
ProcEnviron:
 LANG=ca_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: language-selector
Uname: Linux 2.6.32-14-generic i686

David Planella (dpm) wrote :
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
tags: added: iso-testing
tags: added: regression-potential
Changed in language-selector (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

Arne, as far as I remember this is something between the installer (ubiquity) and the check-language-support script in language-selector-common, right? Can you please test whether check-language-support is still working? Thanks!

Changed in language-selector (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Arne Goetje (arnegoetje)
Arne Goetje (arnegoetje) on 2010-03-17
Changed in language-selector (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
Arne Goetje (arnegoetje) wrote :

I have fixed some code in check-language-support, the --show-installed option didn't work like it should be.
Maybe this fixes the problem already.

Need to test again with version 0.5.2 on the Live CD.

Changed in language-selector (Ubuntu Lucid):
status: Confirmed → Fix Committed
Arne Goetje (arnegoetje) on 2010-03-22
Changed in ubuntu-translations:
status: Triaged → Fix Committed
Arne Goetje (arnegoetje) wrote :

I have committed a fix in version 0.5.3 of language-selector.

This issue needs to be tested again with version 0.5.3 on the LiveCD.

Arne Goetje (arnegoetje) wrote :

OK, I tested again with the latest daily image and the bug is still there.

The file /usr/share/language-support/incomplete-language-support-gnome.note does not get linked to /var/lib/update-notifier/user.d/ .

Adding ubiquity to this bug, need to investigate what goes wrong there.

Changed in ubiquity (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-10.04
Changed in language-selector (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: Fix Committed → Triaged
Colin Watson (cjwatson) on 2010-03-31
Changed in ubiquity (Ubuntu Lucid):
milestone: ubuntu-10.04 → ubuntu-10.04-beta-2
assignee: nobody → Colin Watson (cjwatson)
Changed in pkgsel (Ubuntu Lucid):
status: New → Triaged
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-10.04-beta-2
importance: Undecided → High
Changed in ubiquity (Ubuntu Lucid):
status: Confirmed → Triaged
Colin Watson (cjwatson) on 2010-03-31
Changed in ubiquity (Ubuntu Lucid):
status: Triaged → Fix Committed
Changed in pkgsel (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkgsel - 0.25ubuntu6

---------------
pkgsel (0.25ubuntu6) lucid; urgency=low

  * Install language-selector's update-notifier hook only after marking
    other pending update notifications as seen (LP: #527623).
 -- Colin Watson <email address hidden> Wed, 31 Mar 2010 16:05:24 +0100

Changed in pkgsel (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.12

---------------
ubiquity (2.2.12) lucid; urgency=low

  [ Evan Dandrea ]
  * Accept and discard arguments to the KDE frontend's
    on_keyboard_layout_selected function (LP: #552399).

  [ Colin Watson ]
  * Fix pkgsel/ignore-incomplete-language-support check (LP: #527623).
  * KDE frontend:
    - Ensure that entries in extra_bar_frames are never None (LP: #536912).
    - Lock out manual partitioning operations while the partitioning backend
      is running (LP: #540203).
  * Don't lower-case the locale attribute on frontends. This was added a
    long time ago; since then, it's become unnecessary since i18n.get_string
    lower-cases the locale itself, and it prevented us from finding
    slideshow files for language variants (LP: #476269).
  * Automatic update of included source packages: partman-auto 89ubuntu4,
    partman-ext3 58ubuntu2.

  [ Jonathan Riddell ]
  * Move oem-config-prepare-kde.desktop install directory to
    /usr/share/applications/kde4/, else it is labelled as a KDE 3
    application
 -- Colin Watson <email address hidden> Thu, 01 Apr 2010 01:27:27 +0100

Changed in ubiquity (Ubuntu Lucid):
status: Fix Committed → Fix Released
Arne Goetje (arnegoetje) on 2010-04-01
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers