Language does not get changed on the Lucid LiveCD

Bug #507006 reported by David Planella on 2010-01-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Medium
Unassigned
language-selector (Ubuntu)
Low
Arne Goetje

Bug Description

Binary package hint: language-selector

While testing the Lucid LiveCD ISO in a non-English language, I've noticed that language-selector does not change the language when switching between languages.

Steps to reproduce:

1. Start the LiveCD session in English
2. Once inside the session, go to Support > Language Support and change the language (choose one of: Bengali, German French, Portuguese, Spanish or Xhosa)
3. Log out
4. On logging back in, notice that the language is still in English instead of the language you previously selected.

David Planella (dpm) on 2010-01-13
description: updated
Arne Goetje (arnegoetje) wrote :

1. gdm ignores user LANG and LANGUAGE values in ~/.profile when creating the session.
2. the variable GDM_LANG is always set, no matter if the user selected a language in the gdm login screen or not. Therefor, user settings done with language-selector will never be used.

Changed in language-selector (Ubuntu):
status: New → Triaged
importance: Undecided → High
status: Triaged → Invalid
Changed in gdm (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → ubuntu-10.04-beta-2
Martin Pitt (pitti) wrote :

Note that gdm only reads ~/.dmrc and /var/cache/gdm/$USER/dmrc; it does not read any ~/.profile, etc.

Downgrading priority, since there is a trivial workaround (just select the right language in gdm)

Changed in gdm (Ubuntu):
importance: High → Medium
milestone: ubuntu-10.04-beta-2 → none
Martin Pitt (pitti) wrote :

Note 2: With encrypted home directories, gdm cannot read ~ at all (which is why there is /var/cache/gdm/$USER/dmrc). Thus it might actually be better for l-s to change ~/.dmrc instead of/in addition to ~/.profile for $LANG.

Martin Pitt (pitti) wrote :

Due to the reasons pointed out in comment 3, I think it's better to fix that in the language selector.

Changed in language-selector (Ubuntu):
assignee: nobody → Arne Goetje (arnegoetje)
status: Invalid → Triaged
Changed in gdm (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Triaged → Invalid
Changed in language-selector (Ubuntu):
importance: High → Low
Arne Goetje (arnegoetje) on 2010-04-15
Changed in language-selector (Ubuntu):
status: Triaged → Fix Committed
Arne Goetje (arnegoetje) on 2010-06-29
Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers