Multiple prompts to install language packs that weren't on the CD

Bug #499381 reported by Henri Sivonen on 2009-12-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Arne Goetje

Bug Description

Version: Karmic.

Steps to reproduce:
 1) Disconnect the computer from the network.
 2) Start a Karmic installation from the CD.
 3) Choose Finnish as the main language.
 4) Accept all other install options as the defaults.
 5) After installation, reboot.
 6) Observation point #1.
 7) Shut down the computer.
 8) Connect the computer to an Ethernet network that routes to the Internet.
 9) Boot.
10) Observation point #2.
11) Install all automatic updates.
12) Reboot.
13) Observation point #3.
14) Go to the language selector menu and set all languages to Finnish.
15) Reboot.
15) Create another admin user.
16) Log out.
17) Log in using the newly-created account.
18) Observation point #4.
19) Accept all language file installations that are prompted.
20) Log out.
21) Log in as the user whose account was created during the installation.
22) Observation point #5.

Actual results:
At observation point #1, the system alerts that due to the lack of a network connection the language files for the selected language weren't installed and they can either be installed by pushing a button on the dialog or later by going to such and such menu. Once the computer is rebooted connected to the network at observation point #2, the prompt does not automatically reappear. Going to the indicated menu at observation point #3 does not cause the files to be installed when switching the language from English to Finnish. Logging in as a newly-created user, the language file prompt appears twice at the same time. At observation point #5, the same prompt appears again to the original user even though the other admin user already installed the files twice.

Expected results:
Expected the system to prompt to install the language files at the first opportunity when the network is connected and the logged-in user is an admin user. Expected the prompt to appear as only one instance at a time. Expected not to have to manually re-choose Finnish. Expected the language pack installation to take effect for all users and the other users not to be reprompted.

Arne Goetje (arnegoetje) on 2010-03-09
affects: ubuntu → language-selector (Ubuntu)
Arne Goetje (arnegoetje) wrote :

This should be fixed in gnome-language-selector in version 0.5.1, but is still valid for the qt-language-selector.

Changed in language-selector (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Arne Goetje (arnegoetje)
Arne Goetje (arnegoetje) on 2010-03-25
Changed in language-selector (Ubuntu):
status: Triaged → In Progress
Arne Goetje (arnegoetje) on 2010-03-26
Changed in language-selector (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.5.4

---------------
language-selector (0.5.4) lucid; urgency=low

  * QtLanguageSelector.py: fix to not need to run language-selector
    twice in order to install all needed packages (LP: #499381)
    (LP: #441321)
 -- Arne Goetje <email address hidden> Fri, 26 Mar 2010 14:55:16 +0800

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers