Install cmap-adobe* for supported languages

Bug #496012 reported by Charles on 2009-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: cmap-adobe-japan1

System info:
     Description: Ubuntu 8.04.2
     Release: 8.04

cmap-adobe-japan1:
  Installed: 0+20071201-3
  Candidate: 0+20071201-3
  Version table:
 *** 0+20071201-3 0
        500 http://archive.ubuntu.com hardy/multiverse Packages
        100 /var/lib/dpkg/status

cmap-adobe-japan2:
  Installed: 0+20020208-4
  Candidate: 0+20020208-4
  Version table:
 *** 0+20020208-4 0
        500 http://archive.ubuntu.com hardy/multiverse Packages
        100 /var/lib/dpkg/status

ghostscript:
  Installed: 8.61.dfsg.1-1ubuntu3.2
  Candidate: 8.61.dfsg.1-1ubuntu3.2
  Version table:
 *** 8.61.dfsg.1-1ubuntu3.2 0
        500 http://archive.ubuntu.com hardy-updates/main Packages
        500 http://security.ubuntu.com hardy-security/main Packages
        100 /var/lib/dpkg/status
     8.61.dfsg.1-1ubuntu3 0
        500 http://archive.ubuntu.com hardy/main Packages

ghostscript-x:
  Installed: 8.61.dfsg.1-1ubuntu3.2
  Candidate: 8.61.dfsg.1-1ubuntu3.2
  Version table:
 *** 8.61.dfsg.1-1ubuntu3.2 0
        500 http://archive.ubuntu.com hardy-updates/main Packages
        500 http://security.ubuntu.com hardy-security/main Packages
        100 /var/lib/dpkg/status
     8.61.dfsg.1-1ubuntu3 0
        500 http://archive.ubuntu.com hardy/main Packages

I am try to convert a pdf file using this command: gs -dSAFER -dBATCH -dNOPAUSE -dQUIET -dFirstPage=1 -dLastPage=1 -sDEVICE=jpeg -sOutputFile=a.jpg a.pdf

and I have got the error below:

  Error: /undefinedresource in findresource
Operand stack:
   --nostringval-- --dict:8/17(L)-- 2 MSPGothic 8 --dict:5/5(L)-- --dict:5/5(L)-- MSPGothic --dict:10/12(ro)(G)-- --nostringval-- --dict:7/7(L)-- --dict:7/7(L)-- Adobe-Japan1 CIDFont Adobe-Japan1
Execution stack:
   %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1905 1 3 %oparray_pop 1904 1 3 %oparray_pop 1888 1 3 %oparray_pop --nostringval-- --nostringval-- 2 1 1 --nostringval-- %for_pos_int_continue --nostringval-- --nostringval-- --nostringval-- --nostringval-- %array_continue --nostringval-- false 1 %stopped_push --nostringval-- %loop_continue --nostringval-- 385602 --nostringval-- 1853 4 11 %oparray_pop --nostringval-- false 1 %stopped_push 1852 4 11 %oparray_pop --nostringval-- (gstatetype) --dict:0/0(L)-- --nostringval-- false 1 %stopped_push --nostringval-- %loop_continue --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- %array_continue --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- %loop_continue --nostringval-- 1856 14 11 %oparray_pop findresource %errorexec_pop --nostringval-- --nostringval-- --nostringval--
Dictionary stack:
   --dict:1152/1684(ro)(G)-- --dict:2/20(G)-- --dict:97/200(L)-- --dict:97/200(L)-- --dict:107/127(ro)(G)-- --dict:275/300(ro)(G)-- --dict:22/25(L)-- --dict:4/6(L)-- --dict:25/40(L)-- --dict:5/5(L)-- --dict:16/20(L)-- --dict:38/40(ro)(G)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 8.61: Unrecoverable error, exit code 1

It seems some font is missing to me. I searched the web and found some articales to recommand me to install the CMAP and I then installed all cmap-adobe-japan1 related packages. but still got no luck getting it to work. I am wondering if the fonts are missing on the cmap-adobe-japan1 package.

Martin Pitt (pitti) on 2012-03-02
summary: - ghost script can not find the resources for certain CID fonts even the
- cmap package is installed
+ Install cmap-adobe* for supported languages
affects: cmap-adobe-japan1 (Ubuntu) → language-selector (Ubuntu)
Changed in language-selector (Ubuntu):
status: New → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.71

---------------
language-selector (0.71) precise; urgency=low

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    Modified wording of the error message shown if the example box
    fails to apply the current locale (LP: #930785).

  [ Martin Pitt ]
  * data/pkg_depends: Drop myspell-ru, we have hunspell-ru now.
  * data/pkg_depends: Add cmap-adobe-* packages for ghostscript. (LP: #496012)
 -- Martin Pitt <email address hidden> Fri, 02 Mar 2012 06:54:37 +0100

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers