Some package names in the details section of "language support is not installed completely"-dialog are wrapped after each character

Bug #455370 reported by Markus Korn on 2009-10-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Low
Arne Goetje
Karmic
Low
Arne Goetje

Bug Description

Binary package hint: language-selector

Please see the attached screencast for an example: some package names in the Details section of this Dialog have a new line after each character.

ProblemType: Bug
Architecture: i386
Date: Mon Oct 19 13:08:39 2009
DistroRelease: Ubuntu 9.10
Package: language-selector 0.4.13
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: language-selector
Tags: ubuntu-unr
Uname: Linux 2.6.31-14-generic i686

Markus Korn (thekorn) wrote :
Markus Korn (thekorn) wrote :

Fixing this bug is very easy:

 === modified file 'LanguageSelector/LanguageSelector.py'
--- LanguageSelector/LanguageSelector.py 2009-09-17 22:41:58 +0000
+++ LanguageSelector/LanguageSelector.py 2009-10-19 11:20:42 +0000
@@ -96,7 +96,7 @@
             if pkgcode in self._cache.pkg_translations:
                 for (pkg, translation) in self._cache.pkg_translations[pkgcode]:
                     if (self._cache[pkg].isInstalled and not self._cache[translation].isInstalled):
- missing += translation
+ missing.append(translation)
         support_packages = LanguageSelectorPkgCache._getPkgList(self._cache, pkgcode)
         for support_package in support_packages:
             if (support_package in self._cache and

'translation' is always a string, this is why 'missing += translation' does not work as intended (it adds each character to the 'missing' list)

Markus Korn (thekorn) wrote :

please see the attached patch

Changed in language-selector (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in language-selector (Ubuntu):
importance: Medium → Low
Arne Goetje (arnegoetje) on 2009-10-20
Changed in language-selector (Ubuntu Karmic):
assignee: nobody → Arne Goetje (arnegoetje)
Martin Pitt (pitti) wrote :

Merged and uploaded, thank you!

Changed in language-selector (Ubuntu Karmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.4.15

---------------
language-selector (0.4.15) karmic; urgency=low

  * Added fa_AF and kk translations
  * Fix display of the Details box in gnome-language-selector (Thanks to
    Markus Korn) (LP: #455370)

 -- Arne Goetje <email address hidden> Tue, 20 Oct 2009 09:08:58 +0200

Changed in language-selector (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers