Need a second-time install to complete language support

Bug #441321 reported by Aron Xu on 2009-10-03
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Arne Goetje
language-selector
Invalid
Undecided
Arne Goetje
language-selector (Ubuntu)
High
Arne Goetje

Bug Description

Binary package hint: language-selector

I tried 9.10 Beta CD to have a fresh installation, the locale was set to zh_CN (Chinese simplified) and after the reboot, it told me not full language support as expected. Pressed "Run this action" so a promote of password is occurred, that's normal and started download and installation. Then I restart my box but it still keeps English and promote for not full language support again, so press "Run this action" again and after this time I reboot for a second time, when the box is up, translations are there now.
Then I tried again in my vbox and see at the first time language-selector only install the following 9 packages by default:
ibus-pinyin, ibus-table-wubi, language-pack-zh-hans-base, language-pack-zh-hans, ttf-arphic-ukai, ttf-arphic-uming, xfonts-wqy, language-support-fonts-zh-hans, language-support-input-zh-hans
In the second time, it installs the following 11 packages:
gnome-user-guide, gnome-user-guide-zh, language-pack-gnome-zh, language-pack-gnome-zh-hans-base, language-pack-gnome-zh-hant, language-pack-gnome-zh-hant-base, language-pack-zh-hant, language-pack-zh-hant-base, openoffice.org-l10n-common, openoffice.org-l10n-zh-cn

But what we expected is a one-time installation with full language support added without mix of zh-hans and zh-hant, note if we choose manually in language-selector, it will install those 20 packages one time, but when detecting by program itself, such situation can take place.

Arne Goetje (arnegoetje) wrote :

Thanks for reporting this. I will do some testing and adjust the code.

Changed in language-selector (Ubuntu):
assignee: nobody → Arne Goetje (arnegoetje)
Changed in language-selector:
assignee: nobody → Arne Goetje (arnegoetje)
Changed in ubuntu-translations:
assignee: nobody → Arne Goetje (arnegoetje)
importance: Undecided → High
YunQiang Su (wzssyqa) on 2009-10-08
Changed in language-selector (Ubuntu):
status: New → Confirmed
YunQiang Su (wzssyqa) wrote :

 I can confirm it

Timo Jyrinki (timo-jyrinki) wrote :

Using daily-live 20091015, ie. language-selector 0.4.13, with deliberately not having network connection during installation, I was still able to reproduce this.

See the series of screenshots in the attachment, showing some of the packages having each letter of the package name with \n added... finally the Second run...png shows those same package names written correctly, after the still-required second running of language-selector.

As a sidenote, doing the same installation with network enabled resulted in (almost) everything getting installed, meaning the installer got all the packages (except gnome-user-guide-NN) from check-language-support.

Adi Roiban (adiroiban) on 2009-10-31
Changed in ubuntu-translations:
status: New → Confirmed
Jimhu (huyiwei) wrote :

I can confirm this.
By the way, if you go through the language installation process only once, some part of the fonts will display incorrectly because some font packages are missing.

David Planella (dpm) wrote :

I've tried the installation in Japanese and Korean following http://testcases.qa.ubuntu.com/Install/NonEnglishLanguage#Installation%20Full%20Network%20Support%20&%20CJK%20Input and I could no longer reproduce it (apart from gnome-user-guide-* translations missing from the installation).

Is this still a problem in Chinese with the current Lucid ISO?

Arne Goetje (arnegoetje) wrote :

needs code change in CheckLanguageSupport.py and LangCache.py to use the new functions in the CheckLanguageSupport class.

Changed in language-selector (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
status: Confirmed → Triaged
Changed in language-selector:
status: New → Invalid
Changed in ubuntu-translations:
status: Confirmed → Triaged
Arne Goetje (arnegoetje) wrote :

I have committed some code changes in version 0.5.1 of language-selector which might fix this issue already.

Could you please help testing if this issue has been fixed with the latest version of language-selector for Lucid?

Thanks very much.

Arne Goetje (arnegoetje) wrote :

Setting this to Fix Released, since I cannot reproduce this issue any more with version 0.5.1.

If you still have this issue, please re-open the bug.
Thanks.

Changed in language-selector (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
David Planella (dpm) on 2010-03-22
summary: - Need a second-time install to complete Chinese language support
+ Need a second-time install to complete language support
Changed in ubuntu-translations:
status: Fix Released → Triaged
Changed in language-selector (Ubuntu):
status: Fix Released → Confirmed
David Planella (dpm) wrote :

Tried today's ISO and I could reproduce the bug in Catalan:

* I run http://testcases.qa.ubuntu.com/Install/NonEnglishLanguage#Installation%20Full%20Network%20Support
* After installation, the language packs are installed correctly, but there are some packages missing:

gnome-user-guide-ca
openoffice.org-hyphenation-ca
openoffice.org-thesaurus-ca
gnome-user-guide-en
openoffice.org-hyphenation
openoffice.org-hyphenation-en-us
openoffice.org-thesaurus-en-us
openoffice.org-thesaurus-en-ca

Arne Goetje (arnegoetje) on 2010-03-26
Changed in language-selector (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-translations:
status: Triaged → Fix Committed
Aron Xu (happyaron) wrote :

Using 23rd's ISO it doesn't install OOo's language support files by default.

Aron Xu wrote:
> Using 23rd's ISO it doesn't install OOo's language support files by
> default.
>

Aron, can you please try the latest ISO image or upgrade
language-selector to the latest version before you install the system?

Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.5.4

---------------
language-selector (0.5.4) lucid; urgency=low

  * QtLanguageSelector.py: fix to not need to run language-selector
    twice in order to install all needed packages (LP: #499381)
    (LP: #441321)
 -- Arne Goetje <email address hidden> Fri, 26 Mar 2010 14:55:16 +0800

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Arne Goetje (arnegoetje) on 2010-03-29
Changed in ubuntu-translations:
status: Fix Committed → Fix Released
David Planella (dpm) on 2010-03-31
Changed in ubuntu-translations:
status: Fix Released → Triaged
Arne Goetje (arnegoetje) wrote :

heh.. the packages in question got demoted to universe, since there are no package dependencies anymore which would keep them in main. Since the universe repository is not activated during installation from the CD, the installer and also check-language-support cannot see those packages.

So, check-language-support is not of fault here, we need to get those packages back into main or enable the universe repo on the CD.

Arne Goetje (arnegoetje) wrote :

I will produce a list of affected packages and ask Martin Pitt to seed them back into main.

Changed in ubuntu-translations:
status: Triaged → In Progress
Jimhu (huyiwei) wrote :

Hi, Sorry for responding so late.

I don't think this problem is solved, and i think it's getting even worse.

I installed Kubuntu Lucid Beta in Virtualbox and upgraded system. After that, i couldn't install the Simplified Chinese language support.

Clicking Select language from Langugage & Region section in System Setting, I was told that language support was not fully installed as normal. So I pressed "Install", but an error dialoge pop up and showed some unreadable characters. I I copied those texts to Kate and save them to a file, then I reopened the file with UTF-8 encoding and found out they were just Chinese characters with wrong encode.

The error message told me that there are some conflicts between packages and was not able to satisfied, so language selector refused to install the language support packages.

This bug is something related to #511483

Aron Xu (happyaron) on 2010-04-01
Changed in language-selector (Ubuntu):
status: Fix Released → New
Arne Goetje (arnegoetje) wrote :

@Jimhu:
did you update all packages before calling Language & Region settings?
Your issue seems not to be related to this bug.

Which version of language-selector do you have installed?

Which language did you use to install the system?
Have you modified anything in your locale settings by hand? The Chinese characters being shown in an non-UTF-8 encoding is something totally strange and usually is related to a user setting, which is not supported by default. We only support UTF-8 locales.

Jimhu (huyiwei) wrote :

@Arne:
Should i open another ticket for that issue? I know they are totally different issues. But since i'm a lazy-bone :). I'll open a new ticket if needed, anyway.

I was testing beta1 LiveCD with Virtualbox. The only thing i'd done before install langugage support was to run sudo apt-get update and sudo apt-get upgrade command under Konsole. I didn't know the version of language-selector, but i was sure it should be up to date.

The Chinese characters being shown in an non-UTF-8 encoding is a bug which still exists in install-package.
See bug #468615 for more details.

Hey, why OS-installer not just download language packages in installation process, if Internet available?
You know, in Windows, if user install localization version of the system, after installation he get complete localization version. It's strange for users see not completly localization system after Linux-installation. I create bug about this idea: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/550707 If you like this idea - please, support it in comments.

David Planella (dpm) wrote :

El dl 05 de 04 de 2010 a les 09:27 +0000, en/na RussianNeuroMancer va
escriure:
> Hey, why OS-installer not just download language packages in installation process, if Internet available?
> You know, in Windows, if user install localization version of the
> system, after installation he get complete localization version. It's
> strange for users see not completly localization system after
> Linux-installation. I create bug about this idea:
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/550707 If you
> like this idea - please, support it in comments.
>

RussianNeuroMancer,

Thanks for reporting that bug, but in fact the installer already
installs language packs if there is a working Internet connection.

I'd encourage you to test a Lucid installation to check how this
function is working. Thanks!

In any case, back to the bug, after having tested it with the Beta-2
ISO, the bug is mostly solved.

Of the list of packages which needed a second time installation, now
only 'openoffice.org-hyphenation' is remaining.

I test Russian installation with Kubuntu Lucid Beta 2 with Internet connection and get this result:
1. After installation location correcty selected - Russia, but language list is empty. Until user add Russian language to list, system partly in Russian, partly in English.
2. After user add Russian language to list appears windows with request to complete install language support for selected (Russian) languages.

Arne Goetje (arnegoetje) wrote :

David,

openoffice.org-hyphenation had been errornously demoted to universe. This has been fixed now.

Arne Goetje (arnegoetje) wrote :

@RussianNeuroMancer:
I can reproduce your issue in Kubuntu, but language-selector is not at fault here. That's an issue in KDE. Please file a separate bug about this.

Thanks.

Changed in language-selector (Ubuntu):
status: New → Fix Released
Changed in ubuntu-translations:
status: In Progress → Fix Released

Arne, I already file separete bug, but when I reading comments, it's looks loke nobody understand what I talking about
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/550707

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers