Comment 6 for bug 362204

Hello,

I have been trying to switch language with gnome-language selector today. I was using a Lubuntu 12.04 Precise Pangolin, which I customized and remixed with Remastersys.

I have installed it in English to a Virtualbox machine, and after that I tried to switch to French. When I opened the gui, the English language from different English speaking countries where presented : "English" in first, the other ones grayed, and at the end of the list "French" was there and greyed too so these ones I could try to click on them, nothing happened.

I tried to change : first went to the next tab and unticked English. Then English packages for locales where removed. Rebooted. Alas the menus where still in English.

I tried again, and again, rebootin between each trial, once starting the program from the console to seek for messages, added libperl-locale, and several other packages in case it would help. Rebooted again and again each time in hope the language would have changed but no go!

I started the program again from console, but this time invoking it with gksu : the result was not better. Anything tried failed, the line for the language was now "French" and was alone there, but the menus where still in English.

As it's Lubuntu, I also tried to erase the menu cache file in ~/.config/menus, but that didn't do it either.

At the end, fed up from trying I went to edit the /etc/default/locale by hand, rebooted, and : yes ! the menus from the panel, from lightdm login screen, and in applications where now in French ! Hurrah !

Well, it seems to me that "Gnome language selector" is a gui application which does nothing.

Do you think it could be reviewed and fixed ? (All users know not how to edit files by hand, or even have an idea that there is a file, and where).

Thank you very much for trying.

Mélodie