Can't cancel prompt to enter sudo password

Bug #290570 reported by Eduardo Cereto on 2008-10-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: language-selector

when I select a new language to install and click apply it shows up a prompt to enter sudo password. If I give up and try to hit cancel it just reloads prompt to enter password. If you keep pressing cancel it reloads about 6 times and then you can cancel action as usual.

Tried to replicate on other applications that shows the same dialog but only in language-selector it seems to happen.

This is a clean install of Intrepid RC

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: language-selector 0.3.17
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: language-selector
Uname: Linux 2.6.27-7-generic i686

Eduardo Cereto (dudus) wrote :
Martin Pihl (pihl) wrote :

I have confirmed this on two computers.

And you don't even have to have selected a new language. If you open Language Support and do not choose a new language, and press O.K (instead of cancel), you are prompted for administrator password, and cannot escape it unless you actual know the password.

The only option for the user at this point is to hit the power button (end perhaps lose everything open).

These events have been on clean installs of INtrepid as weel.

Martin Pihl (pihl) on 2008-11-06
Changed in language-selector:
status: New → Confirmed
Yinon Ehrlich (yinone) wrote :

the same for Hardy, too.
IMHO, administrator should be prompted first (or add "unlock" button).
Thanks !

Loïc Minier (lool) wrote :

Martin, your bug seemed to be a different bug which seems to be fixed now. The original bug remains (can't cancel administrator password prompt).

Arne Goetje (arnegoetje) on 2010-03-26
Changed in language-selector (Ubuntu):
importance: Undecided → Low
Arne Goetje (arnegoetje) on 2010-05-27
Changed in language-selector (Ubuntu):
status: Confirmed → Fix Committed
milestone: none → maverick-alpha-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.6.0

---------------
language-selector (0.6.0) maverick; urgency=low

  [ Michael Vogt ]
  * add dbus backend, no need for gksu anymore (LP: #290570)
  * use aptdaemon in the gtk frontend
  * run tests at build time
  * fix "installs missing packages without opt-out" (LP: #584438)
  * code cleanup

  [Arne Goetje]
  * raise exception and display error when package cache is broken (LP: #331380)
 -- Michael Vogt <email address hidden> Fri, 28 May 2010 22:13:17 +0200

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers