[hardy] Japanese 18px or smaller fonts are ugly

Bug #202731 reported by Jun Kobayashi on 2008-03-16
6
Affects Status Importance Assigned to Milestone
Ubuntu Japanese Kaizen Project
Undecided
Unassigned
language-selector (Ubuntu)
Undecided
Arne Goetje

Bug Description

Binary package hint: fontconfig

Japanese fonts displayed in 18px or smaller are ugly.
This is because freetype hinting doesn't work well for Japanese small antialiased fonts.

I confirmed this issue with fontconfig 2.5.0-2ubuntu3.

Jun Kobayashi (jkbys) wrote :

I rewote /etc/fonts/conf.avail/29-language-selector-ja-jp.conf to fix this bug. Attaching.

Jun Kobayashi (jkbys) wrote :

I rewrote /etc/fonts/conf.avail/69-language-selector-ja-jp.conf also.
This is for using VL Gothic fonts added to main repository in recent days.

Arne Goetje (arnegoetje) on 2008-03-16
Changed in fontconfig:
assignee: nobody → arnegoetje
Arne Goetje (arnegoetje) wrote :

The attached fontconfig files have been submitted to bzr. New packages will be built from there.

The default sans-serif and monospace font for Japanese in Ubuntu is currently Kochi Gothic. Should it be replaced with VL Gothic, too?
How about Latin and other scripts. Is it preferred to use the Latin characters which come with the japanese Gothic fonts, or would it be better to prefer Bitstream Vera Sans and DejaVu Sans?

Changed in language-selector:
status: New → Fix Committed
Jun Kobayashi (jkbys) wrote :

Thank you for your help, Arne.

The default sans-serif and monospace font for Japanese should be replaced with VL Gothic, IMO.
This is because Kochi is not under development anymore, meanwhile VL Gothic is under lasting improvement and has better level of visibility than Kochi.

And, it is preferred to use the Latin characters come with Japanese fonts. The Latin characters included in Japanese fonts are designed to match Japanese characters.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.3.2

---------------
language-selector (0.3.2) hardy; urgency=low

  [ Michael Vogt ]
  * LanguageSelector/qt/QtLanguageSelector.py:
    - fix another charackter encoding problem (LP: #203335)
    - fix warning dialog if we have broken packages

  [ Arne Goetje ]
  * fixes in the Japanese font configuration (LP: #202731)

 -- Michael Vogt <email address hidden> Tue, 18 Mar 2008 11:07:17 +0100

Changed in language-selector:
status: Fix Committed → Fix Released
Jun Kobayashi (jkbys) on 2008-03-25
Changed in ubuntu-jp-improvement:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers