[hardy] fonts have had different proportions since update

Bug #199557 reported by pheeror on 2008-03-07
50
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Arne Goetje

Bug Description

Hi,
After the last update, the proportions of all fonts on my system got messed. Probably some problem with DPI. I have no idea where exactly the problem is, sorry. Now, fonts are more larger and thicker and uglier.

This problem doesn't affect already running application, but fonts are differently rendered only in apps started after update. Obviously, after reboot all apps render fonts in the new way.

Fonts on the attached screenshot doesn't look as bad as in real. The bottom application use the new rendering.

the updated packages:

avahi-autoipd (0.6.22-2ubuntu2) ...
avahi-daemon (0.6.22-2ubuntu2) ...
bash 3.2-0ubuntu14
bsdutils 1:2.13.1-1ubuntu1
gimp-data 2.4.4-1ubuntu1
gimp-gnomevfs 2.4.4-1ubuntu1
gimp-python (2.4.5-1ubuntu1) ...
gvfs 0.1.11-0ubuntu2
gvfs-backends (0.1.11-0ubuntu3) ...
hal (0.5.10+git20080301-1ubuntu1) ...
language-selector (0.3.0) ...
language-selector-common (0.3.0) ...
liba52-0.7.4 (0.7.4-11ubuntu1) ...
libart2.0-cil (2.16.1-2ubuntu1) ...
libavahi-client3 0.6.22-2ubuntu1
libavahi-client-dev 0.6.22-2ubuntu1
libavahi-common3 0.6.22-2ubuntu1
libavahi-common-data (0.6.22-2ubuntu2) ...
libavahi-compat-libdnssd1 (0.6.22-2ubuntu2) ...
libavahi-core5 (0.6.22-2ubuntu2) ...
libavahi-glib1 (0.6.22-2ubuntu2) ...
libavahi-glib-dev (0.6.22-2ubuntu2) ...
libavahi-qt3-1 (0.6.22-2ubuntu2) ...
libavahi-ui0 (0.6.22-2ubuntu2) ...
libgconf2.0-cil (2.16.1-2ubuntu1) ...
libgimp2.0 2.4.4-1ubuntu1
libglade2.0-cil (2.10.4-2ubuntu1) ...
libglib2.0-cil (2.10.4-2ubuntu1) ...
libgnome2.0-cil (2.16.1-2ubuntu1) ...
libgnome-vfs2.0-cil (2.16.1-2ubuntu1) ...
libgtk2.0-cil (2.10.4-2ubuntu1) ...
libgtkhtml2.0-cil (2.16.1-2ubuntu1) ...
libgvfscommon0 0.1.11-0ubuntu2
libhal1 0.5.10-5ubuntu8
libhal-dev (0.5.10+git20080301-1ubuntu1) ...
libhal-storage1 (0.5.10+git20080301-1ubuntu1) ...
libhal-storage-dev (0.5.10+git20080301-1ubuntu1) ...
librsvg2.0-cil (2.16.1-2ubuntu1) ...
libscim8c2a (1.4.7-3ubuntu2) ...
menu (2.1.38ubuntu2) ...
mount 2.13.1-1ubuntu1
scim (1.4.7-3ubuntu2) ...
scim-bridge-agent (0.4.14-1ubuntu2) ...
scim-bridge-client-gtk (0.4.14-1ubuntu2) ...
scim-gtk2-immodule (1.4.7-3ubuntu2) ...
scim-modules-socket (1.4.7-3ubuntu2) ...
tomboy (0.9.8-1) ...
util-linux 2.13.1-1ubuntu1
util-linux-locales (2.13.1-2ubuntu1) ...

pheeror (pheeror) wrote :
pheeror (pheeror) wrote :

Can somebody change the name of this bug please?
evil typo, s/properties/proportions/
thanks

Brian Curtis (bcurtiswx) wrote :

i have to say I like the change, if it is an error, maybe something along the lines of a bolder but less "messier" font should be in store for hardy.

Roger van Essen (basslord) wrote :

I can confirm the today's change in rendering. I don't like the change at all, it looks horrible at any possible configuration available. The resolution is 1680x1050 (on a 15,4'' Thinkpad and 22'' Samsung LCD). I would be pleased to get back the old way of rendering/antialiasing. But I'm dreading the thought that this "bug" might be just another step in "improvement" as experienced first when upgrading Feisty to Gutsy. In Gutsy at least greyscaling/strong hinting was acceptable. Please don't make Ubuntu so damned Vistaish.
Since my change from Suse to Ubuntu 5.04 I was pleased to find a state-of-the-art font rendering. It's been sharper thus better readable and less tiring than in Suse and it looked way smoother than in WinXP. To cut it it short: for me it's been just PERFECT.

Jürgen Kreileder (jk) wrote :

I saw the same problem. It's caused by the language-selector 0.3.0 update. After downgrading all is back to normal.

Arne Goetje (arnegoetje) wrote :

This is because of a change in fontconfig, which sets hinting to medium and anti-aliasing to greyscale. This is the default setting on the gnome desktop in Ubuntu anyways (at least in Hardy).

Martin (agima) wrote :

Same problem here. I hope this is not the place to discuss if this change is nice or not.

In gnome I have turned on subpixel rendering and set hinting to strong. The fonts were perfect before the update (since gutsy they look as nice as rendered with cleartype in Windows XP) and I hope that this bug will be fixed soon.

pheeror (pheeror) wrote :

I can confirm the workaround suggested by Juergen. I've dowgraded language-selector and language-selector-common to 0.2.9_all.deb and since then fonts look nice again. Thus, maybe this is not duplicate of bug 199523.

Jürgen Kreileder (jk) wrote :

This isn't a duplicate. The problem is caused by 29-language-selector-ja-jp.conf which enables the autohinter. This gives ugly results with some fonts (which have good hints), for example with the Microsoft fonts (Arial, Verdana, ...).

It's possible to work around this with $(HOME)/.fonts.conf but I don't think the autohinter should be enabled globally.

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit name="autohint" mode="assign">
    <bool>false</bool>
  </edit>
</fontconfig>

Jürgen Kreileder (jk) wrote :

Obviously there's a closing </match> missing in my previous comment. (I have more stuff in ~/.fonts.conf).

Jürgen Kreileder (jk) wrote :

Moving back to appropriate package.

sibidiba (sibidiba) wrote :

Can confirm bug and Juergen Kreileder's workaround.

Lukasz Wisniewski (vishna) wrote :

Same here, can confirm bug and Juergen Kreileder's workaround. Btw if this is a new, hardy's way of font rendering, it is just unacceptable for my eyes.

vista killer (vistakiller) wrote :

I have the same problem in kubuntu hardy alpha 6.

kiev1 (sys-sys-admin) wrote :

1 enter "sudo dpkg-reconfigure fontconfig-config" and select None and None, after enter "sudo dpkg-reconfigure fontconfig" and reboot xorg
2 enable and disable rgb aliasing
3 type "sudo apt-get install ttf-liberation"
4 set hinting full

pheeror (pheeror) wrote :

seems maintainers have not noticed this bug yet; assigning to Arne Goetje who did a change accord to changelog

Changed in language-selector:
assignee: nobody → arnegoetje
Arne Goetje (arnegoetje) wrote :

I did notice this bug, I just didn't have time to look at it yet.

Changed in language-selector:
status: Confirmed → In Progress
Arne Goetje (arnegoetje) on 2008-03-10
Changed in language-selector:
status: In Progress → Fix Committed
pheeror (pheeror) wrote :

thank you for the fix

I confirm the bug on font rendering. I partially fix it by DisplaySize option in xorg.conf but the rendering in gutsty is very better ...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.3.1

---------------
language-selector (0.3.1) hardy; urgency=low

  [ Michale Vogt ]
  * LanguageSelector/gtk/GtkLanguageSelector.py
    - use absolute path when calling gksu (LP: #194166)
  * data/language-selector.desktop.in:
    - remove X-KDE-SubstituteUID
  * fix icon inconsistency (LP: #164316)
  * LanguageSelector/qt/QtLanguageSelector.py:
    - fix charackter encoding in UI (LP: #186157)
  * data/Language-selector.glade:
    - make the main wndow type "Normal" (LP: #148912)

  [ Arne Goetje ]
  * debian/rules: remove dh_link for locale specific fontconfig files
  * LanguageSelector/FontConfig.py: link all locale specific fontconfig files
    only when the locale is called. (LP: #199557)

 -- Michael Vogt <email address hidden> Wed, 12 Mar 2008 13:06:16 +0100

Changed in language-selector:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments