gnome-language-selector crashed with AttributeError in getCurrentInputMethod(): 'NoneType' object has no attribute 'split'

Bug #1660435 reported by fcole90 on 2017-01-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Gunnar Hjalmarsson

Bug Description

Opening the language administration panel from a xubuntu session caused this crash.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: language-selector-gnome 0.165.4
ProcVersionSignature: Ubuntu 4.4.0-59.80-generic 4.4.35
Uname: Linux 4.4.0-59-generic x86_64
NonfreeKernelModules: kpatch_livepatch_Ubuntu_4_4_0_59_80_generic_16
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CrashCounter: 1
Date: Mon Jan 30 21:33:18 2017
ExecutablePath: /usr/bin/gnome-language-selector
InstallationDate: Installed on 2016-09-09 (143 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
InterpreterPath: /usr/bin/python3.5
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/gnome-language-selector
PythonArgs: ['/usr/bin/gnome-language-selector']
SourcePackage: language-selector
Title: gnome-language-selector crashed with AttributeError in getCurrentInputMethod(): 'NoneType' object has no attribute 'split'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: sudo

fcole90 (fcole90) wrote :
tags: removed: need-duplicate-check
Changed in language-selector (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report!

The error tells us that the XDG_CURRENT_DESKTOP environment variable was unset, while it normally is set. Can you tell us anything more about the circumstances under which the crash happened? Have you been able to reproduce it?

Changed in language-selector (Ubuntu):
status: New → Incomplete
Gunnar Hjalmarsson (gunnarhj) wrote :

It makes sense to fix this no matter what; just did.

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.176

---------------
language-selector (0.176) zesty; urgency=medium

  * LanguageSelector/ImConfig.py:
    Prevent crash if XDG_CURRENT_DESKTOP is unset (LP: #1660435).

 -- Gunnar Hjalmarsson <email address hidden> Sat, 11 Mar 2017 21:43:00 +0100

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers