Don't set IM "xim" by default

Bug #1605408 reported by Gunnar Hjalmarsson on 2016-07-21
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Gunnar Hjalmarsson
Xenial
Medium
Gunnar Hjalmarsson

Bug Description

[Impact]

Since the fix of <https://launchpad.net/bugs/1481025> "cjkv" has been the system default in im-config for some flavors (e.g. Xubuntu, Lubuntu), which means that an IM framework is started and configured only if one of the CJKV languages is the selected display language. For other languages "cjkv" means that no IM related environment variables are set (value "none"). However, when starting gnome-language-selector first time after installation of one of those flavors, the selected IM method is set to "xim" automatically. This is undocumented behavior, and the background is commented in the bug description of <https://launchpad.net/bugs/1585797>.

As illustrated in <https://launchpad.net/bugs/1573755>, the "xim" input method occasionally causes hard to debug keyboard problems. For this reason gnome-language-selector should not set "xim", but simply confirm the "none" default value from im-config.

Some users need "xim" to access X11 dead key and compose key variants, and this means that they will always need to set it explicitly. The upside is that users who encounter problems with "xim" will do so as a result of an active measure, which increases the chance that they understand the causality.

[Test Case]

On a Xubuntu or Lubuntu system with a non-CJKV display language:

* Remove already set user specific IM configuration:

  rm -f ~/.xinputrc

* Open gnome-language-selector, and find that the selected "keyboard
  input method system" is "XIM".

After installing the proposed version of language-selector-gnome, those steps instead result in the value "none".

[Regression Potential]

Low. This is only about the default value applied by gnome-language-selector, so it doesn't change an already set user specific IM configuration.

Changed in language-selector (Ubuntu Xenial):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → In Progress
Changed in language-selector (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.171

---------------
language-selector (0.171) yakkety; urgency=medium

  * LanguageSelector/ImConfig.py:
    Use "none" as default for non-CJKV languages on certain flavors
    instead of "xim" (LP: #1605408).

 -- Gunnar Hjalmarsson <email address hidden> Fri, 22 Jul 2016 15:21:00 +0200

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released

Hello Gunnar, or anyone else affected,

Accepted language-selector into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/language-selector/0.165.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in language-selector (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I installed language-selector-{gnome,common} 0.165.4 from xenial-proposed on a Xubuntu system, reproduced the test case, and can confirm the changed behavior.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.165.4

---------------
language-selector (0.165.4) xenial; urgency=medium

  * LanguageSelector/ImConfig.py:
    Use "none" as default for non-CJKV languages on certain flavors
    instead of "xim" (LP: #1605408).

 -- Gunnar Hjalmarsson <email address hidden> Fri, 22 Jul 2016 15:23:00 +0200

Changed in language-selector (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for language-selector has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers