/usr/bin/gnome-language-selector:locale.Error:on_activate:__init__:wrapper:check_input_methods:getCurrentInputMethod:setlocale

Bug #1507500 reported by errors.ubuntu.com bug bridge on 2015-10-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
High
Gunnar Hjalmarsson

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding language-selector. This problem was most recently seen with version 0.150, the problem page at https://errors.ubuntu.com/problem/4deefec173f7edf9e5e73aebc6b96ddc4d678c96 contains more details.

Sebastien Bacher (seb128) wrote :

that seems a regression from

language-selector (0.149) wily; urgency=medium

  * LanguageSelector/ImConfig.py:
    Use "cjkv" instead of "xim" on non-Unity desktops (LP: #1481025).

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

This probably the same issue as bug #1507369, and the root cause is bug #1465530.

When the locale is broken, this line in LanguageSelector/ImConfig.py causes a fatal error:

locale.setlocale(locale.LC_ALL, '')

Sebastien Bacher (seb128) wrote :

ideally the code would handle missing locales though, and it was not triggering that error before 0.149 where the bug you pointed was already there...

Changed in language-selector (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.151

---------------
language-selector (0.151) wily; urgency=medium

  * LanguageSelector/ImConfig.py:
    Prevent crash if the locale is broken (LP: #1507369, LP: #1507500).

 -- Gunnar Hjalmarsson <email address hidden> Mon, 19 Oct 2015 18:06:00 +0200

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers