Ubuntu

language support list not available if network is not available during install

Reported by Timo Jyrinki on 2007-08-30
84
This bug affects 11 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Michael Vogt
Intrepid
Medium
Michael Vogt
ubiquity (Ubuntu)
Medium
Unassigned
Intrepid
Medium
Unassigned

Bug Description

Binary package hint: language-selector

Update: The bug has continued to exist since gutsy through hardy and intrepid -> post-installation language support install does not work properly. See the later comments in this bug for what should be done, ie. 1. (as suggested also by cjwatson in bug 277526) offering to do an apt-get update, 2. correctly installing support for the default language in all cases [now separated to bug 289165]

I installed Gutsy's daily-live from yesterday, and selected Finnish as the installation language. I did not remember to enable network connection (something a newbie doesn't often know, either), and language packs were not installed. After the installation, and after enabling the network connection so that package lists are updated, I went to language support. The language support should in this case suggest installing support for the Default Language in the system (Finnish), but instead it only suggests installing the rest of the English packages.

Timo Jyrinki (timo-jyrinki) wrote :

Ie. if something is already selected as the default language, it should be automatically be selected as a supported language too, and missing support should be offered to be installed.

Timo Jyrinki (timo-jyrinki) wrote :

I checked this with hardy, no different: Installed with Internet connection not enabled.

1. After booting to the installed system, Internet connection enabled, Language Selector lists "English" as the only possible language in the upper part of the windows, and selected. However, "Finnish" (suomi) is selected as the default language in the bottom part of the window, but the program does not have a choice to actually download support for the default language.

2. After manually refreshing software sources in Update Manager (something that will be eventually done automatically too, in case Internet connection is enabled), the language list is complete but the tool does still not suggest enabling support for the language that is selected as the "default". One must manually scroll the language list and select the language support for there.

So, one issue is suggesting the downloading of language support for the default language, and another issue is how to handle the case where software sources have not yet been refreshed.

I used 20080419 daily-live which has language-selector 0.3.4 that should have some new note about this issue, but I didn't notice any notice during installation or after booting into the new system (there might have been one during installation since I didn't pay attention, if it disappeared before the end's reboot suggestion dialog is showed).

As I mention on u-dev-discuss ML, we also saw something like this happen on Hardy RC for Portuguese.
In our case, it was the OpenOffice.org that failed to get the Portuguese GUI.

I request that language-selector should alert the user that Languages Packages are missing some time after the inicial reboot after install.
The same happens with the security updates.

Denys Rtveliashvili (rtvd) wrote :

The same happens with Ukrainian and, perhaps, other languages too.

This is definitely a bug. There is not too much sense in translating the Ubuntu if this translation is not available for end-users straight away.

The user selects her language, installs the Ubuntu... And then she has the system running in another language. If she does not know English, she will not be able to turn on a support for her language.
And even if she does, she will need to get an access to broadband internet first. Unfortunately, it is a luxury in many regions.

Now Ubuntu Hardy Heron is about to be shipping... And I am sure many people will be disappointed.

Changed in language-selector:
status: New → Confirmed

Adding ubiquity task because some people think this should be handled in the live cd installer as reported in duplicate bug #81683.

Changed in language-selector:
importance: Undecided → Medium
Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
Tore Anderson (toreanderson) wrote :

This bug is still present in Kubuntu Intrepid alpha-2, or at least, I did not get Norwegian localization in after having having finished the installation, requesting Norwegian whenever asked. Only exception that I could see was that the the keyboard layout was correctly set (both in X and on the console), and that the Norwegian software archive was used in /etc/apt/sources.list.

I didn't activate the network during the installation (the installer only attempted to activate the wired network, which I'm not using, and did not at all offer to connect to a wireless network instead). I've not retried the installation with a wired connection active to see if that would give me better results as I assume this is the bug I'm seeing.

Tore.

Tore Anderson (toreanderson) wrote :

I was wrong. Just attempted an install with the wired network connected (and successfully enabled), but still no localization, everything is in English.

Should I submit a new bug?

Tore

Timo Jyrinki (timo-jyrinki) wrote :

Tore: Yes, probably you should file a new bug (probably against ubiquity). It has been working if the network was enabled, so maybe it's more broken in intrepid (it has suddenly become broken in the past, too).

Tore Anderson (toreanderson) wrote :

Okay, done. Bug #249526.

Tore

Timo Jyrinki (timo-jyrinki) wrote :

Just to re-cap, to get this bug fixed at least two checks/actions (in pseudo-code) should be done:

// if the default language is not listed at all, it's a sure sign repositories haven't been refreshed
if (default_language !exists in language list) { apt-get update }

// if language support for the default language isn't installed, it should be
if (language list[default_language] != INSTALLED) { install(default_language) }

Currently neither is done.

Timo Jyrinki (timo-jyrinki) wrote :

See also bug #277526, which would be a nice new feature except that it does not work because of this bug.

description: updated
Michael Vogt (mvo) wrote :

This should be fixed in language-selector 0.3.16 - unfortunately it means that there are new strings for the dialog that informs about the mising package list information.

Changed in language-selector:
assignee: nobody → mvo
milestone: none → ubuntu-8.10
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

This is being handled in language-selector rather than ubiquity, so I'm closing the ubiquity task.

Changed in ubiquity:
status: Confirmed → Won't Fix
Colin Watson (cjwatson) on 2008-10-22
Changed in ubiquity:
status: Confirmed → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.3.16

---------------
language-selector (0.3.16) intrepid; urgency=low

  [ Michael Vogt ]
  * LanguageSelector/LanguageSelector.py:
    - add verifyPackageLists() method that checks if there are
      actually packages available that are not on CD
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - offer to update package list if no package information
      is available (LP: #135752, LP: #277526)
  * LanguageSelector/qt/QtLanguageSelector.py:
    - offer to update package list if no package information
      is available (just like in the gtk frontend)
  * data/LanguageSelector.glade:
    - hide the details by default

  [ Colin Watson ]
  * Rearrange fields in restart_session_required.note.in to avoid a broken
    Name field there as well (LP: #287573).

  [ Jonathan Riddell ]
  * LanguageSelector/qt/QtLanguageSelector.py:
    - imswitch should select scim-bridge, not scim

 -- Michael Vogt <email address hidden> Wed, 22 Oct 2008 16:19:30 +0200

Changed in language-selector:
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Hi. Sorry, reopening, though probably starting to be too late for intrepid.

I installed from http://cdimage.ubuntu.com/daily-live/20081025/. I get the note about lacking translation support (properly translated), but when I select "Run this action now", Language Selector does not suggest updating repositories like it should with 0.3.16. Dunno why, but I cannot seem to be able to trigger the question, even if I manually go to Language Support. Thus, only English is shown in the list of languages and nothing else is offerred.

(Secondly, what I've been trying to keep in this bug report, support for "Default Language", ie. installation language, is not suggested even when the repositories have been refreshed. Anyway, since it's really a separate bug I made it into a new bug 289165.)

Changed in language-selector:
status: Fix Released → Confirmed
description: updated
Steve Langasek (vorlon) wrote :

Michael, do you understand why this isn't working? Is there any chance of a quick fix for this first thing today? (I hate to make use of it, but the reality is that the language pack builds buy us some time before we'll start the CD building, so if a fix is known it wouldn't delay us very much at all to include it.)

Timo Jyrinki (timo-jyrinki) wrote :

Just reproduced with 20081026 daily-live, installing in German this time. 1. Installed Ubuntu without network enabled 2. Shut down and enabled network 3. Booted and waited for the notification icon 4. Clicked the German equivalent of "Run this action now" 5. No dialog about updating repositories (or installing the rest of the language support), only Deutsch and Englisch shown in the list. (6. Checked that network is indeed functional by updating repositories via Update Manager manually).

Michael Vogt (mvo) wrote :

It turns out the problem is that the livecd comes pre-populated with archive.ubuntu.com and security.ubuntu.com. That made the check think that there was already a update. I changed it now to ignore security.ubuntu.com in this check.

Changed in language-selector:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.3.17

---------------
language-selector (0.3.17) intrepid; urgency=low

  * LanguageSelector/LanguageSelector.py:
    - ignore "security.ubuntu.com" when checking if there are repositories
      that contain language-packages (LP: #135752)

 -- Michael Vogt <email address hidden> Mon, 27 Oct 2008 10:29:07 +0100

Changed in language-selector:
status: In Progress → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers