gnome-language-selector should warn that a reboot is necessary after changing default system language

Bug #127356 reported by Jonathan Clarke on 2007-07-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Gunnar Hjalmarsson

Bug Description

Binary package hint: language-selector

I'm using latest version of language-selector (0.2.6). When I change the default language using gnome-language-tool, the change takes effect, but only after a restart : gdm is in the new language, as is my user account.

I spent some time wondering why this didn't take effect immediatly, even after logging out, and restarting X. I feel that gnome-language-selector should display a warning message that one has to reboot for changes to take effect. Or, if this is not actually necessary, changes should just take effect :-)

Michael Vogt (mvo) wrote :

I add half a fix for this in the current implementation by making sure that a reboot required notification comes up. For hardy we need to show a propper dialog text, this is currently a bit of a problem as we are in StringFreeze for gutsy already.

Cheers,
 Michael

Changed in language-selector:
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :

language-selector (0.2.7) gutsy; urgency=low

  * fontconfig/zh_CN:
    - updated based on the input of ZhengPeng Hou and
      Arne Goetje (thanks!)
  * fontconfig/ja_JP:
    - fix hinting, thanks to Fumihito YOSHIDA
      (LP: #139738)
  * LanguageSelector/LocaleInfo.py:
    - fix crash in locale output parsing (LP: #139018)
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - do not fail if the system default language is unknown
      (LP: #128168)
    - gray out complex charackter support if im-switch is
      not available (LP: #111311)
    - set reboot required flag when new packages got installed
      (LP: #127356)
  * LanguageSelector/qt/QtLanguageSelector.py:
    - do not crash on broken cache (LP: #108238)
    - gray out complex charackter support if im-switch is
      not available (LP: #111311)

 -- Michael Vogt <email address hidden> Thu, 27 Sep 2007 12:47:36 +0200

Changed in language-selector:
status: Confirmed → Fix Released
Oded Arbel (oded-geek) on 2009-11-10
Changed in language-selector (Ubuntu):
status: Fix Released → Confirmed
Oded Arbel (oded-geek) wrote :

I changed the bug status back to "confirmed" (I didn't know that I can actually do that) because currently on Karmic there is no notification that any action is required - there isn't even an "OK" or "Close" button on the language selector!

Also notably in Karmic a reboot is only needed if the "For everyone at startup and login" language is changed, otherwise only a logout and login is needed.

Use case:
1. User wants to change their langauge
2. User accesses System->Administration->Language Support
3. User changes "For my menus and windows use:" menu to some other language
...? No obvious way is offered to continue

What currently happens is:
4. user closes the window
5. No change is apparent
6. Some times after that the user logs out
7. User logs in and the new language is active

What I expect to happen is:
4. User presses "Close" (or closes the window with the X button, though a "Close" button is a much better case)
5. A new message dialog appears that lets the user know if they need to logout (only "my menus and windows" changed) or reboot ("everyone at start and login" changed) and offers to take that action or continue normally and logout/restart later.
6. User either accepts a restart or logout from the dialog, or continues normally and restarts or logouts later
7. User logs back in and the new language is active.

Gunnar Hjalmarsson (gunnarhj) wrote :

Right below the combo box on language-selector's "Language" tab there is a note saying that changes take effect at next login. I will propose for inclusion in Natty that the text below the "Apply System-Wide" button is extended to include info in a similar way about the need to restart the system.
https://code.launchpad.net/~gunnarhj/language-selector/language-menu

Making system changes take effect at the login screen without a restart would be a GDM thing; see bug 552664.

@Oded Arbel
The interactive approach you suggested would be more 'fancy', but not really necessary IMO. If you think it's important enough, I ask you to please report a separate (wishlist) bug.

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.12

---------------
language-selector (0.12) natty; urgency=low

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - Show only options corresponding to available translations in the
      combo box on language-selector's "Language" tab (LP: #693337).
  * LanguageSelector/LanguageSelector.py:
    - Skip the encoding part in the dmrc "Language" value. It's not
      a locale name, so let's not give the impression it is.
  * data/LanguageSelector.ui:
    - Clearer labels to describe the second ("Text") tab.
    - Icon added to taskbar. Thanks to Pavol Klačanský (LP: #648109).
    - Texts that inform the user about the need to restart for changes
      to system settings to take effect (LP: #127356, #612991).
    - Ellipses removed from the labels on the "Apply System-Wide"
      buttons (LP: #531799).
    - Layout tweaking of the "Format" (previously "Text") tab
      (LP: #697606).
  * data/main-countries:
    - Provide main or origin country for languages with multiple country
      codes present among the languages' available locales.
  * LanguageSelector/utils.py:
    - Take main country code into account when language2locale()
      generates a locale name for LC_MESSAGES.
    - language2locale() rewritten to make use of other language-selector
      functions.

  [ Martin Pitt ]
  * LanguageSelector/gtk/GtkLanguageSelector.py: Update ListStore construction
    to also work with the next pygobject release.
 -- Gunnar Hjalmarsson <email address hidden> Fri, 28 Jan 2011 15:50:50 +0100

Changed in language-selector (Ubuntu):
status: In Progress → Fix Released
Benjamin (nailartcenter) wrote :

In Ubuntu 12.04 beta2 consists the problem again. No warning comes for reboot after change the default system language from english to german.

Gunnar Hjalmarsson (gunnarhj) wrote :

Benjamin,
It's true that the text about a need to reboot has been removed in 12.04, and the reason is that there is no such need any longer. If you don't agree, I ask you to please submit a new bug report where you define "the problem".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions