ubuntu-standard is uninstallable with only security repo enabled : language-selector-common depends unavailable version of accountsservice

Bug #1231529 reported by Guillaume Penin on 2013-09-26
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
accountsservice (Ubuntu)
High
Marc Deslauriers
language-selector (Ubuntu)
Undecided
Unassigned

Bug Description

We're using unattended-upgrades in Ubuntu 12.04 LTS, configured to only update packages from ubuntu-security repository.

language-selector-common (0.79.4) was added to ubuntu-security repository on Friday 2013/09/13.

This package depends on accountsservice (>= 0.6.15-2ubuntu9.5), but this version is not presend in the ubuntu-security repository (0.6.15-2ubuntu9.1).

As a matter of fact, our systems can not upgrade this package :

The following packages have been kept back:
  language-selector-common

This also breaks fresh installations.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Carey Underwood (cwillu) on 2013-10-10
summary: - Unattended-upgrades is unable to upgrade language-selector-common
+ ubuntu-standard is uninstallable with only security repo enabled :
+ language-selector-common depends unavailable version of accountsservice
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

Sebastien,
Can we move accountsservice 0.6.15-2ubuntu9.6 to precise-security, and with that make the security pocket equal the updates pocket?

Marc Deslauriers (mdeslaur) wrote :

I will rebuild accountsservice in the -security pocket.

Changed in accountsservice (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: New → Confirmed
Changed in language-selector (Ubuntu):
status: Confirmed → Invalid
Changed in accountsservice (Ubuntu):
importance: Undecided → High
Gunnar Hjalmarsson (gunnarhj) wrote :

Great, thanks Marc!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.15-2ubuntu9.6.1

---------------
accountsservice (0.6.15-2ubuntu9.6.1) precise-security; urgency=low

  * No change rebuild in security pocket to fix language-selector
    when the updates pocket isn't enabled. (LP: #1231529)
 -- Marc Deslauriers <email address hidden> Thu, 10 Oct 2013 11:10:22 -0400

Changed in accountsservice (Ubuntu):
status: Confirmed → Fix Released
George (george-pezzott) on 2013-10-25
Changed in language-selector (Ubuntu):
status: Invalid → New
status: New → Confirmed
status: Confirmed → New
status: New → Confirmed
George (george-pezzott) on 2013-10-25
Changed in language-selector (Ubuntu):
status: Confirmed → New
status: New → Confirmed
status: Confirmed → New
status: New → Incomplete
status: Incomplete → Confirmed
assignee: nobody → George (george-pezzott)
status: Confirmed → New
status: New → Confirmed
assignee: George (george-pezzott) → nobody
Changed in accountsservice (Ubuntu):
assignee: Marc Deslauriers (mdeslaur) → nobody
Changed in language-selector (Ubuntu):
status: Confirmed → Invalid
Changed in accountsservice (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
Jacques Rijsdijk (rsk61) on 2014-01-11
affects: language-selector (Ubuntu) → dutch (Ubuntu)
affects: dutch (Ubuntu) → language-selector (Ubuntu)

I am new ubuntu user. How do I apply this fix so that I may update this OS?

Seth Arnold (seth-arnold) wrote :

David, this should download and install all updates, including this one, that your system needs:

sudo apt-get update && sudo apt-get -u dist-upgrade

Thanks

Thank you. I am not sure how I did it just yet, but I have fixed the bug.
My OS is now up grading. Thank you for your very fast reply.
 On Jan 28, 2014 5:05 PM, "Seth Arnold" <email address hidden> wrote:

> David, this should download and install all updates, including this one,
> that your system needs:
>
> sudo apt-get update && sudo apt-get -u dist-upgrade
>
> Thanks
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1231529
>
> Title:
> ubuntu-standard is uninstallable with only security repo enabled :
> language-selector-common depends unavailable version of
> accountsservice
>
> Status in "accountsservice" package in Ubuntu:
> Fix Released
> Status in "language-selector" package in Ubuntu:
> Invalid
>
> Bug description:
> We're using unattended-upgrades in Ubuntu 12.04 LTS, configured to
> only update packages from ubuntu-security repository.
>
> language-selector-common (0.79.4) was added to ubuntu-security
> repository on Friday 2013/09/13.
>
> This package depends on accountsservice (>= 0.6.15-2ubuntu9.5), but
> this version is not presend in the ubuntu-security repository
> (0.6.15-2ubuntu9.1).
>
> As a matter of fact, our systems can not upgrade this package :
>
> The following packages have been kept back:
> language-selector-common
>
> This also breaks fresh installations.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/1231529/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers