Fontconfig warning: "/etc/fonts/conf.d/30-cjk-aliases.conf", line 21: Having multiple <family> in <alias> isn't supported and may not work as expected

Bug #1191450 reported by Doug McMahon on 2013-06-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Undecided
Gunnar Hjalmarsson

Bug Description

The result of the latest update to language-selector-common 0.112
Seen in terminal quite often & in ~/.cache/ upstart/dbus & gnome-session logs
(lines 21, 31, 47, 59, 72, 86, 98, 109, 116, 130, 146, 157, 165, 173, 182,

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: language-selector-common 0.112
ProcVersionSignature: Ubuntu 3.9.0-4.9-generic 3.9.4
Uname: Linux 3.9.0-4-generic i686
ApportVersion: 2.10.2-0ubuntu1
Architecture: i386
Date: Sat Jun 15 22:30:39 2013
InstallationDate: Installed on 2013-05-29 (17 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130529)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: language-selector
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
summary: - Fontconfig warning: "/etc/fonts/conf.d/30-cjk-aliases.conf", line 130:
+ Fontconfig warning: "/etc/fonts/conf.d/30-cjk-aliases.conf", line 21:
Having multiple <family> in <alias> isn't supported and may not work as
expected
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your help to improve Ubuntu by reporting this issue!

I did some editing to 30-cjk-aliases.conf that hopefully will stop those fontconfig warnings. Can you please replace your copy of /etc/fonts/conf.avail/30-cjk-aliases.conf with the attached file, and let us know the result.

Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :
Doug McMahon (mc3man) wrote :

The replacement 0-cjk-aliases.conf works fine, no more messages, ect.

Doug McMahon (mc3man) wrote :

That was - 30-cjk-aliases.conf, poor typing...

Gunnar Hjalmarsson (gunnarhj) wrote :

Great, thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.113

---------------
language-selector (0.113) saucy; urgency=low

  * fontconfig/30-cjk-aliases.conf:
    Stop fontconfig warnings (LP: #1191450).
 -- Gunnar Hjalmarsson <email address hidden> Sun, 16 Jun 2013 07:41:00 +0200

Changed in language-selector (Ubuntu):
status: In Progress → Fix Released
mtbdrew (mtbdrew) wrote :

Thanks for the file this corrected the issue for me as well.

Lupe Christoph (lupe) wrote :

This bug hasn't been fixed it seems - 0.116 (installed by Kubuntu upgrade to 13.10) has it, and I get a long list every five minutes, triggered by munin-cron. The file installed is identical to the one provided by Gunnar Hjalmarsson.

Probably an independent problem, this is also in the cron mail:

Fontconfig warning: "/etc/fonts/conf.d/99-language-selector-zh.conf", line 11: Having multiple values in <test> isn't supported and may not work as expected.

Lupe Christoph (lupe) wrote :

Please ignore #9 - this was caused by the upgrade running. I've just seen that it has stopped now that the upgrade has finished.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers