gnome-language-selector crashed with TypeError in _expand_pkg_pattern(): not enough arguments for format string

Bug #1161953 reported by Gunnar Hjalmarsson on 2013-03-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
High
Gunnar Hjalmarsson
Precise
High
Gunnar Hjalmarsson

Bug Description

Precise SRU request
-------------------

[Impact]
gnome-language-selector crashes when launched under certain conditions.

[Test Case]
Not able to tell exactly when the buggy code is run and when it's not. The severity of the bug still justifies this SRU IMO.

[Regression Potential]
Minimal

[Original description]
This happened suddenly after a dist-upgrade from 12.10 to 13.04. The buggy code is not always run; the same version of language-selector launches fine on another 13.04 installation of mine.

Anyway, running the buggy code results in a fatal error, and since it's sometimes run at the launch of language-selector (and also when running the check-language-support command), it prevents all use of language-selector.

The proposed fix is obvious and harmless. I think that a FinalBetaFreeze exception is motivated.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: language-selector-gnome 0.107
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
Uname: Linux 3.8.0-15-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.9.2-0ubuntu5
Architecture: i386
CrashCounter: 1
Date: Fri Mar 29 17:46:14 2013
ExecutablePath: /usr/bin/gnome-language-selector
InstallationDate: Installed on 2012-10-11 (168 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3.3 /usr/bin/gnome-language-selector
PythonArgs: ['/usr/bin/gnome-language-selector']
SourcePackage: language-selector
Title: gnome-language-selector crashed with TypeError in _expand_pkg_pattern(): not enough arguments for format string
UpgradeStatus: Upgraded to raring on 2013-03-29 (0 days ago)
UserGroups: adm admin lpadmin sambashare

Gunnar Hjalmarsson (gunnarhj) wrote :
Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
tags: removed: need-duplicate-check
Stefano Rivera (stefanor) wrote :

This looks like a trivial bug fix, so please just upload it.

Jamie Strandboge (jdstrand) wrote :

Thanks for your patch! I've merged your changes and will upload shortly.

Changed in language-selector (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.108

---------------
language-selector (0.108) raring; urgency=low

  * language_support_pkgs.py:
    Fix of TypeError in _expand_pkg_pattern() (LP: #1161953).
 -- Gunnar Hjalmarsson <email address hidden> Fri, 29 Mar 2013 18:40:00 +0100

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :
tags: added: patch
description: updated
Changed in language-selector (Ubuntu Precise):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
status: New → In Progress
Dimitri John Ledkov (xnox) wrote :

uploaded into precise-proposed unapproved queue. Next a member of SRU team should verify and accept the proposed package.
Unsubscribing Ubuntu Sponsors Team.

Hello Gunnar, or anyone else affected,

Accepted language-selector into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/language-selector/0.79.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in language-selector (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I have installed language-selector 0.79.3 from precise-proposed. With prerequisites that cause version 0.79.2 to crash with the TypeError at launch, language-selector now starts without problems.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.79.3

---------------
language-selector (0.79.3) precise-proposed; urgency=low

  * language_support_pkgs.py:
    Fix of TypeError in _expand_pkg_pattern() (LP: #1161953).
 -- Gunnar Hjalmarsson <email address hidden> Tue, 09 Apr 2013 13:11:25 +0100

Changed in language-selector (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers