Check for missing language support for all installed languages

Bug #1134364 reported by Gunnar Hjalmarsson on 2013-02-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
accountsservice (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Gunnar Hjalmarsson
language-selector (Ubuntu)
Undecided
glen cunningham
Precise
Undecided
Gunnar Hjalmarsson

Bug Description

[Impact]
When dealing with bug 1103547 it was considered appropriate to let language-selector start checking for missing language support packages for all installed languages. At first hand it's the fix of 'the hunspell issue' in bug 1103547 that is anxious to backport as an SRU. This bug is related to bug 1103547 in such a way that it's reasonable to backport also the fix of this bug as an SRU.

[Test Case]
Steps to reproduce:
* On an updated Precise (and assuming that French was not already installed), install French via the "Installed Languages" window in Language Support.
* Close Language Support
* Remove hunspell-fr:
  sudo dpkg -r hunspell-fr
* Start Language Support and note that you are not prompted to install the missing package hunspell-fr.

[Regression Potential]
Besides the proposed change to LanguageSelector.py, and to prevent undesired side effects, we identified a need to:
* backport https://launchpad.net/ubuntu/+source/accountsservice/0.6.29-1ubuntu5, and
* modify available_languages() in language_support_pkgs.py to safely exclude non-installed languages.
Given those supplementary changes (which are included in this SRU request), the regression risk should be low.

Gunnar Hjalmarsson (gunnarhj) wrote :
tags: added: patch

The attachment "accountsservice_precise-sru_lp-1134364.diff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Martin Pitt (pitti) on 2013-02-28
Changed in accountsservice (Ubuntu):
status: New → Fix Released
Changed in language-selector (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) on 2013-02-28
Changed in accountsservice (Ubuntu Precise):
status: New → In Progress
Changed in language-selector (Ubuntu Precise):
status: New → In Progress
Changed in accountsservice (Ubuntu Precise):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
Changed in language-selector (Ubuntu Precise):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
Sebastien Bacher (seb128) wrote :

(seems like pitti sponsored those, unsubscribing sponsors)

Dave Walker (davewalker) wrote :

Briefly looking at this SRU bug, please can you expand the description to satisfy the template suggested here:
https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

It will unlikely be processed without this, particularly as trying to judge regression potential.

Thanks.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Dave: Description updated as requested.

description: updated

Hello Gunnar, or anyone else affected,

Accepted accountsservice into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/accountsservice/0.6.15-2ubuntu9.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in accountsservice (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in language-selector (Ubuntu Precise):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Gunnar, or anyone else affected,

Accepted language-selector into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/language-selector/0.79.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Gunnar Hjalmarsson (gunnarhj) wrote :

I have successfully installed and run language-selector 0.79.2 and accountsservice 0.6.15-2ubuntu9.5 from precise-proposed. When following the test case steps above I was prompted to install hunspell-fr as expected, even if French is not selected as my current language.

I also generated the locale zh_CN.utf8 using locale-gen() (simplified Chinese is not installed) and restarted gnome-language-selector. I was not prompted to install any Chinese language support files.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.15-2ubuntu9.5

---------------
accountsservice (0.6.15-2ubuntu9.5) precise-proposed; urgency=low

  * debian/patches/0009-language-tools.patch:
    Prevent language-options from listing items that don't correspond
    with an installed langpack, even if there is a matching locale
    (LP: #1134364).
 -- Gunnar Hjalmarsson <email address hidden> Wed, 27 Feb 2013 15:48:00 +0100

Changed in accountsservice (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.79.2

---------------
language-selector (0.79.2) precise-proposed; urgency=low

  * LanguageSelector/LanguageSelector.py:
    Call missing() in language_support_pkgs.py instead of
    by_locale(), so the check for missing language support packages
    is carried out for all the installed languages, not only for the
    current system language (LP: #1134364).
  * language_support_pkgs.py:
    - Hack to prevent that users are prompted to install hunspell-de-xx
      when the enhanced (and conflicting) hunspell-de-xx-frami is
      installed (LP: #1103547).
    - Changes in available_languages() to avoid that users are prompted
      to install language support for non-installed languages. That
      could happen if there were other locales on the system but the
      locales representing the installed languages (LP: #1134364).
  * LanguageSelector/LangCache.py:
    When a language is removed, don't remove packages that are not
    language specific (LP: #37707).
  * debian/control:
    Bump the accountsservice dependency.
 -- Gunnar Hjalmarsson <email address hidden> Wed, 27 Feb 2013 16:44:00 +0100

Changed in language-selector (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in language-selector (Ubuntu):
assignee: nobody → glen cunningham (glencunningham7510)

Thank You

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers