Broken plural forms in KDE

Bug #203349 reported by Martin Gräßlin
150
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Amarok
Invalid
Medium
Launchpad itself
High
Данило Шеган
Medibuntu
Invalid
Undecided
Unassigned
Ubuntu Translations
Undecided
Unassigned
language-pack-kde-ca (Ubuntu)
Medium
Unassigned
language-pack-kde-cs (Ubuntu)
Medium
Unassigned
language-pack-kde-da (Ubuntu)
Medium
Unassigned
language-pack-kde-de (Ubuntu)
Medium
Unassigned
language-pack-kde-en (Ubuntu)
Medium
Unassigned
language-pack-kde-es (Ubuntu)
Medium
Ubuntu Spanish Translators
language-pack-kde-fr (Ubuntu)
Medium
Unassigned
language-pack-kde-hu (Ubuntu)
Medium
Unassigned
language-pack-kde-it (Ubuntu)
Medium
Unassigned
language-pack-kde-pl (Ubuntu)
Medium
Unassigned
language-pack-kde-ru (Ubuntu)
Medium
Unassigned
language-pack-kde-sv (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: language-pack-kde-de

I found a broken translation in the German version of Amarok.

How to find:
Open the context menu of a song. The last entry shows "BROKEN TRANSLATION Edit Track Information"

Revision history for this message
ana (anabelle) wrote :

This also happens in the same field "Edit track information" but in the spanish translation.

Exact same error.

Revision history for this message
Massimo Bilvi (massimo-bilvi) wrote :

Exact same error but in the italian translation.

Revision history for this message
Alexis (alxju) wrote :

Same problem in French translation. Is not a missing in Amarok's kde translation, but in Kubuntu, package only.

See this repport I made on Kde bug trackeing system:

http://bugs.kde.org/show_bug.cgi?id=161257

But now.. the "LTS" version is released without needed corrections...

Others french mistranslation I saw:
- in the contextual menu, the third tab is translated as "Artist" (but in french is "Artiste" (with a "e")
- idem in the playlist columns: "Artist" is not correctly translated (fr: Artiste)
- When you click over a song in the playlist, "manage files" > "Organise file" / "Delete file". "Delete file" isn't translated (by "Supprimer ce fichier").

Notes: using Amarok 1.4.9.1

Changed in amarok:
status: Unknown → Invalid
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

We don't ship any amarok translations in medibuntu, they are removed with pkgstriptranslations. The broken translations come from language-pack-kde-*-base.

Changed in medibuntu:
status: New → Invalid
Revision history for this message
Harald Sitter (apachelogger) wrote :

For appearance in Adept see bug #212313

Revision history for this message
Harald Sitter (apachelogger) wrote :

For appearance in D3lphin see bug #198864

Revision history for this message
Harald Sitter (apachelogger) wrote :

For appearance in KTorrent see bug #162861

Changed in language-pack-kde-cs:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-de:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-en:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-es:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-fr:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-hu:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-it:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-pl:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-ru:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Harald Sitter (apachelogger) wrote :

Sorry for the flood, but this issue is quite large and therefore hard to keep track of.

I did some research and posted my results in bug #222221 to Rosetta (the Launchpad Translation component which is causing these issues), please post extran research information which are helpful in order to fix the bug there.

Thank you all for reporting these issues and sorry for leaving them unnoticed for so long.

Changed in language-pack-kde-ca:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-sv:
importance: Undecided → Medium
status: New → Confirmed
Changed in language-pack-kde-da:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
toer (tore-ericsson) wrote :

My Dolphin within (K)Ubuntu 7.10 , gutsy, displaying in the Swedish language, issues
the annoying line at each window refresh (even F5). I updated the last sections to
....
msgid ""
"_: NAME OF TRANSLATORS\n"
"Your names"
msgstr ",Launchpad Contributions:,Daniel Nylander"

msgid ""
"_n: 1 File selected (%1)\n"
"%n Files selected (%1)"
msgstr ""
"1 fil markerad (%1)\n"
"%n filer markerade (%1)"

msgid ""
"_n: 1 Folder selected\n"
"%n Folders selected"
msgstr ""
"1 mapp markerad\n"
"%n mappar markerade"

msgid ""
"_n: 1 Item\n"
"%n Items"
msgstr ""
"1 objekt\n"
"%n objekt"

But (at least) this status message is untranslated (no error message though), example:

"23 Objects (3 Folders, 20 Files)" is translated into "23 objekt (3 Folders, 20 Files) ", that is, the expression within brackets is not translated. By the way, shouldn't the term "Directory" be preferred before "Folder"? In such a case, the Swedish corresponding word to be used is "katalog", pl. "kataloger".

Revision history for this message
Mads Peter Rommedahl (lhademmor) wrote :

I can confirm this behaviour in Amarok w/ Danish translation - try right-clicking on a track and in the menu you can see "BROKEN TRANSLATION Edit Track Information..."

Revision history for this message
Carlos Perelló Marín (carlos) wrote :

You can see the action plan we are going to take at:

https://bugs.edge.launchpad.net/rosetta/+bug/222221/comments/5

Changed in rosetta:
importance: Undecided → High
milestone: none → 1.2.5
status: New → Confirmed
Revision history for this message
Jonathan Riddell (jr) wrote :

Jeroen commented on bug 222221, hopefully it'll get fixed in the next Launchpad update.

Changed in rosetta:
assignee: nobody → danilo
Changed in rosetta:
status: Confirmed → In Progress
Revision history for this message
Данило Шеган (danilo) wrote :

Fixed in RF 6361.

Changed in rosetta:
status: In Progress → Fix Committed
Changed in rosetta:
status: Fix Committed → Fix Released
Revision history for this message
Данило Шеган (danilo) wrote :

Note: for translations to be actually fixed, we need both .pot and .po files re-uploaded (since the bug caused Launchpad to lose some data, we can't reconstruct it).

Revision history for this message
Tom Chiverton (bugs-launchpad-net-falkensweb) wrote :

This has been marked invalid for Amarok, but I still see it in 8.04.1's Amarok (english locale) and the matching KDE bug has been closed as a Ubuntu problem.

Revision history for this message
Alexis (alxju) wrote :

Indeed, I haven't seen any changes in Amarok. Why it is not possible to correct this mistranslations quickly? More than 3 mouth now..

Revision history for this message
gordboy (gordonamiller-btinternet) wrote :

I agree with Alexis, but I go further.

It is high time that the people who are responsible for maintaining Hardy were shown the door. It is been an unmitigated disaster from Day 1.

What is infuriating is that people who are capable and want to help are being denied access in order to "protect" the reputations of the current maintainers.

I have never seen such a comedy of errors from a bunch of amateur muppets. It not only brings Ubuntu into disrepute, it also brings the whole open source movement into disrepute.

Revision history for this message
Harald Sitter (apachelogger) wrote :

I have absolutely no idea what you are talking about, gordboy.

Revision history for this message
Alexis (alxju) wrote :

Me, I understand gordboy. For several months we have reported a bug bad translations that seems important (several errors of translation into several languages). We (the community) are ready to make corrections. But nothing happens. There are no updates. No message of responsible packages in question.

FOSS say working with the community. The community is there. Perhaps inexperienced, but voluntary. What can be done?

What we expect to make the correction knowing that it can be done very quickly?

Revision history for this message
Martin Pitt (pitti) wrote :

Which packages' translations does that affect at all, just amarok's?

I was pointed to this problem recently, I'm currently discussing with the LP maintainers how we can recover the original translations without trashing manual changes made in the LP web UI.

Revision history for this message
Lydia Pintscher (lydia-pintscher) wrote :

According to the duplicate reports it affects at least Amarok, KTorrent, Dolphin and Adept-notifier.
I assume it affects more.

Revision history for this message
Urs Hanselmann (urs-hanselmann) wrote :

this fixed the problem for me (with language-pack-kde-de): https://bugs.launchpad.net/ubuntu/+source/dolphin/+bug/198864/comments/4

Changed in language-pack-kde-de:
status: Confirmed → Fix Committed
Revision history for this message
Harald Sitter (apachelogger) wrote :

This is not a fix, it's a very temporary workaround (one would have to do this after every upgrade).

Changed in language-pack-kde-de:
status: Fix Committed → Confirmed
Revision history for this message
Takahani (simon-esneault) wrote :

Still here in amarok 1.4.9.1 french medibuntu version, Ubuntu 8.04

Revision history for this message
Gergely Csépány (cheoppy) wrote :

Latest Amarok update from hardy-updates broke Hungarian translations.
Amarok package version: 1.4.9.1-0ubuntu3.1.

Revision history for this message
Tom Chiverton (bugs-launchpad-net-falkensweb) wrote :

This appears fixed in 8.04 as of now (UK english)

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

First let me state I like Kubuntu (8.04 LTS), don't like KDE 4 for various reason.
It's not the eye candy, I dislike..., but the memory consumption of plasma in special.
So I'm happy with KDE 3.5.10 - even with an update to 8.10 (very nice) I would reconvert.

Apropos Eyecandy. The last three Language Packs did not update this error yet.
It still appears & hurt my eyes everyday. I really wonder how many users accept this sluggish error. Will you pls by update the priority by now to high ?
Dolphin is a every day tool - so I + any other user would stumple 'bout this (again)
sluggish error on a daily & frequent frequent base. This is by no ways acceptable.

It really disappoints me this error has not been corrected yet. The workaround from Urs worked 'til today - but now there ain't no "d3'lphin.mo" no more in the directory
user/share/locale-langpack/de/LC_MESSAGES/ ???

What can we do, but wait ???

Greetings to all
(from Germany)

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

KDE 3.5.10 / Dolphin / Broken Translation

Hello again
I've got to correct myself. The file "d3lphin.mo" is in the given place.

And this: https://bugs.launchpad.net/ubuntu/+source/dolphin/+bug/198864/comments/4
(dated 2008-06-16) worked fine again.

Looking forward to the nxt KDE-Language-Pack...
Again, I'd like to ask to set prority of this error to "high" since it was not get done on three updates. Is that possible ?

Best greetings

Revision history for this message
Arne Goetje (arnegoetje) wrote :

We have new language-pack updates in hardy-proposed. Can you please test if the problem still exists with the latest updates? Thanks.

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

Hello
thanks for the fast reply !
as stated before the error recurred with the last three updates on the language packs.

Today was installed:

Richte language-pack-de ein (1:8.04+20081103) ...
Richte language-pack-en ein (1:8.04+20081103) ...
Richte language-pack-kde-de ein (1:8.04+20081103) ...
Richte language-pack-kde-en ein (1:8.04+20081103) ... dpkg run finished

And there was this error again, this is why I am slightly upset...
Tested and still there.
There is a thread on the forum ubuntuuseres.de:
http://forum.ubuntuusers.de/topic/uebersetzungsfehler-seit-update/
Firstly opened since 29-02-2008

This is were I found the link to the temporarely workaround.
Today I reopened the thread there as unsolved, since it was not really solved with a workaround.
I would not have reporteted this bug, if it wouldn't have appeared the fourth time in a row
with the update of the language packs. It's an ongoing error.
I'm a patient person - but today I was fed. Got myself a login-ID-that much fed.
With the visual effect on a standard user, I would justify this error as serious.
The more hence it seems to be very tiny coding work.
Excuses for inconveniences coming up with this old crap again.

Hope this help to make Kubuntu better everyday.
Especially as I will stay with the LTS-Version.
Thanks again for fast reply.
Best regards ROLAND

Revision history for this message
Arne Goetje (arnegoetje) wrote :

Apparently this was a major bug in Launchpad which has been fixed already in May/June. Unfortunately we need to import all the KDE translations again, since some data got lost due to that bug. This task got lost somehow. We are working on reimporting them right now and will generate new language-packs when it's done.

Thanks for the heads up.

Changed in language-pack-kde-ca:
status: Confirmed → In Progress
Changed in language-pack-kde-cs:
status: Confirmed → In Progress
Changed in language-pack-kde-da:
status: Confirmed → In Progress
Changed in language-pack-kde-de:
status: Confirmed → In Progress
Changed in language-pack-kde-en:
status: Confirmed → In Progress
Changed in language-pack-kde-es:
status: Confirmed → In Progress
Changed in language-pack-kde-fr:
status: Confirmed → In Progress
Changed in language-pack-kde-hu:
status: Confirmed → In Progress
Changed in language-pack-kde-it:
status: Confirmed → In Progress
Changed in language-pack-kde-pl:
status: Confirmed → In Progress
Changed in language-pack-kde-ru:
status: Confirmed → In Progress
Changed in language-pack-kde-sv:
status: Confirmed → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

https://chinstrap.canonical.com/~pitti/kde-rebuilds/ has the rebuilt translation tarballs for import.

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

Tks 4 explanation + tks 4 taking action
Greetings from Germany

Revision history for this message
Данило Шеган (danilo) wrote :

I've uploaded KDE files to Launchpad, I am hoping they'll be imported during weekend. Martin, thanks for providing these.

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

Hi there,

this sluggish error reoccured again on the update of the KDE-language-packs on 07-Dec-2008

Kubuntu 8.04.1 - D3lphin 0.9.2 - KDE 3.5.10

(Lese Datenbank ... 177286 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von language-pack-de 1:8.04+20081103
(durch .../language-pack-de_1%3a8.04+20081124_all.deb) ...
Entpacke Ersatz für language-pack-de ...
Ersetze die Dateien im alten Paket language-pack-de-base ...
Vorbereiten zum Ersetzen von language-pack-en 1:8.04+20081103
(durch .../language-pack-en_1%3a8.04+20081124_all.deb) ...
Entpacke Ersatz für language-pack-en ...
Ersetze die Dateien im alten Paket language-pack-en-base ...
Vorbereiten zum Ersetzen von language-pack-kde-de 1:8.04+20081103
(durch .../language-pack-kde-de_1%3a8.04+20081124_all.deb) ...
Entpacke Ersatz für language-pack-kde-de ...
Ersetze die Dateien im alten Paket language-pack-kde-de-base ...
Vorbereiten zum Ersetzen von language-pack-kde-en 1:8.04+20081103
(durch .../language-pack-kde-en_1%3a8.04+20081124_all.deb) ...
Entpacke Ersatz für language-pack-kde-en ...
Ersetze die Dateien im alten Paket language-pack-kde-en-base ...
Richte language-pack-de ein (1:8.04+20081124) ...
Richte language-pack-en ein (1:8.04+20081124) ...
Richte language-pack-kde-de ein (1:8.04+20081124) ...
Richte language-pack-kde-en ein (1:8.04+20081124) ...
dpkg run finished!

I also refer to bug# 44599

Hope this error may be settled soon, ongoing since Version 7.04- this is hardly believable

regards

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

Detailized Picture added

Revision history for this message
Uqbar (uqbar) wrote :

I think none is really interested in this flaw.
I moved to English Kubuntu just to avoid a number of similar problems.
My next move will be to a different more careful distro.

Arne Goetje (arnegoetje)
Changed in language-pack-kde-ca:
status: In Progress → Fix Committed
Changed in language-pack-kde-cs:
status: In Progress → Fix Committed
Changed in language-pack-kde-da:
status: In Progress → Fix Committed
Changed in language-pack-kde-de:
status: In Progress → Fix Committed
Changed in language-pack-kde-en:
status: In Progress → Fix Committed
Changed in language-pack-kde-es:
status: In Progress → Fix Committed
Changed in language-pack-kde-fr:
status: In Progress → Fix Committed
Changed in language-pack-kde-hu:
status: In Progress → Fix Committed
Changed in language-pack-kde-it:
status: In Progress → Fix Committed
Changed in language-pack-kde-pl:
status: In Progress → Fix Committed
Changed in language-pack-kde-ru:
status: In Progress → Fix Committed
Changed in language-pack-kde-sv:
status: In Progress → Fix Committed
Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

8.04 KDE 3.5.10 D3lphin

Actually I feel quite sorry about the current development on this bug. D3lphin has become an english peninsula within my german localised distro during the last language pack update. Looking up /usr/share/locale-langpack/de/LC_MESSAGES/ The file d3lphin.mo this file is completely missing now.

This application seems to be completely given up by the maintainer at alpha status? Trying to go to the homepage of the developer I get a warning on the Certificate in Firefox. I will n o t open it.

Why is this not communicated?

Just hope this does not become security measures one day.

Thanks for looking at this subject.

With kind regards

Revision history for this message
Uqbar (uqbar) wrote :

An untrusted certificate should not hurt anyone.
From the website:

<quote>
Hi folks,

sorry for all these inconviniences, but at the moment I have really no time to code on D3lphin because of personal issues :-(

If one wants to help with D3lphin, send me a mail and I can give you SVN access, maybe there are people with more time than me. Still wondering if it was a good idea to take over maintaining of D3lphin :-( Sorry!

Best regards,

-- marrat 2007-12-17 08:22:57
</quote>

Which is a 13 months old "hold on" message.
I would advise the guys at Ubuntu/Debian to revert to the ol' good konqueror.

Revision history for this message
Thomas Kluyver (takluyver) wrote : Re: [Bug 203349] Re: Broken plural forms in KDE

2009/1/20 uqbar <email address hidden>

> I would advise the guys at Ubuntu/Debian to revert to the ol' good
> konqueror.

Kubuntu has moved to KDE4 for Intrepid onwards, so there will be no need to
revert (D3lphin is the KDE3 version of dolphin, a mainly KDE4 program, which
works fine). In the mean time, konqueror is still there in Hardy if you want
to use it.

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

I am not familiar with Konquerer, and I will not use. Taking Krusader instead.

 I have issued the so called fix in german ubuntu forum (dolphin_fixed.mo). This "fix" has not come around to get implemented for a long time.

I think we cannot reach all KDE 8.04 user thruout Germany via a forum message?. Handling bugs like this does damage to the Image of KDE. Same like KDE 4.0 on 8.10 did via lack of communication.

The international bug jam would have some good leg taping & laughters on this. All this is going back to the fact that some1 put a wrong status on this bug in regards of d3lphin (mine& confirmed of some other users is german speaking with us again!)

Thanks 4 ur help.

robin

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

Fixed in italian language pack.

Changed in language-pack-kde-it (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Uqbar (uqbar) wrote :

Sergio, does this mean that I can install KUbuntu and get the proper italian messages?
Thanks.

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

Yes, if not immediately, just wait a language pack update.

Changed in language-pack-kde-es (Ubuntu):
assignee: nobody → ubuntu-l10n-es
Adi Roiban (adiroiban)
tags: added: i18n
Revision history for this message
Uqbar (uqbar) wrote :

Does all this mean that I can now come back to KDE and see the proper translations?

David Planella (dpm)
tags: added: kubuntu
Adi Roiban (adiroiban)
Changed in ubuntu-translations:
status: New → Fix Released
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

With the latest language pack updates, the problem where vast amounts of KDE in Intrepid were not translated should be fixed. (Note that things still might not be perfect in Intrepid)

It would be nice if international users still using Intrepid could see if the latest language packs did fix the majority of the problem.

description: updated
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Since these should be fixed now and nobody's complained, I'll mark the remaining ones as fixed.

Changed in language-pack-kde-ca (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-cs (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-da (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-de (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-en (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-es (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-fr (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-hu (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-pl (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-ru (Ubuntu):
status: Fix Committed → Fix Released
Changed in language-pack-kde-sv (Ubuntu):
status: Fix Committed → Fix Released
Changed in amarok:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.