items of system menu display english in zh_CN

Bug #512211 reported by YunQiang Su
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
language-pack-gnome-zh-hans (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
pyxdg (Ubuntu)
High
Martin Pitt
Lucid
High
Martin Pitt

Bug Description

Binary package hint: language-pack-gnome-zh-hans

after upgraded on 2009-01-25,it occered

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: c5b469c7e49d1f6d9d00553ad2e4697f
CheckboxSystem: b1053abfde9c3129a6d80935c06af64c
Date: Mon Jan 25 15:17:35 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: language-pack-gnome-zh-hans 1:10.04+20100105
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=zh_CN.utf8
 PATH=(custom, user)
 LANG=zh_CN.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
SourcePackage: language-pack-gnome-zh-hans
Uname: Linux 2.6.32-11-generic x86_64

Related branches

Revision history for this message
YunQiang Su (wzssyqa) wrote :
YunQiang Su (wzssyqa)
Changed in language-pack-gnome-zh-hans (Ubuntu):
assignee: nobody → wzssyqa (wzssyqa)
assignee: wzssyqa (wzssyqa) → nobody
assignee: nobody → Bug Supervisors for Ubuntu Translations (ubuntu-translations-bugsupervisors)
assignee: Bug Supervisors for Ubuntu Translations (ubuntu-translations-bugsupervisors) → Ubuntu Translator Tools Hackers (ubuntu-translator-tools-hackers)
assignee: Ubuntu Translator Tools Hackers (ubuntu-translator-tools-hackers) → nobody
YunQiang Su (wzssyqa)
Changed in language-pack-gnome-zh-hans (Ubuntu):
assignee: nobody → Ubuntu Translations Coordinators (ubuntu-translations-coordinators)
YunQiang Su (wzssyqa)
Changed in language-pack-gnome-zh-hans (Ubuntu):
assignee: Ubuntu Translations Coordinators (ubuntu-translations-coordinators) → nobody
Revision history for this message
David Planella (dpm) wrote :

I can confirm this after having upgraded to Lucid UNE. Not only the entries in the Preferences menu show up untranslated, but all entries in the menus.

I've also tested this on a Lucid virtual machine, but I could not reproduce it there.

Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → High
Changed in language-pack-gnome-zh-hans (Ubuntu):
status: New → Invalid
Revision history for this message
Yann Dìnendal (yannbreliere) wrote :

I can confirm this bug, although I don't use language-pack-gnome-zh-hans but language-pack-gnome-fr.

So everything is in french, including «Système», «Préférences» and «Administration».
But everything inside these 2 menus is in english ("About me", "Appearance",… "Computer janitor", "Disk utility"…).
The «Applications» menu also has some entries in english, like "Calculator" or "Rhythmbox Music Player".

Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is due to the gnome-menus caching, assigning to pitti who did those changes

Changed in gnome-menus (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti)
Changed in gnome-menus (Ubuntu):
status: New → In Progress
importance: Undecided → High
tags: added: regression-potential
Changed in gnome-menus (Ubuntu):
milestone: none → lucid-alpha-3
Revision history for this message
Martin Pitt (pitti) wrote :

Looks like this is a bug in pyxdg:

$ python -c 'from xdg.DesktopEntry import DesktopEntry; import locale; locale.setlocale(locale.LC_ALL, ""); print DesktopEntry("/usr/share/applications/gnome-settings-mouse.desktop").getComment()'
Set your mouse preferences

(it should deliver the German translation)

affects: gnome-menus (Ubuntu Lucid) → pyxdg (Ubuntu Lucid)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyxdg - 0.18-1ubuntu2

---------------
pyxdg (0.18-1ubuntu2) lucid; urgency=low

  * Add debian/patches/series, so that gettext-support.patch actually gets
    applied. (LP: #512211)
 -- Martin Pitt <email address hidden> Wed, 10 Feb 2010 14:24:32 +0100

Changed in pyxdg (Ubuntu Lucid):
status: In Progress → Fix Released
David Planella (dpm)
Changed in ubuntu-translations:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers