"Deleted items folder" name doesn't make sense

Bug #72304 reported by Joachim Noreiko
12
Affects Status Importance Assigned to Milestone
language-pack-gnome-en-base (Ubuntu)
Undecided
Ubuntu English (United Kingdom) Translators

Bug Description

This used to be called the Trash or Wastebasket.
Now it's "Deleted items folder".

This causes inconsistencies with the trash metaphor.
For example, the context menu for an item in Trash says "Delete from Deleted items folder". Huh? It's already deleted, as it's a 'deleted item'!

The whole purpose of the trash metaphor is to create a distinction between putting something in the trash, where you can get it back, and deleting, which is killing something for good.

Revision history for this message
Tom Harris (tom-harris) wrote :

I was just about to file the same bug. Does anyone know why this was even changed? What was wrong with "Wastebasket"?

Revision history for this message
Francesco Fumanti (frafu) wrote :

Why not simply call it: 'Empty Trash'

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu and locale do you use? That looks like a translation bug

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Revision history for this message
Joachim Noreiko (jnoreiko) wrote :

I'm using Edgy.
I don't know how to find out what locale I am using, but when I first set up I would have set my location to United Kingdom.

Revision history for this message
Tom Harris (tom-harris) wrote :

Same here. Seems to be a British English translation problem. Slightly off-topic, but how does Rosetta work? For instance if I were to find and fix this string, would that be applied in an update at some point?

Revision history for this message
Sebastien Bacher (seb128) wrote :

rosetta export translations which are used to produce updated language packs, if you fix it on rosetta it'll be fixed with next upload

Changed in nautilus:
assignee: desktop-bugs → ubuntu-l10n-en-gb
status: Needs Info → Unconfirmed
Revision history for this message
Tom Harris (tom-harris) wrote :

I can't work out Rosetta so I'll leave someone else to do it. According to the UK translation team "Deleted Items" is the preferred nomenclature (https://wiki.ubuntu.com/EnglishTranslation/WordSubstitution), however I don't think it is suitable. For a start, it loses the real-world metaphor, and is too long and cumbersome. I can understand objections to "Trash", but "Wastebasket" seems perfect to my mind, and is consistent with previous Ubuntu releases. I also retains the original meaning of "Trash" which "Deleted Items" does not. "Waste Bin" could also work.

Revision history for this message
Joachim Noreiko (jnoreiko) wrote :

I've downloaded the two PO files from Rosetta but I'm not sure what to do with them next.

Revision history for this message
Joachim Noreiko (jnoreiko) wrote :

Sorry -- I mean I've fixed the "Deleted items" translation to "Wastebasket" throughout. I don't have the access rights to upload them back to rosetta.

Here's the one for gnome-applets.

Revision history for this message
Roger Light (roger.light) wrote :

I'd agree that "Deleted items folder" isn't the best solution, especially in the example given, but on the other hand as someone who lives in England I'm pretty certain that I've never once said "wastebasket". In my opinion the correct term should be "Rubbish bin".

Revision history for this message
Benjamin Goodger (goodgerster-deactivatedaccount) wrote : Re: [Ubuntu-l10n-eng] [Bug 72304] Re: "Deleted items folder" name doesn't make sense

On 11/12/06, Roger Light <email address hidden> wrote:
>
> I'd agree that "Deleted items folder" isn't the best solution,
> especially in the example given, but on the other hand as someone who
> lives in England I'm pretty certain that I've never once said
> "wastebasket". In my opinion the correct term should be "Rubbish bin".

Perhaps "bin" at best, but as I have previously covered the metaphor is
stale and should be dumped.

--
Ben Goodger
#391382
---------------------

Mi admiras religiajn; ili estas fine ebliĝinta solvi la maljunegan demandon
"kiel oni povas vivi sencerbe?".
It is well-known that I am blunt and unsophisticated. It's largely your
fault if you object to this.

Revision history for this message
Sridhar Dhanapalan (sridhar) wrote :

This is not a bug. The change in nomenclature was a decision made after careful debate on the ubuntu-l10n-eng mailing list. This discussion weighed a range of factors, including but not exclusive to the ones which have been mentioned here.

Please do not unilaterally try to change the policy of the ubuntu-l10n-en-gb team by altering our wiki pages. If you wish to make a difference, subscribe to the list and apply to join the team. I strongly suggest that you browse through our list archives to gain an understanding of our goals and reasoning.

Revision history for this message
rockbadger (paul-huxley) wrote : Re: [Ubuntu-l10n-eng] [Bug 72304] Re: "Deleted items folder" name doesn't make sense

On Mon, 2006-12-11 at 12:17 +0000, Ben Goodger wrote:
> On 11/12/06, Roger Light <email address hidden> wrote:
> >
> > I'd agree that "Deleted items folder" isn't the best solution,
> > especially in the example given, but on the other hand as someone who
> > lives in England I'm pretty certain that I've never once said
> > "wastebasket". In my opinion the correct term should be "Rubbish bin".
>
>
> Perhaps "bin" at best, but as I have previously covered the metaphor is
> stale and should be dumped.
>

Dumped? Now there's an idea. How about renaming it the dump?

> --
> Ben Goodger
> #391382
> ---------------------
>
> Mi admiras religiajn; ili estas fine ebliĝinta solvi la maljunegan demandon
> "kiel oni povas vivi sencerbe?".
> It is well-known that I am blunt and unsophisticated. It's largely your
> fault if you object to this.
>
> --
> "Deleted items folder" name doesn't make sense
> https://launchpad.net/bugs/72304
>

Changed in language-pack-gnome-en-base:
status: Unconfirmed → Rejected
Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

To be honest, I am in the team and have been against "Deleted Items folder" ever since it became policy.

1. It's long winded.
2. It is not used in the real world
3. The capitalisation seems odd.

Mind you, I can't think of anything better than this, but "Wastebasket" seemed fine, and they say "If it isn't broken, don't fix it."

Revision history for this message
Joachim Noreiko (jnoreiko) wrote :

I'm not hugely bothered what it's changed *to* -- I picked 'Wastebasket' because it's what Macs used to use before OS X.

'Deleted Items folder' is wordy and cumbersome, but the worst problem with it is that it completely breaks the trash metaphor: objects in the trash are not deleted, they are in the trash. You delete something by emptying the trash.

Using 'Deleted Items folder' forces you to set up 'delete' and 'permanently delete' as terms for two very different things, which is confusing.

Revision history for this message
Tom Harris (tom-harris) wrote :

I really have three main issues with "Deleted Items".

1. It's a bit long and cumbersome (not the end of the world).
2. It's an oxymoron. You can't have a folder of Deleted Items.
3. Attached is the pop-up for when you press shift-delete (to delete a file, rather than move it to the Wastebasket as was). As is correct, the window points out that "If you delete an item, it is permanently lost". This doesn't make any sense when the Wastebasket is called "Deleted Items". So currently the user has two ways to remove a file. They can delete it to the "Deleted Items folder" or they can delete it. Confused yet? Exactly. Wastebasket/Trash wasn't perfect, but at least it kept a distinction between simply moving the file and permanently erasing it.

I've looked through the mailing list archives, and it seems this change was decided on a poll of 18 people (14 voting for "Deleted Items"). Hardly an impressive sample size, and only translators could vote not users. What's more I couldn't find the reasoning behind a change being needed at all.

It's all very well getting bogged down in "but technically it's not a bin it's a folder" because then you you could just rename "file" to "Collection of Binary" and folder to "Collection of collections of binary". Real life metaphors work, that's why they've always been used.

I was amazed to see one person suggest it should be changed to "Deleted Items folder" because they never said "Wastebasket" in real life. I wonder how often they say "Deleted Items" in real life?

Finally, having done a quick search, how many bugs do you reckon are filed against the use of the name Wastebasket? You guessed it, none.

It wasn't broken, so why was it "fixed"?

Revision history for this message
Tom Harris (tom-harris) wrote :

P.S. How about "Dustbin"?

Revision history for this message
Sridhar Dhanapalan (sridhar) wrote :

Tom and Joachim,

Your comments are all valid, and they were raised several months ago on the mailing list, along with many other points which you are likely unaware of. Again, please read our archive [1] and read about our reasoning before re-opening old debates. If you still feel strongly about it, join the list and post a comment there. Please note that I have closed this bug report.

Regards,
Sridhar Dhanapalan
Ubuntu-l10n-en-gb team Administrator

[1] https://lists.ubuntu.com/mailman/listinfo/ubuntu-l10n-eng

Revision history for this message
Joachim Noreiko (jnoreiko) wrote :

I find mailing list archives near-impossible to read.

I've made my point as clearly as I can: "Deleted items" causes the Trash interface to make no sense.
I don't see what reasons can trump that.

It doesn't seem to me like there's much point in me joining the list.

Revision history for this message
Tom Harris (tom-harris) wrote :

I have read the list, as I said above...

"I've looked through the mailing list archives, and it seems this change was decided on a poll of 18 people (14 voting for "Deleted Items"). Hardly an impressive sample size, and only translators could vote not users. What's more I couldn't find the reasoning behind a change being needed at all."

Bugs go on a bugtracker. If I recall correctly this is all forwarded to the list anyway.

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote : Re: [Ubuntu-l10n-eng] [Bug 72304] Re: "Deleted items folder" name doesn't make sense

On Mon, 2006-12-11 at 18:59 +0000, Tom Harris wrote:
> I've looked through the mailing list archives, and it seems this change
> was decided on a poll of 18 people (14 voting for "Deleted Items").
> Hardly an impressive sample size, and only translators could vote not
> users. What's more I couldn't find the reasoning behind a change being
> needed at all.

I ran a forum poll about this issue [0], again not very scientific, but
this is a larger sample size at least.

[0] http://ubuntuforums.org/showthread.php?t=268709
--
Bruce Cowan <https://launchpad.net/people/bruce89>

Revision history for this message
Sridhar Dhanapalan (sridhar) wrote :

Joachim Noreiko wrote:
> I find mailing list archives near-impossible to read.

It is the preferred means of communication for our Team, and Team members are expected to be subscribed to it. You may feel more comfortable interacting with the list through Gmane [1]. Note that some of our older messages may not have been imported into the Gmane archive.

> I've made my point as clearly as I can: "Deleted items" causes the Trash interface to make no sense.
> I don't see what reasons can trump that.

If you don't read the list, how can you expect to be informed of the issues or reasons? We work as a team, and important decisions are discussed on the list. We clearly state this on our Web pages. Important changes should not be decided upon unilaterally.

Bruce Cowan wrote:
> I ran a forum poll about this issue [0], again not very scientific, but this is a larger sample size at least.

The original Team poll was more of an exercise than anything definitive. The majority of the Team members taking part in the discussion had already voted in favour of the change. Also, sample size is not everything. The Team members were actively (or at least passively) taking part in the discussion, and hence were aware of all of the issues involved and also of the mission of the Ubuntu-l10n-En-GB effort. Also, most Team members have been tested for their knowledge and skill in the language and have agreed with the principles of the project. Whether this outweighs the votes of an uninformed crowd is another matter, and I'll leave that decision up to you.

One thing we did agree upon after making this change is that we need better communication with upstream projects, and we have been forging closer relationships with groups like GNOME-UK and KDE-En-GB. The main way in which we differ is that we are at present a Commonwealth translation project, and are not strictly British. This is part of a longer-term plan to eventually have regional variations[2].

There is some inconsistency amongst KDE, GNOME and other projects, so the notion that we altered a single en_GB standard is a fallacy. KDE uses 'wastebin', GNOME uses 'wastebasket', and some applications use 'deleted items'. Instead of creating yet another standard, we chose to adopt an existing one. Ideally, projects upstream should agree upon a single title. In the meanwhile we should provide a degree of consistency with what we already have, rather than inventing something entirely new.

The supposed desktop metaphor is a weak one these days. Software is not restricted to the limited capabilities of an office desk. Users are aware of what it means to 'delete' a file, and most people don't talk about placing a digital file in a rubbish receptacle.

Issues such as these, amongst many others, were raised in the discussion on the ubuntu-l10n-eng mailing list.

Note once again that I have closed this report. It was a conscious decision and is not a bug.

[1] http://dir.gmane.org/gmane.linux.ubuntu.translators.en
[2] http://permalink.gmane.org/gmane.linux.ubuntu.translators.en/529

Revision history for this message
Nick (lupine) wrote : Re: [Ubuntu-l10n-eng] [Bug 72304] Re: "Deleted items folder " name doesn't make sense

On Monday 11 December 2006 12:43, rockbadger wrote:
> On Mon, 2006-12-11 at 12:17 +0000, Ben Goodger wrote:
> > On 11/12/06, Roger Light <email address hidden> wrote:
> > > I'd agree that "Deleted items folder" isn't the best solution,
> > > especially in the example given, but on the other hand as someone who
> > > lives in England I'm pretty certain that I've never once said
> > > "wastebasket". In my opinion the correct term should be "Rubbish bin".
> >
> > Perhaps "bin" at best, but as I have previously covered the metaphor is
> > stale and should be dumped.
>
> Dumped? Now there's an idea. How about renaming it the dump?
>

Why not go all-out and call it Purgatory?

That's what it is, after all - where uncertain files wait until their fate is
decided...

Might offend non-Christians, though ;). Although I'm not offended. Anyone
else?

xF,

...Nick

Revision history for this message
Joachim Noreiko (jnoreiko) wrote :

Sridhar,
Consistency across the desktop is a very good thing to aim for.
Adopting an existing term instead of pulling a new one out of a hat is also a very good idea.

However, the existing term you've picked is not satisfactory.
Users may be aware of what it means to delete a file, but anyone can see that a menu item 'Delete from Deleted Items folder' is just silly.

Your choice of term was by design, but the consequences is has are buggy: hence the bug report.

I apologize for being too hasty initially -- you're right, I should have signed up to the list before diving in to the wiki.
But I must ask you to reopen this and address it. You've still not actually justified the specific choice of 'Deleted Items'.
In changing the 'Trash/Delete' concept to 'Delete/Permanently Delete' you're not translating the interface, you are redesigning it, and that isn't your job.

Revision history for this message
Tom Harris (tom-harris) wrote :

I think Joachim has summed up the problem pretty well in this one sentence:

"In changing the 'Trash/Delete' concept to 'Delete/Permanently Delete' you're not translating the interface, you are redesigning it, and that isn't your job."

The attached icon is a Dustbin, a Wastebasket, heck you could probably find an English-speaker who would call it Trash. But it is definitely NOT a "Deleted Items".

Revision history for this message
Joachim Noreiko (jnoreiko) wrote :

In the Gnome Desktop User Guide, section 'Deleting a File or Folder':

When you delete a file or folder, the file or
folder is not moved to Trash, but is deleted from your
file system immediately. The Delete menu item is
only available if you select the Include a Delete command that bypasses
Trash option in the File Management Preferences
 dialog.

The above help text makes no sense with the current GUI labelling.

Please reopen this bug and address the matter.

Revision history for this message
Adam Lindberg (eproxus) wrote :

Usability is, for me, broken since it takes a lot longer to scan the Nautilus context menu with this name, looking for a way to delete files. Trash or similar is recognized quicker.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers