Ubuntu

Bad translation of translator-credits

Reported by Claude Paroz on 2006-09-25
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
language-pack-fr (Ubuntu)
High
Claude Paroz

Bug Description

Binary package hint: language-pack-fr

The upstream string translator-credits have been superseeded by "Equipe français de traduction d'Ubuntu" in some packages. This should be corrected as it's violates the copyright.
The following packages may be affected in Dapper:
adept_installer
adept
adept_notifier
adept_updater
alacarte
devhelp
gconf-editor
gdebi
gnome-app-install
gnome-netstatus
gnome-nettool
gnome-panel-2.0
gnome-power-manager
gnome-system-monitor
gnome-utils-2.0
gparted
hwdb-client
keep
kio-locate
knetworkmanager
nautilus
NetworkManager
planner
sabayon
skim
superkaramba
systemsettings
totem

Claude Paroz (paroz) wrote :

gnome-panel-2.0, gnome-power-manager and gnome-system-monitor have alredy been corrected

Changed in language-pack-fr:
assignee: nobody → ubuntu-l10n-fr
status: Unconfirmed → Confirmed
Simon Law (sfllaw) on 2006-09-25
Changed in language-pack-fr:
importance: Untriaged → High
Sebastien Bacher (seb128) wrote :

Claude, that's rather a Rosetta issue than a package one, you should better contact rosetta people about it

Sebastien Bacher (seb128) wrote :

what version of Ubuntu do you use and where do you have those mistakes listed?

Changed in language-pack-fr:
status: Confirmed → Needs Info

I don't know if it's a Rosetta issue, but there's at least one bug in Rosetta: the translator-credits field is a single line one, though it should be multi-line.

Sebastien Bacher (seb128) wrote :

What "translator-credits"? The one from the .po from the source package? The one from whatever file installed on the disk? From where do you read it?

Donk (donk) wrote :

I mean "translator credits" in Rosetta, in several cases it's a single line field (input tag) but it should be multi-line (textarea tag)

Sebastien Bacher (seb128) wrote :

if the issue is with rosetta the language-pack-fr ubuntu package is the wrong place to open a bug, opening a rosetta task

Carlos Perelló Marín (carlos) wrote :

the problem that we only render one single line for the translators credit is bug #38984 I'm working on it.

I'm closing Rosetta task because the content having bad credits cannot be fixed by us, it should be handled by French translators.

As a workaround to bug #38984 until my changes land on production, you need to fix it downloading the .po file, fixing it and uploading it again.

Changed in rosetta:
status: Unconfirmed → Rejected
Claude Paroz (paroz) wrote :

Yes, this bug should be handled by French translators. I've prepared a Wiki page for this.
http://doc.ubuntu-fr.org/groupetraducteur/resolutionbug62338

Carlos is right, resolution of bug #38984 will ease correction, but it's not the subject of this bug report.

Claude Paroz (paroz) on 2006-10-16
Changed in language-pack-fr:
assignee: ubuntu-l10n-fr → paroz
status: Needs Info → In Progress
Claude Paroz (paroz) wrote :

Affected strings have been changed in Rosetta. Waiting for release of latest language-pack-fr.

Changed in language-pack-fr:
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

apparently edgy has that issue too.

From gnome-panel by example:
https://launchpad.net/distros/ubuntu/edgy/+source/gnome-panel/+pots/gnome-panel-2.0/fr/46/+translate

Mainteneur :\nChristophe Merlet (RedFox) <email address hidden>\n\nContributeurs :\nChristophe Fergeau <email address hidden>\nBaptiste Mille-Mathias <email address hidden>\nBenoît Dejean <email address hidden>\nL'équipe de traduction d'Ubuntu en français <email address hidden>, 2006

The package .po has that:

"# Vincent Renardias <email address hidden>, 1998-2000.
# Joaquim Fellmann <email address hidden>, 2000.
# maintainer: Christophe Merlet (RedFox) <email address hidden>, 2000-2006.
# Christophe Fergeau <email address hidden>, 2002.
# Baptiste Mille-Mathias <email address hidden>, 2004-2005.
# Benoît Dejean <email address hidden>, 2006.
# Robert-André Mauchin <email address hidden>, 2006.
# Damien Durand <email address hidden>, 2006"

Changed in language-pack-fr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers