"Disc" in en_GB translation should be "Disk"

Bug #68955 reported by Adam McMaster
6
Affects Status Importance Assigned to Milestone
language-pack-en (Ubuntu)
Low
Ubuntu English (United Kingdom) Translators

Bug Description

The en_GB translation refers to the disk usage of portable devices as "Disc Usage". "Disk" and "disc" do not mean the same thing, so this should be changed.

Revision history for this message
Caroline Ford (secretlondon) wrote :

Actually they are alternative spellings:

Disk is a variant spelling of disc, and the preferred US spelling of disc in all senses. It is also the majority spelling in the computing industry - Collins Concise Dictionary, 2001.

Ask Oxford (http://www.askoxford.com/concise_oed/disc?view=uk) says that disk is the US spelling of disc, but that IT uses the US spelling. Presumably similar to the usage of program rather than programme.

As disk rather than disc is used in computing we should use disk - despite the fact that some would say it's an Americanism.

Revision history for this message
Caroline Ford (secretlondon) wrote :

Subscribing en_GB team.

Changed in banshee:
assignee: nobody → ubuntu-l10n-en-gb
Revision history for this message
Sridhar Dhanapalan (sridhar) wrote :

The Ubuntu-l10-en-GB team has decided to follow the conventions set by the GNOME and KDE en_GB teams in this regard. If describing a round object (e.g. a CD or DVD), we use 'disc'. Otherwise, we use 'disk' (e.g. a hard disk drive).

The Cambridge, Collins and Chambers dictionaries refer to 'disk' as being specifically magnetic in nature. Some concessions have been made in en_GB translations to cover spellings which have become commonplace due to US influence over the field of computing.

I'd be hesitant to diverge from upstream. If we wish to make a change, we should discuss it with the GNOME and KDE guys. Otherwise, we should just follow their cue.

Revision history for this message
Adam McMaster (adammc) wrote :

I would just like to point out that in the case of portable MP3 players we are talking about magnetic storage, meaning "disk" is the correct spelling.

Revision history for this message
Nick (lupine) wrote : Re: [Ubuntu-l10n-eng] [Bug 68955] Re: "Disc" in en_GB translation should be "Disk"

On Sunday 29 October 2006 09:19, Adam McMaster wrote:
> I would just like to point out that in the case of portable MP3 players
> we are talking about magnetic storage, meaning "disk" is the correct
> spelling.
>

Surely that depends on the MP3 player? iPod and iRivier, yes, because they
contain a hard drive. All my MP3 players use solid-state storage, however -
and that wasn't magnetic, last time I checked ;).

xF,

...Nick

Revision history for this message
Adam McMaster (adammc) wrote : Re: [Ubuntu-l10n-eng] [Bug 68955] Re: "Disc" in en_GB translation should be "Disk"

On Sun, 2006-10-29 at 12:14 +0000, Nick wrote:
> On Sunday 29 October 2006 09:19, Adam McMaster wrote:
> > I would just like to point out that in the case of portable MP3 players
> > we are talking about magnetic storage, meaning "disk" is the correct
> > spelling.
> >
>
> Surely that depends on the MP3 player? iPod and iRivier, yes, because they
> contain a hard drive. All my MP3 players use solid-state storage, however -
> and that wasn't magnetic, last time I checked ;).
>
Good point. In that case, neither "disc" nor "disk" would be
appropriate.

--
Adam McMaster <email address hidden>

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

I'm not sure if anyone has noticed, but Banshee isn't translatable in Rosetta - https://launchpad.net/distros/ubuntu/edgy/+source/banshee/+translations.

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

I looked at the PO file, and it appears that "disc" is referring to a CD, so this is correct usage of the word. There is one error in the file and that is "Could not transfer files to create disk image.", which should be "Could not transfer files to create disc image."

If you think that using disc is an error, file a bug upstream about it - http://bugzilla.gnome.org/simple-bug-guide.cgi

Revision history for this message
Martin Pitt (pitti) wrote :

This is by no means an issue of langpack-locales, but a per-application translation issue. Can you please elaborate where you saw those wrong translations?

Changed in langpack-locales:
status: Unconfirmed → Needs Info
Revision history for this message
Adam McMaster (adammc) wrote :

It was somewhere in Banshee, though to be honest it was so long ago that I can't remember exactly where.

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

There is one string in the PO file which seems suspect:
#: ../data/banshee.glade.h:3
msgid "Disk Usage:"
msgstr "Disc Usage:"

Is this the one?

Another strange thing about the PO file is that the original text uses "disc" instead of "disk".

Revision history for this message
David Lodge (dave-cirt) wrote : Re: [Ubuntu-l10n-eng] [Bug 68955] Re: "Disc" in en_GB translation should be "Disk"

On Tue, 03 Apr 2007 15:33:56 +0100, Bruce Cowan
<email address hidden> wrote:
> There is one string in the PO file which seems suspect:
> #: ../data/banshee.glade.h:3
> msgid "Disk Usage:"
> msgstr "Disc Usage:"
>
> Is this the one?
>
> Another strange thing about the PO file is that the original text uses
> "disc" instead of "disk".

Is this really a bug - as far as I can tell all instances I can find the
word "Disc" refer to CDs or DVDs, where "disc" is valid.

dave

Revision history for this message
elinux (e-nagi7000) wrote :

hi what you doing now?

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, Ubuntu gets its translations from the translations portion of Launchpad ( http://translations.launchpad.net/ubuntu/), where translation teams work on making Ubuntu more useful in their language. If you want to change a translation in Ubuntu there is the right place.

Changed in language-pack-en:
status: Incomplete → Invalid
Revision history for this message
Colin Watson (cjwatson) wrote :

Jean-Baptiste, there is nowhere to track translation bugs other than language-pack-*. It makes sense for other packages not to accumulate bugs in translations that can only be fixed in Launchpad, so they need to be moved somewhere (and language packs are as good as anywhere), but it does not make sense to close them altogether. They're still bugs.

Changed in language-pack-en:
status: Invalid → Incomplete
Andreas Moog (ampelbein)
Changed in language-pack-en (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed
Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

Is this still a problem, and if so, where?

Revision history for this message
David Planella (dpm) wrote :

Is this still a problem in the English (UK) translation?

Changed in language-pack-en (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Steve Holmes (bouncysteve) wrote :

I think from #10 and #11, this is (potentially) a bug in Banshee's translation, which does not use Launchpad for translation. If it is still a bug then it should be raised upstream against Banshee. It is not a bug in (Ubuntu) UK translation.

Changed in language-pack-en (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers